Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE "Software Renderer In Use" [SOLVED}
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message

Joined: 08 Jul 2007
Posts: 313
Location: Virginia, USA

PostPosted: Sun Dec 01, 2019 9:16 pm    Post subject: KDE "Software Renderer In Use" [SOLVED} Reply with quote

I have built a new desktop computer as my old desktop died...
A problem I am having relates to the graphics board. After a start KDE (with startx), an icon shows in the KDE task manager and if I hover mouse over it I see a bubble with the text: "Software Renderer In Use"/"rendering may be degraded". If I click the icon I get a dialog box with dire warning:
These settings adjust the QtQuick settings used by Plasma. Only adjust if you know what you are doing.

This seems sad... Shouldn't a hardware renderer be in use? Am I alone with this problem? Is this just the state of reality and I can stop pulling out my hair on this?

The graphics board is: Nvidia GeForce GTX 1660
On first efforts I was using the nouveau driver (as I had been with my old computer with an ancient nvidia board). This didn't work at all. IIRC there were messages about "Screen 0" not found or some such. In any case some googling led me to believe that the nouveau driver does not yet support my graphics board. (Maybe added in kernel 5.3?) Faced with that I decided to use the x11-drivers/nvidia-drivers-440.31-r1. As I type this this is the most recent stable. I paid a great deal of attention to disabling support for nouvea and believe I have removed all of the nouveau stuff from the kernel (gentoo-sources-4.19.86). I have not tried gentoo-sources-5.x.y because I use zfs and am not prepared to upgrade to zfs--0.8.x. I will eventually, but not yet.

I have read (and reread and reread ...) every gentoo wiki I can find relating to graphics/X/KDE plus a lot of other posts. I have configured my system according to the various wiki articles and, in fact, the system boots and KDE starts. I am just left with the feeling that something must be amiss because of the "Software Renderer ..." message and because at least some KDE functionality crashes. In particular, the KDE splash screen (which I now have disabled) and a few other apps (although I can't recall which).

glxgears runs and reports 60 fps which I think about matches my monitor refresh rate.

NAShost ~ # glxinfo | grep -i direct
direct rendering: Yes

lspci -v
08:00.0 VGA compatible controller: NVIDIA Corporation TU116 [GeForce GTX 1660] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: Gigabyte Technology Co., Ltd TU116 [GeForce GTX 1660]
        Flags: bus master, fast devsel, latency 0, IRQ 71
        Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Memory at f0000000 (64-bit, prefetchable) [size=32M]
        I/O ports at e000 [size=128]
        [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 3
        Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [78] Express Legacy Endpoint, MSI 00
        Capabilities: [100] Virtual Channel
        Capabilities: [250] Latency Tolerance Reporting
        Capabilities: [258] L1 PM Substates
        Capabilities: [128] Power Budgeting <?>
        Capabilities: [420] Advanced Error Reporting
        Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
        Capabilities: [900] #19
        Capabilities: [bb0] #15
        Kernel driver in use: nvidia
        Kernel modules: nvidia_drm, nvidia

I see this in /var/log/messages
Dec  1 12:25:57 NAShost kernel: [   41.319041] [drm] [nvidia-drm] [GPU ID 0x00000800] Loading driver
Dec  1 12:25:57 NAShost kernel: [   41.319042] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:08:00.0 on minor 0

The modules seem right
NAShost ~ # lsmod | grep nvidia
nvidia_drm             45056  4
nvidia_modeset       1077248  7 nvidia_drm
nvidia              19480576  280 nvidia_modeset

I, of course, will be happy to provide any additional info requested.

Last edited by jfp on Sun Dec 01, 2019 10:25 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 08 Jul 2007
Posts: 313
Location: Virginia, USA

PostPosted: Sun Dec 01, 2019 10:24 pm    Post subject: Reply with quote

Well. I am a bit embarassed...

I found this link: and that provided the answer. I had seen this page during my debugging, but somehow overlooked the answer. I think I was focusing on some other possible solution and it went right past me.
In my case, the first option was "Software" so, duh, software rendering was set.
Once I set both options to "Automatic" (and I rebooted the box), the QtQuck icon disappeared.
Unfortunately, now that the icon is gone I have no idea how to launch the QtQuick dialog so can't check that, in fact, both of the options are now "Automatic", although I assume they are. The link above shows an image of the dialog.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum