Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] X to display Noto-Emoji font
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
mikLhh
n00b
n00b


Joined: 29 Nov 2019
Posts: 2
Location: Linköping, Sweden

PostPosted: Fri Nov 29, 2019 7:46 pm    Post subject: [Solved] X to display Noto-Emoji font Reply with quote

Hello gang!

I'm here trying out Gentoo for the first time, coming from an Arch Linux background. So far I am enjoying the experience, learning oh so many new things! A week ago I decided to migrate my laptop system to Gentoo. On this machine I am running a classic X+i3 setup on a Linux 5.3.12 kernel.

However, I am facing a problem displaying the emojicon characters from the media-fonts/noto-emoji-20190328 package. So far I've noticed this problem manifesting itself through Firefox and my customized i3blocks-config where no emojicon characters are displayed whatsoever.

I'm not quiet sure where to start debuging this problem. I have looked through the output logs of X and i3 in search of any hint but none of them indicate anything (at all really) regarding fonts. I've also tried to install the x11-libs/cairo-9999 package (as suggested here) but reverted back to x11-libs/cairo-1.16.0-r3 when I still faced the same problem. It appears as fontconfig indeed detects the installed font. I am really struggling to find anything related on the internet regarding this issue. Have anyone else faced the same problem, that is emoji characters cannot be displayed what so ever? Down below I leave some snippets I belive to be usedful in finding a solution to this issue. I am wondering, where do I go from here?

Font config detection. Indeed Noto Emoji is detected. From here it all appears to be good.
Code:

 [~] $ fc-match "Noto Color Emoji"
NotoColorEmoji.ttf: "Noto Color Emoji" "Regular"

 [~] $ fc-match -v "Noto Color Emoji"
Pattern has 40 elts (size 48)
   family: "Noto Color Emoji"(s)
   familylang: "en"(s)
   style: "Regular"(s)
   stylelang: "en"(s)
   fullname: "Noto Color Emoji"(s)
   fullnamelang: "en"(s)
   slant: 0(i)(s)
   weight: 80(f)(s)
   width: 100(f)(s)
   size: 104.64(f)(w)
   pixelsize: 109(f)(s)
   spacing: 100(i)(w)
   foundry: "GOOG"(w)
   antialias: False(w)
   hintstyle: 1(i)(w)
   hinting: True(s)
   verticallayout: False(s)
   autohint: False(s)
   globaladvance: True(s)
   file: "/usr/share/fonts/noto-emoji/NotoColorEmoji.ttf"(w)
   index: 0(i)(w)
   outline: False(w)
   scalable: True(w)
   dpi: 75(f)(s)
   scale: 1(f)(s)
   matrix: [0.114679 0; 0 0.114679](w)
   charset:
   0000: 00000000 03ff0409 00000000 00000000 00000000 00004200 00000000 00000000
   0020: 00002000 10000000 00000200 00000000 00000000 00000000 00000000 00000008
   0021: 00000000 02000004 00000000 00000000 03f00000 00000600 00000000 00000000
   0023: 0c000000 00000100 00000000 00000000 00000000 00000000 00008000 070ffe00
   0024: 00000000 00000000 00000000 00000000 00000000 00000000 00000004 00000000
   0025: 00000000 00000000 00000000 00000000 00000000 00400c00 00000001 78000000
   0026: 2132401f 0700c44d 800fff05 c8000169 1afc0000 60030c03 001ac130 27bf0600
   0027: 2054bf24 00180102 00b85090 00000018 00e00000 80010002 00000000 00000000
   0029: 00000000 00300000 00000000 00000000 00000000 00000000 00000000 00000000
   002b: 180000e0 00000000 00210000 00000000 00000000 00000000 00000000 00000000
   0030: 00000000 20010000 00000000 00000000 00000000 00000000 00000000 00000000
   0032: 00000000 00000000 00000000 00000000 02800000 00000000 00000000 00000000
   01f0: 00000010 00000000 00000000 00000000 00000000 00000000 00008000 00000000
   01f1: 00000000 00000000 00000000 c0030000 07fe4000 00000000 00000000 ffffffc0
   01f2: 04000006 07fc8000 00030000 00000000 00000000 00000000 00000000 00000000
   01f3: ffffffff fffffff3 ffffffff ffffffff cecfffff ffffffff ffffffff ffb9ffff
   01f4: ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff bfffffff
   01f5: ffffffff 3fffffff ffff7e00 07f980ff 00613c80 10060130 700e001c fc08810a
   01f6: ffffffff ffffffff 0000ffff 00000000 ffffffff ffffffff 0007f83f 03f91a3f
   01f9: ffff0000 77ffffff ffffffbf f479ffff ffffffff 03ff0007 ffff0007 ffffffff
   0e00: 00000000 03ff0000 00000000 87fffffe 00000000 00000000 00000000 00000000
   0fe4: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00007fe0
   0fe8: 00000000 00ffd000 00000000 00000000 00000000 00000000 00000000 00000000
(w)
   lang: und-zsye(s)
   fontversion: 132186(i)(s)
   capability: "otlayout:DFLT"(w)
   fontformat: "TrueType"(w)
   embeddedbitmap: True(s)
   decorative: False(s)
   namelang: "en"(s)
   prgname: "fc-match"(s)
   postscriptname: "NotoColorEmoji"(w)
   color: True(s)
   symbol: False(s)
   variable: False(s)
   pixelsizefixupfactor: 0.114679(f)(w)


Snippet of .Xresources.
Code:

*.font:   xft:Hack:style=Regular:size=12, \
          xft:Noto Color Emoji:style=Regular:size=12


Fontconfig (eselect) selection (I believe [38] & [39] are of most interest):
Code:

 [~] $ eselect fontconfig list
Available fontconfig .conf files (* is enabled):
  [1]   10-autohint.conf
  [2]   10-hinting-full.conf
  [3]   10-hinting-medium.conf
  [4]   10-hinting-none.conf
  [5]   10-hinting-slight.conf *
  [6]   10-no-sub-pixel.conf
  [7]   10-scale-bitmap-fonts.conf *
  [8]   10-sub-pixel-bgr.conf
  [9]   10-sub-pixel-rgb.conf
  [10]  10-sub-pixel-vbgr.conf
  [11]  10-sub-pixel-vrgb.conf
  [12]  10-unhinted.conf
  [13]  11-lcdfilter-default.conf
  [14]  11-lcdfilter-legacy.conf
  [15]  11-lcdfilter-light.conf
  [16]  20-unhint-small-dejavu-sans.conf
  [17]  20-unhint-small-dejavu-sans-mono.conf
  [18]  20-unhint-small-dejavu-serif.conf
  [19]  20-unhint-small-vera.conf *
  [20]  25-unhint-nonlatin.conf
  [21]  30-metric-aliases.conf *
  [22]  40-nonlatin.conf *
  [23]  42-luxi-mono.conf *
  [24]  45-generic.conf *
  [25]  45-latin.conf *
  [26]  49-sansserif.conf *
  [27]  50-user.conf *
  [28]  51-local.conf *
  [29]  57-dejavu-sans.conf
  [30]  57-dejavu-sans-mono.conf
  [31]  57-dejavu-serif.conf
  [32]  60-generic.conf *
  [33]  60-latin.conf *
  [34]  65-fonts-persian.conf *
  [35]  65-khmer.conf
  [36]  65-nonlatin.conf *
  [37]  69-unifont.conf *
  [38]  70-no-bitmaps.conf
  [39]  70-yes-bitmaps.conf *
  [40]  75-yes-terminus.conf
  [41]  80-delicious.conf *
  [42]  90-synthetic.conf *


A hint might present itself here under Font Path: where the Noto Emoji font file is not located in any of the directories shown.
Code:

 ~ $ xset -q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  225    repeat rate:  25
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600
Colors:
  default colormap:  0x22    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/misc/,/usr/share/fonts/TTF/,/usr/share/fonts/OTF/,/usr/share/fonts/Type1/,/usr/share/fonts/100dpi/,/usr/share/fonts/75dpi/,built-ins
DPMS (Energy Star):
  Standby: 600    Suspend: 600    Off: 600
  DPMS is Enabled
  Monitor is On
Back to top
View user's profile Send private message
mikLhh
n00b
n00b


Joined: 29 Nov 2019
Posts: 2
Location: Linköping, Sweden

PostPosted: Sun Dec 01, 2019 11:18 pm    Post subject: Solved Reply with quote

This problem has now been resolved.

I was able to start displaying the emojis from media-fonts/noto-emoji by adding png to my USE flag and then re-emerging media-libs/freetype.

I'm not yet particularly used to Portage nor the Gentoo way, but wouldn't it make sense to add png as a local/global USE flag to the media-fonts/noto-emoji package webpage, especially if it actually where to be a dependencie for correct usage of this package? Either that or some other sign such that it is clear that it is needed. Perhaps I missed out on this information elsewhere?

Atleast I'm very happy this is all working now.
Yours, mikL
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 15603

PostPosted: Mon Dec 02, 2019 12:17 am    Post subject: Reply with quote

If media-libs/freetype with USE=png is required for media-fonts/noto-emoji to work at all, then yes, this should be enforced in the media-fonts/noto-emoji ebuild with a USE dependency, such as RDEPEND=" media-libs/freetype[png] ". If media-fonts/noto-emoji is partly usable without PNG support, but requires PNG support to be fully usable, then the decision is more complicated.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 6625

PostPosted: Mon Dec 02, 2019 1:04 am    Post subject: Reply with quote

I'd say it's an ebuild bug, yes. The entire point of this font is to provide a set of colour glyphs implemented as PNGs internally.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum