Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Problemi con ASUS UX333FN
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
verito
n00b
n00b


Joined: 07 Apr 2013
Posts: 15

PostPosted: Mon Nov 25, 2019 8:00 pm    Post subject: [RISOLTO] Problemi con ASUS UX333FN Reply with quote

Ciao a tutto il forum.

Ho recentemente acquistato uno Zenbook UX333FN ed ho subito installato gentoo che uso oramai da anni.
Sto pero' avendo dei problemi che non riesco a risolvere:
1) il touchpad non viene rilevato dalkernel,
2) non riesco ad avere in KDE la gestione della risoluzione,
3) i driver per la scheda grafica nvidia producono un grande uso di CPU ad opera di udevd che prende il 100% di un core (sia con i driver nvida che con nouveau).

Il problema 3), non avendo avuto il tempo di studiarlo, al momento lo ho bypassato non caricando i moduli e per ora non me ne occupo, ma gli altri non riesco proprio a risolverli pur avendo cercato possiibli soluzioni.

Provo a dare qualche dettaglio singolarmente nella speranza di ricevere utili suggerimenti.

Problema 1)
ho installato gentoo usando la live di SystemRescueCD e la sessione grafica (xfce) vede il touchpad che quindi e' supportato dal kernel.
tramite libinput il touchpad viene visto come
ELAN 1402:00 04F3:30BF
nella installazione ho provato a compilare nel kernel tutti i moduli necessari a gestirlo (almeno per quello che credo io) ma il touchpad non viene rilevato.
Non ne vedo traccia ne con dmesg, ne in /proc/bus/input/devices, cosi' come non compare nella lista di lspci e di lsusb.
Evidentemente manca qualcosa nel kernel ma non riesco a capire cosa (ammesso che sia questo il problema).

Problema 2)
avendo installato KDE, che usa il driver della scheda grafica intel, quando seleziono
SystemSettings -> Dysplay e Monitor
viene mostrata solo la voce "Compositor" senza avere la parte relativa alla risoluzione grafica o alla selezione dei monitor.
Anche collegando un monitor esterno alla HDMI non o modo di selezionarlo per abilitarlo.

Con un monitor collegato il xrandr riporta
Code:

# xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 293mm x 165mm
   1920x1080     60.03*+  60.01    59.97    59.96    48.01    59.93 
   1680x1050     59.95    59.88 
   1400x1050     59.98 
   1600x900      59.99    59.94    59.95    59.82 
   1280x1024     60.02 
   1400x900      59.96    59.88 
   1280x960      60.00 
   1440x810      60.00    59.97 
   1368x768      59.88    59.85 
   1280x800      59.99    59.97    59.81    59.91 
   1280x720      60.00    59.99    59.86    59.74 
   1024x768      60.04    60.00 
   960x720       60.00 
   928x696       60.05 
   896x672       60.01 
   1024x576      59.95    59.96    59.90    59.82 
   960x600       59.93    60.00 
   960x540       59.96    59.99    59.63    59.82 
   800x600       60.00    60.32    56.25 
   840x525       60.01    59.88 
   864x486       59.92    59.57 
   700x525       59.98 
   800x450       59.95    59.82 
   640x512       60.02 
   700x450       59.96    59.88 
   640x480       60.00    59.94 
   720x405       59.51    58.99 
   684x384       59.88    59.85 
   640x400       59.88    59.98 
   640x360       59.86    59.83    59.84    59.32 
   512x384       60.00 
   512x288       60.00    59.92 
   480x270       59.63    59.82 
   400x300       60.32    56.34 
   432x243       59.92    59.57 
   320x240       60.05 
   360x202       59.51    59.13 
   320x180       59.84    59.32 
HDMI-1 connected (normal left inverted right x axis y axis)
   1920x1080i    60.00 +  60.00    50.00    50.00    59.94 
   1920x1080     24.00    23.98 
   1280x720      60.00    60.00    50.00    50.00    59.94 
   1024x768      75.03    70.07    60.00 
   1440x480i     59.94 
   832x624       74.55 
   800x600       72.19    75.00    60.32    56.25 
   720x576       50.00    50.00 
   720x576i      50.00    50.00 
   720x480       60.00    60.00    59.94    59.94    59.94 
   720x480i      60.00    60.00    59.94    59.94 
   640x480       75.00    72.81    66.67    60.00    59.94    59.94


ma in KDE non vedo il montor collegato.
Forse devo abilitarlo in qualche modo?


Mi scuso per essere stato lungo.
Sto provando a risolvere questi problemi da giorni senza risucirci e non so piu' cosa tentare.

Saro' grato a chiunque riesca a darmi consigli su come affronarli.

Grazie.


Last edited by verito on Wed Nov 27, 2019 11:01 am; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23989
Location: here

PostPosted: Mon Nov 25, 2019 8:13 pm    Post subject: Reply with quote

1) Puoi postare con wgetpaste il file .config del kernel e anche il tuo emerge --info?
2) Come hai installato kde plasma?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
verito
n00b
n00b


Joined: 07 Apr 2013
Posts: 15

PostPosted: Mon Nov 25, 2019 9:26 pm    Post subject: Reply with quote

Innanzitutto grazie per la risposta.

fedeliallalinea wrote:
1) Puoi postare con wgetpaste il file .config del kernel e anche il tuo emerge --info?

.config -> http://dpaste.com/3VX7DRW

emerge --info -> http://dpaste.com/024PE5R

fedeliallalinea wrote:

2) Come hai installato kde plasma?


Non so se ho capito bene la domanda.
Ho installato i pacchetti del desktop base con
Code:

emerge --ask kde-plasma/plasma-desktop

e poi ho aggiunto i pacchetti che mi servivano come powerdevil, systemsettings, plasma-nm, kmix.
Possiiblmente ne manca qualcuno importante per la gestione di screen e monitor, ma non saprei quale.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23989
Location: here

PostPosted: Tue Nov 26, 2019 6:57 am    Post subject: Reply with quote

1) prova anche ad attivare nel kernel le seguenti voci
Code:
       -> Device Drivers 
         -> I2C support 
           -> I2C support (I2C [=y])
             -> I2C Hardware Bus support
                  <M> Synopsys DesignWare Platform
                  <M> Synopsys DesignWare PCI

leggendo un po' nel forum sembra che siano necessari per questo touchpad.

2) Ok hai installato plasma nel modo light e quindi probabilmente ti manca qualche pacchetto probabilmente kde-plasma/kscreen. Comunque se vuoi plasma completo dovresti installare plasma-meta.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
verito
n00b
n00b


Joined: 07 Apr 2013
Posts: 15

PostPosted: Tue Nov 26, 2019 9:20 am    Post subject: Reply with quote

fedeliallalinea wrote:
1) prova anche ad attivare nel kernel le seguenti voci
Code:
       -> Device Drivers 
         -> I2C support 
           -> I2C support (I2C [=y])
             -> I2C Hardware Bus support
                  <M> Synopsys DesignWare Platform
                  <M> Synopsys DesignWare PCI

leggendo un po' nel forum sembra che siano necessari per questo touchpad.

2) Ok hai installato plasma nel modo light e quindi probabilmente ti manca qualche pacchetto probabilmente kde-plasma/kscreen. Comunque se vuoi plasma completo dovresti installare plasma-meta.


Adesso non ho il portatile sotto mano; questa sera provero' attivando nel kernel le voci che mi consigli.
Avevo cercato anche nel forum ma non mi sono accorto di quelle.

L'istallazione di plasma nel modo light e' stata volontaria. Non volevo tutto plasma solo selezionare le cose di mio interesse.
Cosi' facendo mi rendo conto di espormi a rischi di mancanza di pacchetti di cui non mi rendo conto.

Questa sera' provero' entrambi i suggerimenti.

Grazie.
Back to top
View user's profile Send private message
verito
n00b
n00b


Joined: 07 Apr 2013
Posts: 15

PostPosted: Tue Nov 26, 2019 10:17 pm    Post subject: Reply with quote

verito wrote:
fedeliallalinea wrote:
1) prova anche ad attivare nel kernel le seguenti voci
Code:
       -> Device Drivers 
         -> I2C support 
           -> I2C support (I2C [=y])
             -> I2C Hardware Bus support
                  <M> Synopsys DesignWare Platform
                  <M> Synopsys DesignWare PCI

leggendo un po' nel forum sembra che siano necessari per questo touchpad.

2) Ok hai installato plasma nel modo light e quindi probabilmente ti manca qualche pacchetto probabilmente kde-plasma/kscreen. Comunque se vuoi plasma completo dovresti installare plasma-meta.


Adesso non ho il portatile sotto mano; questa sera provero' attivando nel kernel le voci che mi consigli.
Avevo cercato anche nel forum ma non mi sono accorto di quelle.

L'istallazione di plasma nel modo light e' stata volontaria. Non volevo tutto plasma solo selezionare le cose di mio interesse.
Cosi' facendo mi rendo conto di espormi a rischi di mancanza di pacchetti di cui non mi rendo conto.

Questa sera' provero' entrambi i suggerimenti.

Grazie.


Implementati entrambi i suggerimenti con successo.
1) I moduli mancanti sembrano essere proprio quelli indicati; adesso il touchpad funziona
Avevo cercato nel forum ma non avevo trovato l'indicazione di quei moduli. La prossimo volta dovro' essere piu' accorto!

2) Istallando kde-plasma/kscreen il modulo per la configurazione dello schermo in KDE e diventato disponibile.

Adesso mi rimane da risolvere il problema della nvidia con udev, ma intanto posso usare bene il notebook.

Grazie mille fedeliallalinea.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum