Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg.conf for Razer Naga mouse
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Dyspy
n00b
n00b


Joined: 23 Oct 2019
Posts: 7

PostPosted: Thu Nov 14, 2019 6:30 pm    Post subject: Xorg.conf for Razer Naga mouse Reply with quote

I've got plasma up and running on Linux however can't get X11 to find my mouse. It's a Razer Naga molten edition and I understand there isn't full support for Razer peripherals.

So far, I've tried evdev and mouse for the driver, both return the same error, just from the different drivers: Couldn't open /dev/input/event13 (no such file or directory)

As for troubleshooting, once I'm in the terminal, I've cat into dev /input/event13 and event14, these are the two events linked to my mouse. I found this through usb-utils. When I cat into event13, it shows the mouse input. Event14 is the input for the buttons on the side of the mouse. Event14 has been configured as a keyboard and therefore the buttons work as expected however event13 can never be found. I've replaced the device path in xorg.conf with the /dev/input/by-id/ address for event13 as well as creating symbolic links through adding a rule to /etc/init.d/udev directory and using those as pathways.

Every address and link I've used so far produces input through cat however X11 can never find these paths on startup. Udev is set to start at default runtime and I've modified xinitrc to explicitly start udev before xdm so the device pathways are created and assigned before xinit starts yet xorg.0.log still showing it can't find the path. As a test, I set the device path to just /dev and the error changes to cannot open directory(paraphrasing as I'm not looking at it directly right now) so the issue isn't a problem with /dev not mounting. The device pathways exist as soon as sddm start so I feel like this is an issue with runtime service start order but I can't think of anymore ways to elevate udevs priority for the paths to be set.

Any help would be appreciated.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum