Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome-terminal doesn't start
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
malimlun
n00b
n00b


Joined: 14 Nov 2019
Posts: 17

PostPosted: Thu Nov 14, 2019 3:01 pm    Post subject: gnome-terminal doesn't start Reply with quote

Hello everyone,

I am writing here because I have an issue to solve, I tried by myself without any results.

Yesterday I installed gentoo 4.19.82, in 40 hours because I had few problems, a kernel panic, grub, netflex..
anyway everything went well and I decided to use gnome openRC as DE (5 hours compiling..)

It seems quite smooth, fast and every applications start except Terminal, when I click on the icon appears on the upper menu, it loads and doesn't show off.

Gnome-Terminal is installed

emerge --search gnome-terminal

x11-terms/gnome-terminal 3.30.3
x11-terms/mate-terminal 1.22.0

I tried:

sudo dbus-launch gnome-terminal
#Failed to parse arguments: Cannot open display:

I don't know how to fix this problem.

Thank you in advance.
Back to top
View user's profile Send private message
mrbassie
Guru
Guru


Joined: 31 May 2013
Posts: 574

PostPosted: Thu Nov 14, 2019 3:15 pm    Post subject: Re: gnome-terminal doesn't start Reply with quote

malimlun wrote:




Code:
sudo dbus-launch gnome-terminal
#Failed to parse arguments: Cannot open display:


I don't know how to fix this problem.

Thank you in advance.


Where are you entering that command?
Back to top
View user's profile Send private message
malimlun
n00b
n00b


Joined: 14 Nov 2019
Posts: 17

PostPosted: Thu Nov 14, 2019 3:27 pm    Post subject: Reply with quote

I am sorry ,

I forgot to tell you,

I use

tty1 Ctrl-Alt F1

to come back to gnome Alt F7
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22961
Location: here

PostPosted: Thu Nov 14, 2019 3:30 pm    Post subject: Reply with quote

But you want to start only gnome terminal or you want complete gnome as desktop environment?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
mrbassie
Guru
Guru


Joined: 31 May 2013
Posts: 574

PostPosted: Thu Nov 14, 2019 3:31 pm    Post subject: Reply with quote

That wouldn't work anyway.

Try emerging xterm
Code:
# emerge --oneshot x11-terms/xterm


and running
Code:
 gnome-terminal -v


from there.
Back to top
View user's profile Send private message
malimlun
n00b
n00b


Joined: 14 Nov 2019
Posts: 17

PostPosted: Thu Nov 14, 2019 3:42 pm    Post subject: Reply with quote

Thank you for the replies,

with :

Code:
 # emerge --oneshot x11-terms/xterm


installed 7 packages

but

Code:
 gnome-terminal -v
#Failed to parse arguments: Cannot open display: 




to fedeliallalinea : what doesn't mean "a complete gnome as desktop environment" ? Is it not complete my Gnome installation?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22961
Location: here

PostPosted: Thu Nov 14, 2019 3:50 pm    Post subject: Reply with quote

malimlun wrote:
to fedeliallalinea : what doesn't mean "a complete gnome as desktop environment" ? Is it not complete my Gnome installation?

gnome-terminal is only a terminal not all gnome, I don't know what you installed for run gnome but you can find all in related wiki page
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
malimlun
n00b
n00b


Joined: 14 Nov 2019
Posts: 17

PostPosted: Thu Nov 14, 2019 3:52 pm    Post subject: Reply with quote

ok I came back to Gnome

I have now UXTerm and Xterm applications

UXterms once opened says in a pop-up:

Quote:

xterm tried unsuccessfully to use locale en_US.UTF-8
by setting $LANG to "en_US.UTF-8"




Xterm instead starts and works, of course there is not preferences, I cannot set anything , color font ecc

but at least I have a shell!

thank you
Back to top
View user's profile Send private message
malimlun
n00b
n00b


Joined: 14 Nov 2019
Posts: 17

PostPosted: Thu Nov 14, 2019 4:25 pm    Post subject: Reply with quote

fedeliallalinea wrote:

gnome-terminal is only a terminal not all gnome, I don't know what you installed for run gnome but you can find all in related wiki page


Yes I use this wiki gentoo page
because I didn't use systemd

and yes I know Gnome-Terminal is a Terminal and not a Desktop Environment.


I am still trying to open Gnome-Terminal ..
Thank you
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14560

PostPosted: Fri Nov 15, 2019 1:36 am    Post subject: Reply with quote

How exactly are you now trying to start gnome-terminal? Describe it as if you want someone else to sit at your computer and do the steps for you. If you're trying to start it from a context where $DISPLAY is unset, it probably won't work.
Back to top
View user's profile Send private message
Juippisi
Developer
Developer


Joined: 30 Sep 2005
Posts: 381
Location: /home

PostPosted: Fri Nov 15, 2019 6:24 am    Post subject: Reply with quote

First I thought it'd be some xorg-wayland thing, but I remember running to same error after making a switch from systemd to openrc and it was due to locale issue in the end. So try fixing your locales (in env, or term) and try again?

Something like
Code:

LC_ALL=en_US.UTF-8 LANG=en_US.UTF-8 gnome-terminal

in xterm should probably work better, if you have generated en_US.UTF-8 with locale-gen.
Back to top
View user's profile Send private message
malimlun
n00b
n00b


Joined: 14 Nov 2019
Posts: 17

PostPosted: Fri Nov 15, 2019 10:03 am    Post subject: Reply with quote

Juippisi wrote:

Something like
Code:

LC_ALL=en_US.UTF-8 LANG=en_US.UTF-8 gnome-terminal

in xterm should probably work better, if you have generated en_US.UTF-8 with locale-gen.


Code:

user@shell_gentoo ~ $ LC_ALL=en_US.UTF-8 LANG=en_US.UTF-8 gnome-terminal
# _g_io_module_get_default: Found default implementation gvfs (GDaemonVfs) for â
# Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 9


exited status 9, I'm convinced myself too about the locale


Hu wrote:

ow exactly are you now trying to start gnome-terminal? Describe it as if you want someone else to sit at your computer and do the steps for you. If you're trying to start it from a context where $DISPLAY is unset, it probably won't work.


I tried to install again gnome-terminal yesterday,
and I had this:
Terminal exited with status 8
About DISPLAY , I Found a forum that talked about it, but I really don't know how it works and how it can be used.

Right now I'm still trying to start Terminal, without success and I use XTerm.

thank you for your support!
Back to top
View user's profile Send private message
malimlun
n00b
n00b


Joined: 14 Nov 2019
Posts: 17

PostPosted: Fri Nov 15, 2019 10:19 am    Post subject: Reply with quote

Sorry I wasn't looged as root

Quote:

shell_gentoo /home/user # LC_ALL=en_US.UTF-8 LANG=en_US.UTF-8 gnome-terminal
# _g_io_module_get_default: Found default implementation local (GLocalVfs) for â
# Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: The connection is closed
Back to top
View user's profile Send private message
fturco
l33t
l33t


Joined: 08 Dec 2010
Posts: 782
Location: Italy

PostPosted: Fri Nov 15, 2019 11:34 am    Post subject: Reply with quote

Running gnome-terminal as root is not a good idea...
Back to top
View user's profile Send private message
fturco
l33t
l33t


Joined: 08 Dec 2010
Posts: 782
Location: Italy

PostPosted: Fri Nov 15, 2019 11:38 am    Post subject: Reply with quote

Also, how do you start GNOME? Do you use the GDM display manager or something else?
Back to top
View user's profile Send private message
malimlun
n00b
n00b


Joined: 14 Nov 2019
Posts: 17

PostPosted: Fri Nov 15, 2019 11:49 am    Post subject: Reply with quote

fturco wrote:

Also, how do you start GNOME? Do you use the GDM display manager or something else?


when I start the computer --> grub2 --> gentoo --> gnome DE automatically

before install XTerm I used to go on tty1 for the commands and come back in DE with Alt + F7

with XTerm installed , I'm using it in the DE Gnome

and when I click on Terminal, start to load and stop
Back to top
View user's profile Send private message
malimlun
n00b
n00b


Joined: 14 Nov 2019
Posts: 17

PostPosted: Fri Nov 15, 2019 1:18 pm    Post subject: Reply with quote

One question:

when I was installing Gentoo in livecd,
I set a root password with passwd
after
I created an user with adduser, with another password

is it correct? I have a password for root, accessing by the command "su"
I have another password for the user account created. I use it also to log into the DE on start.

I think I did something with the locale, profile or password
Back to top
View user's profile Send private message
fturco
l33t
l33t


Joined: 08 Dec 2010
Posts: 782
Location: Italy

PostPosted: Fri Nov 15, 2019 3:00 pm    Post subject: Reply with quote

Having two different passwords for root and a non-root user is OK. Logging into GNOME as a non-root user is also OK.

Please post the output of the following commands:
Code:
eselect profile show

Code:
locale

Code:
locale -a
Back to top
View user's profile Send private message
malimlun
n00b
n00b


Joined: 14 Nov 2019
Posts: 17

PostPosted: Fri Nov 15, 2019 3:13 pm    Post subject: Reply with quote

Code:

 ~ # eselect profile show
Current /etc/portage/make.profile symlink:
  default/linux/amd64/17.0/desktop/gnome


Code:

 ~ # locale
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=it_IT.UTF-8
LC_TIME=it_IT.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=it_IT.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=it_IT.UTF-8
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT=it_IT.UTF-8
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=



Code:

 ~ # locale -a
C
C.utf8
en_US.utf8
POSIX



I read a forum that said it could be not match the LANG and the LC_NUMERIC this one
Back to top
View user's profile Send private message
fturco
l33t
l33t


Joined: 08 Dec 2010
Posts: 782
Location: Italy

PostPosted: Fri Nov 15, 2019 3:28 pm    Post subject: Reply with quote

What's inside your /etc/env.d/02locale file?

Edit #1: you should also enable the following line in your /etc/locale.gen file:
Code:
it_IT.UTF-8 UTF-8


Edit #2: you should then run the following command (as root):
Code:
locale-gen

You also need to log out from your non-root user and log in into GNOME again.


Last edited by fturco on Fri Nov 15, 2019 3:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
malimlun
n00b
n00b


Joined: 14 Nov 2019
Posts: 17

PostPosted: Fri Nov 15, 2019 3:30 pm    Post subject: Reply with quote

fturco wrote:
What's inside your /etc/env.d/02locale file?




Code:

# Configuration file for eselect
# This file has been automatically generated.
LANG='en_US.UTF-8'
Back to top
View user's profile Send private message
fturco
l33t
l33t


Joined: 08 Dec 2010
Posts: 782
Location: Italy

PostPosted: Fri Nov 15, 2019 3:38 pm    Post subject: Reply with quote

It seems your /etc/env.d/02locale lacks any Italian locales, but the "locale" command still shows them... Where did you configure them?
Back to top
View user's profile Send private message
malimlun
n00b
n00b


Joined: 14 Nov 2019
Posts: 17

PostPosted: Fri Nov 15, 2019 3:44 pm    Post subject: Reply with quote

I don't remember,
few during the installations
few in the settings in Gnome.

Do I add something in the file?
Back to top
View user's profile Send private message
fturco
l33t
l33t


Joined: 08 Dec 2010
Posts: 782
Location: Italy

PostPosted: Fri Nov 15, 2019 4:08 pm    Post subject: Reply with quote

On my system I usually configure my locales directly in /etc/env.d/02locale, but there are no other users on my system.
Do other people use your system besides you? Do they have different language preferences?

Anyway the most important thing in my opinion is adding the Italian locale in /etc/locale.gen (as I wrote before).

In the future, I'd also like to suggest you to write down all commands you issue and all configuration file lines you modify while you're installing and configuring your Gentoo system, especially while you're still learning. This can be very helpful later. You can either choose to write everything down on paper, or use some digital text editor, depending on your preferences.
Back to top
View user's profile Send private message
malimlun
n00b
n00b


Joined: 14 Nov 2019
Posts: 17

PostPosted: Sat Nov 16, 2019 3:38 pm    Post subject: Reply with quote

fturco wrote:
On my system I usually configure my locales directly in /etc/env.d/02locale, but there are no other users on my system.
Do other people use your system besides you? Do they have different language preferences?


No I don't, I'm the only user in this computer.

Quote:

In the future, I'd also like to suggest you to write down all commands you issue and all configuration file lines you modify while you're installing and configuring your Gentoo system, especially while you're still learning. This can be very helpful later. You can either choose to write everything down on paper, or use some digital text editor, depending on your preferences.


Yes, good advice, I did it, I wrote every single command in a .rtf, but when I saw for the first time the desktop environment, I quit write down
commands and spent some time for Terminal

I will try to add that line as you said before.

Thank you
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum