Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
courier-imap-5.0.7 unable to pop with STARTTLS [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
hanj
Veteran
Veteran


Joined: 19 Aug 2003
Posts: 1418

PostPosted: Sun Oct 27, 2019 7:03 pm    Post subject: courier-imap-5.0.7 unable to pop with STARTTLS [SOLVED] Reply with quote

Upgrading from courier-imap-4.18.2 to 5.0.7, I began having problems with pop'ing mail using STARTTLS. Standard SSL port works. Rolling back to 4.18.2 gets me up and running again.

Here are my USE flags.

Code:
[ebuild     U  ] net-mail/courier-imap-5.0.7::gentoo [4.18.2::gentoo] USE="berkdb gdbm -debug -fam -gnutls -ipv6 -libressl (-selinux) -trashquota" 3220 KiB


Any directions/ideas on where to see the problem? When I watch the logs, I see the connection, but never follows up with LOGIN/LOGOUT. So I'm assuming something with TLS.

On my mail client I do see ** Socket error after the SSL/TLS negotiation. No specific errors in the mail.log or messages though.

Thanks!
hanji


UPDATE:
This has been resolved. Need to change ownership to mail:mail on /etc/courier-imap/pop3d.pem and /var/lib/courier-imap/couriersslcache

Details here: https://bugs.gentoo.org/698674
_________________
Server Admin Blog - Uno-Code.com
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum