Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Who is starting wpa_supplicant on wlp3s0?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
lfs0a
n00b
n00b


Joined: 19 Oct 2016
Posts: 72

PostPosted: Thu Oct 24, 2019 2:02 pm    Post subject: [SOLVED]Who is starting wpa_supplicant on wlp3s0? Reply with quote

Code:
 * Bringing up interface wlp3s0
 *   Caching network module dependencies
need dbus
 *   Starting wpa_supplicant on wlp3s0 ...
 *   /etc/wpa_supplicant/wpa_supplicant.conf not found
 [ !! ]
 * ERROR: net.wlp3s0 failed to start


I commemted all lines in /etc/conf.d/net
I deleted /etc/init.d/wpa_supplicant
But when I boot my laptop, I keep getting above message
Who is starting wpa_supplicant on wlp3s0?


Last edited by lfs0a on Thu Oct 24, 2019 4:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
freke
Guru
Guru


Joined: 23 Jan 2003
Posts: 588
Location: Somewhere in Denmark

PostPosted: Thu Oct 24, 2019 2:32 pm    Post subject: Reply with quote

You could try
Code:
grep 'need net' /etc/init.d/*
to see if any of the other services depends on net being started - openrc would then try and start it.
Back to top
View user's profile Send private message
lfs0a
n00b
n00b


Joined: 19 Oct 2016
Posts: 72

PostPosted: Thu Oct 24, 2019 2:53 pm    Post subject: Reply with quote

freke wrote:
You could try
Code:
grep 'need net' /etc/init.d/*
to see if any of the other services depends on net being started - openrc would then try and start it.


Thanks for reply,freke.
I got a net.wlp3s0 in /etc/init.d,
but why would starting wpa_supplicant on wlp3s0?
I didn't configure any wpa_supplicant relative file.
Back to top
View user's profile Send private message
lfs0a
n00b
n00b


Joined: 19 Oct 2016
Posts: 72

PostPosted: Thu Oct 24, 2019 4:27 pm    Post subject: Reply with quote

net-misc/netifrc to blame!
after I uminstalled it,networkmanager works just fine.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum