Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wifi card lost (Realtek8188)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
twoflowers
n00b
n00b


Joined: 22 Sep 2019
Posts: 5

PostPosted: Sun Oct 20, 2019 9:32 am    Post subject: wifi card lost (Realtek8188) Reply with quote

Hello,

I am having problems with my wifi card.
Few hours ago, I used it to emerge/configure some libraries, it was up and running at wls0p4.
This morning I cannot use it with both gentoo or any other system previously configured to use it.

I want believe it has been "turned off", otherwise I have to conclude it is somehow broken.
may you suggest a way to diagnose if my card is still alive?

Thanks.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45448
Location: 56N 3W

PostPosted: Sun Oct 20, 2019 10:48 am    Post subject: Reply with quote

twoflowers,

What does dmesg say about your wifi.
Putting the whole thing on a pastebin site would be good.

Does the kernel still see your WiFi?
It should be listed in
Code:
ifconfig -a

_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
twoflowers
n00b
n00b


Joined: 22 Sep 2019
Posts: 5

PostPosted: Sat Oct 26, 2019 7:10 am    Post subject: Reply with quote

NeddySeagoon, I found that was indeed a kernel issue.
Now I can see my card (with ifconfig -a or ip a)

I see a curious output from dmesg

rtl8188ee: Polling FW ready fail!! REG_MCUFWDL:0x00000006 .
rtl8188ee: Firmware is not ready to run!

and in fact I can't connect to the internet with wlp4s0 (I was used to do this by wpa_supplicant)

easy question: shall I reconfigure/reinstall my kernel?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45448
Location: 56N 3W

PostPosted: Sat Oct 26, 2019 10:24 am    Post subject: Reply with quote

twoflowers,

Has the kernel loaded the firmware?

Code:
rtl8188ee: Polling FW ready fail!! REG_MCUFWDL:0x00000006 .
rtl8188ee: Firmware is not ready to run!

Says the kernel asked the device if it was ready and the device said "No"

That usually means that the device does not appear in
Code:
ifconfig -a
or if it does, it won't work.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum