Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Can't connect to networks with an ath10k card
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
alaah
n00b
n00b


Joined: 29 Sep 2019
Posts: 2

PostPosted: Mon Sep 30, 2019 12:52 pm    Post subject: [SOLVED] Can't connect to networks with an ath10k card Reply with quote

Hi,

I'm unable to get my Atheros card to work. I followed the general wifi instructions and https://wiki.gentoo.org/wiki/Qualcomm_Atheros_QCA6174
The device is visible. Scanning SSIDs works fine. It just can't connect, even to open networks. I installed NetworkManager and it's all the same.
At best I could connect to an open network and lose connection after 1 ping. Honestly, after struggling with this for a long time I may have mixed something up or made a big oversight.

It's not a hardware problem since it works fine on liveUSBs of other distros.

kernel config
daemon.log

Code:
lspci -k

...
01:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)
   Subsystem: AzureWave QCA9377 802.11ac Wireless Network Adapter
   Kernel driver in use: ath10k_pci
   Kernel modules: ath10k_pci

ifconfig -a

enp0s21f0u2: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.42.133  netmask 255.255.255.0  broadcast 192.168.42.255
        inet6 fe80::f1dc:3679:9aac:154f  prefixlen 64  scopeid 0x20<link>
        ether 66:bd:fb:9a:0a:66  txqueuelen 1000  (Ethernet)
        RX packets 42890  bytes 58211605 (55.5 MiB)
        RX errors 60131  dropped 0  overruns 0  frame 10
        TX packets 10146  bytes 1248130 (1.1 MiB)
        TX errors 966  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 5422286  bytes 329409391 (314.1 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 5422286  bytes 329409391 (314.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

sit0: flags=128<NOARP>  mtu 1480
        sit  txqueuelen 1000  (IPv6-in-IPv4)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp1s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether fa:de:cc:d3:3b:f4  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

iw dev wlp1s0 info

Interface wlp1s0
   ifindex 3
   wdev 0x1
   addr fa:de:cc:d3:3b:f4
   type managed
   wiphy 0
   txpower 0.00 dBm

lsmod

Module                  Size  Used by
rndis_host             16384  0
cdc_ether              16384  1 rndis_host
usbnet                 36864  2 rndis_host,cdc_ether
ath10k_pci             53248  0
ath10k_core           548864  1 ath10k_pci
mac80211              782336  1 ath10k_core
ath                    36864  1 ath10k_core
btusb                  49152  0
btrtl                  16384  1 btusb
btbcm                  16384  1 btusb
btintel                20480  1 btusb
x86_pkg_temp_thermal    20480  0
bluetooth             421888  23 btrtl,btintel,btbcm,btusb
ecdh_generic           16384  1 bluetooth
cfg80211              651264  3 ath,mac80211,ath10k_core
efivarfs               16384  1

dmesg | grep firmware

[    1.085669] i915 0000:00:02.0: Direct firmware load for i915/bxt_dmc_ver1_07.bin failed with error -2
[    1.085681] i915 0000:00:02.0: Failed to load DMC firmware i915/bxt_dmc_ver1_07.bin. Disabling runtime power management.
[    1.085690] i915 0000:00:02.0: DMC firmware homepage: https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/i915
[    4.398023] Bluetooth: hci0: QCA: patch rome 0x302 build 0x3e8, firmware rome 0x302 build 0x111
[    4.813418] ath10k_pci 0000:01:00.0: firmware ver WLAN.TF.2.1-00021-QCARMSWP-1 api 6 features wowlan,ignore-otp crc32 42e41877


Last edited by alaah on Mon Sep 30, 2019 2:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44900
Location: 56N 3W

PostPosted: Mon Sep 30, 2019 1:45 pm    Post subject: Reply with quote

alaah,

Code:
Sep 29 20:26:41 gentooaler NetworkManager[2911]: <warn>  [1569781601.1058] sup-iface[0x55cdf5ddf0e0,wlp1s0]: connection disconnected (reason -3)
Sep 29 20:26:41 gentooaler NetworkManager[2911]: <info>  [1569781601.1129] device (wlp1s0): supplicant interface state: completed -> disconnected
Sep 29 20:26:41 gentooaler NetworkManager[2911]: <info>  [1569781601.2115] device (wlp1s0): supplicant interface state: disconnected -> scanning
Sep 29 20:26:46 gentooaler NetworkManager[2911]: <info>  [1569781606.1648] device (wlp1s0): supplicant interface state: scanning -> authenticating
Sep 29 20:26:46 gentooaler NetworkManager[2911]: <info>  [1569781606.1982] device (wlp1s0): supplicant interface state: authenticating -> associating
Sep 29 20:26:46 gentooaler NetworkManager[2911]: <info>  [1569781606.2801] device (wlp1s0): supplicant interface state: associating -> completed
Sep 29 20:26:46 gentooaler NetworkManager[2911]: <warn>  [1569781606.2804] sup-iface[0x55cdf5ddf0e0,wlp1s0]: connection disconnected (reason -3)
Sep 29 20:26:46 gentooaler NetworkManager[2911]: <info>  [1569781606.2891] device (wlp1s0): supplicant interface state: completed -> disconnected
Sep 29 20:26:47 gentooaler NetworkManager[2911]: <info>  [1569781607.3873] device (wlp1s0): supplicant interface state: disconnected -> scanning
Sep 29 20:26:56 gentooaler NetworkManager[2911]: <info>  [1569781616.1220] device (wlp1s0): supplicant interface state: scanning -> authenticating
Sep 29 20:26:56 gentooaler NetworkManager[2911]: <info>  [1569781616.1337] device (wlp1s0): supplicant interface state: authenticating -> associating
Sep 29 20:26:56 gentooaler NetworkManager[2911]: <info>  [1569781616.2340] device (wlp1s0): supplicant interface state: associating -> completed
Sep 29 20:26:56 gentooaler NetworkManager[2911]: <warn>  [1569781616.2437] sup-iface[0x55cdf5ddf0e0,wlp1s0]: connection disconnected (reason -3)


That says its working fine but several network managers are fighting over the interface.
Like the good soldier, wpa_supplicant is obeying the last order, so none of the network managers win and the interface is up and down every few seconds.
reason -3 means that the interface was instructed to disconnect.

FInd all your network managers and remove them from the default runlevel. That's harder than it may seem as several things will manage WiFi if they are configured to.
Reboot. You are aiming for wlp1s0 to not start at boot at all. Rinse and repeat until you get there.
Once that happens, nothing is trying to manage wlp1s0.

Choose exactly one network manager to start.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
alaah
n00b
n00b


Joined: 29 Sep 2019
Posts: 2

PostPosted: Mon Sep 30, 2019 2:53 pm    Post subject: Reply with quote

That did it, thanks a lot
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum