Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Multiple issues with KDE
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message

Joined: 25 Sep 2019
Posts: 22

PostPosted: Wed Sep 25, 2019 4:09 am    Post subject: Multiple issues with KDE Reply with quote

Hello. I'm new to Gentoo and have been playing around with a few VMs to get a feel for it. On one of them, I've done an install of KDE and I'm having a few issues with it. Maybe you guys could help?

I've got a Dell R720 with Debian 10 installed, running KVM and QEMU. The VM in question was configured with Q35 firmware, BIOS boot, and OpenRC, on the stable branch.

1) I've got SDDM configured to start automatically. The Session menu gives 3 options- Plasma, Xsession, and Plasma (Wayland). If I choose Plasma, I'm able to log in. If I choose either of the other two, I see a very brief text output (too fast to read), then the VM goes right back to the SDDM logon screen.

2) Logging into a Plasma session, the default screen resolution is 1024x768. I'm able to change it to 1920x1080, but if I log out, the settings don't persist. Logging back in, I get the default screen resolution.

3) I did a custom kernel configuration, consulting the Gentoo page for configuring a KVM guest. When I run lspci -v, all the devices shown in the output list drivers in use, except for two. Trying to locate the missing drivers, I ran the same command on an Arch VM on the same box and was able to figure out the name of one of the missing drivers. Problem is, when I run make menuconfig on my Gentoo VM and do a search, I can't find it. Another thing I tried was to set the VM to boot into a Debian live CD, then running lspci -v again. The missing drivers didn't show up. So I'm wondering, could it be that the driver that did show up in the Arch VM was due to a newer kernel? Here are the devices in question:

00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller
   Subsystem: Red Hat, Inc. QEMU Virtual Machine
   Flags: fast devsel

(On the Arch VM, it shows the kernel driver as intel_agp. I found a driver named agp_intel and added it to my kernel, but that didn't help.)

07:00.0 PCI bridge: Red Hat, Inc. Device 000e (prog-if 00 [Normal decode])
   Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
   Memory at fc200000 (64-bit, non-prefetchable) [size=256]
   Bus: primary=07, secondary=08, subordinate=08, sec-latency=0
   I/O behind bridge: 0000c000-0000cfff [size=4K]
   Memory behind bridge: fc000000-fc1fffff [size=2M]
   Prefetchable memory behind bridge: None
   Capabilities: [8c] MSI: Enable- Count=1/1 Maskable+ 64bit+
   Capabilities: [84] Power Management version 3
   Capabilities: [48] Express PCI-Express to PCI/PCI-X Bridge, MSI 00
   Capabilities: [40] Hot-plug capable
   Capabilities: [100] Advanced Error Reporting

(This one I haven't been able to identify.)

Any help with any of these issues would be greatly appreciated. Thanks in advance.

[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message

Joined: 25 Sep 2019
Posts: 22

PostPosted: Wed Sep 25, 2019 5:34 am    Post subject: Reply with quote

UPDATE: I set elogind to start at boot and now I'm able to log into a Wayland session. Still no luck on the XSession option from the SDDM logon screen. I added "exec startkde" to my .xinitrc file and if I run startx from a terminal, I get a GUI up and running. Getting closer...

Now I have a different problem regarding my screen resolution. If I log into a Plasma session and set the resolution to 1920x1080, it will go to the new resolution for about a second, then go right back to the default resolution. If I enter a Wayland session and change the resolution, nothing happens.

Any suggestions?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum