Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No Wired Network on New Install.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Bigby
n00b
n00b


Joined: 17 Sep 2019
Posts: 2

PostPosted: Tue Sep 17, 2019 6:18 pm    Post subject: No Wired Network on New Install. Reply with quote

Hi,

I have read all the info written here, and I learned a lot, but i have the same problem
I´ve got no network after the installation of Gentoo

I should have solved that but my problem is the difference between the network card, mine says:

Code:
Ethernet Controller: Raeltek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 07)
Subsystem: Hewlett-Packard Company RTL810xE Express Fast Ethernet controller
Kernel driver in use: r8169
Kernel modules: r8169


Please, I need help with this,

Thanks

[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44053
Location: 56N 3W

PostPosted: Tue Sep 17, 2019 6:39 pm    Post subject: Reply with quote

Bigby,

Welcome to Gentoo. I have split your post to a new topic as you have a different problem.

You system says
Code:
Kernel driver in use: r8169
Kernel modules: r8169
which is correct for your
Code:
RTL810xE PCI Express Fast Ethernet controller
so your kernel is in good shape.

What does
Code:
ifconfig -a
show?
Only the interface names.

Does one of them have an address?
Code:
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.100.20  netmask 255.255.255.0  broadcast 192.168.100.255

That's the inet 192.168.100.20 bit above.

Do you have
Code:
net.<ifname>
in the default runlevel?

Does
Code:
dhcpcd  <ifname>
make it work?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Bigby
n00b
n00b


Joined: 17 Sep 2019
Posts: 2

PostPosted: Tue Sep 17, 2019 7:32 pm    Post subject: No network after install Reply with quote

Hey, thanks for the fast reply

but, after a few investigations I just discovered the problem, for some reason the eth0, is not the one that my PC uses it had another name, and with the Official Handbook I solved the problem by accessing the Internet manually

but for all, thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum