Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nfs-utils-2.4.1-r1 on x86 nfs server borks server
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
figueroa
Guru
Guru


Joined: 14 Aug 2005
Posts: 505
Location: GA-USA

PostPosted: Thu Oct 31, 2019 5:13 pm    Post subject: Reply with quote

nfs-utils-2.4.1-r3 has now gone stable:

Code:
Calculating dependencies  ......... ..... . ...... ..... . ..... .... ... done!
[ebuild     U  ] net-fs/nfs-utils-2.4.1-r3 [2.3.3]


Do I need to mask this version too, or are the problems serving nfs3 to a client actually fixed? 2.4.1-r3 is the only ebuild present in /usr/portage/net-fs/nfs-utils/. I have 2.3.3 in my local repository.
_________________
Andy Figueroa
andy@andyfigueroa.net Working with Unix since 1983.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7367

PostPosted: Fri Nov 01, 2019 10:13 am    Post subject: Reply with quote

It looks clear -r3 is made for that, if you are scared, nothing prevent you from quickpkg nfs-utils before upgrading, but your issue should be fixed by -r3
Quote:
net-fs/nfs-utils: Revbump to fix issue with old kernels and statx

Bumped straight to stable as this seems to affect many users.

Back to top
View user's profile Send private message
figueroa
Guru
Guru


Joined: 14 Aug 2005
Posts: 505
Location: GA-USA

PostPosted: Wed Nov 06, 2019 1:59 am    Post subject: Reply with quote

krinn wrote:
It looks clear -r3 is made for that, if you are scared, nothing prevent you from quickpkg nfs-utils before upgrading, but your issue should be fixed by -r3
Quote:
net-fs/nfs-utils: Revbump to fix issue with old kernels and statx

Bumped straight to stable as this seems to affect many users.

Just a note to confirm that the issue appears to be resolved in current version. I upgraded, and restarted nfs on the server. My client appeared to remained connected; unmounting then remounting was uneventful. Happy.
_________________
Andy Figueroa
andy@andyfigueroa.net Working with Unix since 1983.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7367

PostPosted: Wed Nov 06, 2019 12:24 pm    Post subject: Reply with quote

I think thanks should goes to Lars, he was the one testing and confirming the bug, making the solve comes fast
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum