Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201909-05 ] WebkitGTK+
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2226

PostPosted: Fri Sep 06, 2019 8:26 pm    Post subject: [ GLSA 201909-05 ] WebkitGTK+ Reply with quote

Gentoo Linux Security Advisory

Title: WebkitGTK+: Multiple vulnerabilities (GLSA 201909-05)
Severity: normal
Exploitable: remote
Date: 2019-09-06
Bug(s): #683234, #686216, #693122
ID: 201909-05

Synopsis

Multiple vulnerabilities have been found in WebkitGTK+, the worst
of which could result in the arbitrary execution of code.


Background

WebKitGTK+ is a full-featured port of the WebKit rendering engine,
suitable for projects requiring any kind of web integration, from hybrid
HTML/CSS applications to full-fledged web browsers.


Affected Packages

Package: net-libs/webkit-gtk
Vulnerable: < 2.24.4
Unaffected: >= 2.24.4
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in WebkitGTK+. Please
review the CVE identifiers referenced below for details.


Impact

An attacker, by enticing a user to visit maliciously crafted web
content, may be able to execute arbitrary code or cause memory
corruption.


Workaround

There is no known workaround at this time.

Resolution

All WebkitGTK+ users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-libs/webkit-gtk-2.24.4"
   


References

CVE-2019-11070
CVE-2019-6201
CVE-2019-6251
CVE-2019-7285
CVE-2019-7292
CVE-2019-8503
CVE-2019-8506
CVE-2019-8515
CVE-2019-8518
CVE-2019-8523
CVE-2019-8524
CVE-2019-8535
CVE-2019-8536
CVE-2019-8544
CVE-2019-8551
CVE-2019-8558
CVE-2019-8559
CVE-2019-8563
CVE-2019-8595
CVE-2019-8607
CVE-2019-8615
CVE-2019-8644
CVE-2019-8644
CVE-2019-8649
CVE-2019-8649
CVE-2019-8658
CVE-2019-8658
CVE-2019-8666
CVE-2019-8666
CVE-2019-8669
CVE-2019-8669
CVE-2019-8671
CVE-2019-8671
CVE-2019-8672
CVE-2019-8672
CVE-2019-8673
CVE-2019-8673
CVE-2019-8676
CVE-2019-8676
CVE-2019-8677
CVE-2019-8677
CVE-2019-8678
CVE-2019-8678
CVE-2019-8679
CVE-2019-8679
CVE-2019-8680
CVE-2019-8680
CVE-2019-8681
CVE-2019-8681
CVE-2019-8683
CVE-2019-8683
CVE-2019-8684
CVE-2019-8684
CVE-2019-8686
CVE-2019-8686
CVE-2019-8687
CVE-2019-8687
CVE-2019-8688
CVE-2019-8688
CVE-2019-8689
CVE-2019-8689
CVE-2019-8690
CVE-2019-8690
WSA-2019-0002
WSA-2019-0004
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum