Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No video thumbnails in Caja
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Linx_
n00b
n00b


Joined: 01 Jul 2018
Posts: 27

PostPosted: Thu Sep 05, 2019 11:09 pm    Post subject: No video thumbnails in Caja Reply with quote

I'm running ~amd64 and Mate desktop, and Caja is not generating any thumbnails for video files. Photos and other types of media are generating fine, just not video. Caja preferences --> Preview is set to "always" and "files smaller than 4GB" so that's not it.

I've tried adding all kinds of global USE flags like x264 and x265, but no use flags I've tried seem to make a difference. I've also tried installing totem and some other media players to see if thumbnailing might be part of that functionality, but no. I'm aware of ffmpegthumbnailer, but I'm not sure whether that's what I want here or not, or how exactly to make it work with Caja.

I have a Mint 19.2 Mate installation on my laptop, and Caja generates them fine on there, so I know it can be done. What am I missing to get it to work in Gentoo?
_________________
I occasionally post sober.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23552
Location: here

PostPosted: Fri Sep 06, 2019 6:38 am    Post subject: Reply with quote

Try to install ffmpegthumbnailer and restart caja, see https://github.com/mate-desktop/caja/issues/1009
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Linx_
n00b
n00b


Joined: 01 Jul 2018
Posts: 27

PostPosted: Fri Sep 06, 2019 7:15 pm    Post subject: Reply with quote

I did see that issue on my search, but that seems only to relate to files on network shares. My issue is on local drives, and so I didn't know if it was applicable to me.

I've installed ffmpegthumbnailer, but nothing has changed. Do I have to do something with it to tell Caja that it's there?
_________________
I occasionally post sober.
Back to top
View user's profile Send private message
Juippisi
Developer
Developer


Joined: 30 Sep 2005
Posts: 427
Location: /home

PostPosted: Sat Sep 07, 2019 8:55 am    Post subject: Reply with quote

Try installing totem and, well, ALL gst-plugins pretty much (controllable by gst-plugins-meta).
Back to top
View user's profile Send private message
Linx_
n00b
n00b


Joined: 01 Jul 2018
Posts: 27

PostPosted: Sun Sep 08, 2019 6:29 pm    Post subject: Reply with quote

So it did finally start working, but I have no idea why. I installed ffmpegthumbnailer and created /usr/share/thumbnailers/mate-ffmpegthumbnailer.thumbnailer as follows:

Code:
[Thumbnailer Entry]
TryExec=ffmpegthumbnailer
Exec=ffmpegthumbnailer -i %i -o %o -s %s -f
MimeType=video/jpeg;video/mp4;video/mpeg;video/quicktime;video/x-ms-asf;video/x-ms-wm;video/x-ms-wmv;video/x-msvideo;video/x-flv;video/x-matroska;video/mp2t;video/3gpp;video/webm;video/x-ogm+ogg;


I rebooted and it didn't work, and so I went on with other business hoping for a solution here. Then after a couple of days and a dozen reboots, it suddenly started working for no clear reason. No clue why it took so long.
_________________
I occasionally post sober.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum