Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libreoffice can't display chinese characters on dialog
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
huangfei
n00b
n00b


Joined: 31 Aug 2019
Posts: 5

PostPosted: Sat Aug 31, 2019 8:05 am    Post subject: libreoffice can't display chinese characters on dialog Reply with quote

hello, I have recently built libreoffice version 6.3.0.4 with chinese language support, all user interface displays correctly except popup dialogs, for example, the "about dialog', "find and replace", "daily tips", buttons are ok, just the labels, I tried all kinds of settings and reinstall libreoffice-l10n couple of times but no luck. I suspect the language pack is incomplete but has no clue to verity the problem, has anyone met the same situation before? many thanks for the help.
Back to top
View user's profile Send private message
Prof. Frink
Apprentice
Apprentice


Joined: 07 Jan 2017
Posts: 176

PostPosted: Sun Sep 01, 2019 1:32 pm    Post subject: Reply with quote

Hey,

what is the output of

Code:
L10N="zh-CN" emerge -av app-office/libreoffice-l10n


Frink
Back to top
View user's profile Send private message
huangfei
n00b
n00b


Joined: 31 Aug 2019
Posts: 5

PostPosted: Sun Sep 01, 2019 2:41 pm    Post subject: Reply with quote

Prof. Frink wrote:
Hey,

what is the output of

Code:
L10N="zh-CN" emerge -av app-office/libreoffice-l10n


Frink


thanks for the reply, here's the output with and without the L10N variable:
Code:

huangfei ~]$ sudo L10N="zh_CN" emerge -av libreoffice-l10n

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-office/libreoffice-l10n-6.3.0.4::gentoo  USE="-offlinehelp" L10N="-af -am -ar -as -ast -be -bg -bn -bn-IN -bo -br -brx -bs -ca -ca-valencia -cs -cy -da -de -dgo -dz -el -en -en-GB -en-ZA -eo -es -et -eu -fa -fi -fr -ga -gd -gl -gu -gug -he -hi -hr -hu -id -is -it -ja -ka -kk -km -kmr-Latn -kn -ko -kok -ks -lb -lo -lt -lv -mai -mk -ml -mn -mni -mr -my -nb -ne -nl -nn -nr -nso -oc -om -or -pa -pl -pt -pt-BR -ro -ru -rw -sa -sat -sd -si -sid -sk -sl -sq -sr -sr-Latn -ss -st -sv -sw-TZ -ta -te -tg -th -tn -tr -ts -tt -ug -uk -uz -ve -vi -xh -zh-CN* -zh-TW -zu" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No] n

Quitting.

huangfei ~]$ sudo emerge -av libreoffice-l10n

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-office/libreoffice-l10n-6.3.0.4::gentoo  USE="-offlinehelp" L10N="zh-CN -af -am -ar -as -ast -be -bg -bn -bn-IN -bo -br -brx -bs -ca -ca-valencia -cs -cy -da -de -dgo -dz -el -en -en-GB -en-ZA -eo -es -et -eu -fa -fi -fr -ga -gd -gl -gu -gug -he -hi -hr -hu -id -is -it -ja -ka -kk -km -kmr-Latn -kn -ko -kok -ks -lb -lo -lt -lv -mai -mk -ml -mn -mni -mr -my -nb -ne -nl -nn -nr -nso -oc -om -or -pa -pl -pt -pt-BR -ro -ru -rw -sa -sat -sd -si -sid -sk -sl -sq -sr -sr-Latn -ss -st -sv -sw-TZ -ta -te -tg -th -tn -tr -ts -tt -ug -uk -uz -ve -vi -xh -zh-TW -zu" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No]


I have L10N set in make.conf
Code:

huangfei ~]$ grep L10N /etc/portage/make.conf
L10N="en-US zh-CN"


it's a surprise that "zh_CN" get removed while the variable set as part of the command line.
Back to top
View user's profile Send private message
Prof. Frink
Apprentice
Apprentice


Joined: 07 Jan 2017
Posts: 176

PostPosted: Sun Sep 01, 2019 3:18 pm    Post subject: Reply with quote

Okay, then execute

Code:
sudo L10N="zh_CN" emerge -av libreoffice-l10n


again and answer "yes" on the question. Then it should work.

Or maybe not, I don't know, just try it.
Back to top
View user's profile Send private message
Prof. Frink
Apprentice
Apprentice


Joined: 07 Jan 2017
Posts: 176

PostPosted: Sun Sep 01, 2019 3:29 pm    Post subject: Reply with quote

If the recompilation finishes with no errors, you will still have to change the language in libreoffice-options. But maybe the correct command is

Code:
sudo L10N="zh-CN" emerge -av libreoffice-l10n


If the first one does not work, try this one.
Back to top
View user's profile Send private message
huangfei
n00b
n00b


Joined: 31 Aug 2019
Posts: 5

PostPosted: Sun Sep 01, 2019 4:10 pm    Post subject: Reply with quote

I'm afraid neither of the two commands above works for me, because it makes no difference with the L10N variable set in make.conf.

the problem is that the language pack is just partially working, so confused. I tried to post a screenshot, seems not supported.
Back to top
View user's profile Send private message
Prof. Frink
Apprentice
Apprentice


Joined: 07 Jan 2017
Posts: 176

PostPosted: Sun Sep 01, 2019 4:14 pm    Post subject: Reply with quote

Okay, what is the output of

Code:
sudo L10N="zh-CN" emerge -av libreoffice-l10n


Your make.conf also seems to be configured wrong

Code:
L10N="en-US zh-CN"


On my system there is no language with the flag "en-US". So maybe try to set


Code:
L10N="en zh-CN"


at /etc/portage/make.conf and execute the command above again.
Back to top
View user's profile Send private message
huangfei
n00b
n00b


Joined: 31 Aug 2019
Posts: 5

PostPosted: Sun Sep 01, 2019 4:35 pm    Post subject: Reply with quote

here is the output:
Code:

huangfei ~]$ sudo L10N="zh-CN" emerge -av1 --color=n libreoffice-l10n

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-office/libreoffice-l10n-6.3.0.4::gentoo  USE="-offlinehelp" L10N="zh-CN -af -am -ar -as -ast -be -bg -bn -bn-IN -bo -br -brx -bs -ca -ca-valencia -cs -cy -da -de -dgo -dz -el -en -en-GB -en-ZA -eo -es -et -eu -fa -fi -fr -ga -gd -gl -gu -gug -he -hi -hr -hu -id -is -it -ja -ka -kk -km -kmr-Latn -kn -ko -kok -ks -lb -lo -lt -lv -mai -mk -ml -mn -mni -mr -my -nb -ne -nl -nn -nr -nso -oc -om -or -pa -pl -pt -pt-BR -ro -ru -rw -sa -sat -sd -si -sid -sk -sl -sq -sr -sr-Latn -ss -st -sv -sw-TZ -ta -te -tg -th -tn -tr -ts -tt -ug -uk -uz -ve -vi -xh -zh-TW* -zu" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No]


the variable "en" doesn't affect anything, it's the default and always working, I've tried all combinations including "en", "zh-CN" even "zh-TW" but the problem remains there, now I suspect this is a possible bug with libreoffice, maybe a broken language pack. I'll try to figure out it later, thank you so much for the help so far.
Back to top
View user's profile Send private message
Prof. Frink
Apprentice
Apprentice


Joined: 07 Jan 2017
Posts: 176

PostPosted: Sun Sep 01, 2019 4:43 pm    Post subject: Reply with quote

Did you execute the command and answered "yes"? What did happen? What was the output?

But first of all: You are using a "testing" version of libreoffice-l10n. Please do not do that, unless you know what you are doing. Please downgrade to the stable version and try again to execute

Code:
sudo L10N="zh-CN" emerge -av libreoffice-l10n


If it fails again, pleace post the output of this command.
Back to top
View user's profile Send private message
huangfei
n00b
n00b


Joined: 31 Aug 2019
Posts: 5

PostPosted: Mon Sep 02, 2019 3:13 am    Post subject: Reply with quote

the command itself never failed, just the popup dialogs remains a mass. the testing or unstable problem you mentioned is a good point, I nearly forgot all about that,
I reverted back to the latest stable 6.2.5.2 but no luck, guess I have to rebuild libreoffice as a whole which I won't do it right now because it will take half a day, so I decided
to leave it there and see what will happen next time I upgrade the system.

thanks again
Back to top
View user's profile Send private message
Prof. Frink
Apprentice
Apprentice


Joined: 07 Jan 2017
Posts: 176

PostPosted: Mon Sep 02, 2019 3:15 am    Post subject: Reply with quote

Okay, don't forget to reboot, just to be sure.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum