Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to start kde wayland session[solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
drizzt
Guru
Guru


Joined: 21 Jul 2002
Posts: 416

PostPosted: Sun Jul 28, 2019 3:30 pm    Post subject: How to start kde wayland session[solved] Reply with quote

Hi,
I wanted to try out kde with wayland. I followed some instructions here on the forum setting useflags and recompiling stuff.

After that I am able to start weston from a TTY.

I cannot start plasma from TTY nor a plasma session on wayland from sddm.
Either way the screen just freezes until I kill the kwin_wayland process.

Anybody any idea how to get kde on wayland running ?

Thanks
_________________
People don't have to earn my respect. I offer my respect to them, but be careful to lose my respect...


Last edited by drizzt on Mon Aug 12, 2019 5:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
mike155
Veteran
Veteran


Joined: 17 Sep 2010
Posts: 1731
Location: Frankfurt, Germany

PostPosted: Sun Jul 28, 2019 4:11 pm    Post subject: Reply with quote

Quote:
I cannot start plasma from TTY

  1. How do you start your Plasma session from the TTY console?

    I use
    Code:
    export XDG_SESSION_TYPE=wayland
    export $(dbus-launch) && startplasmacompositor

  2. Which CPU do you have?

  3. Which graphics chip do you have?

  4. Please post the output of
    Code:
    emerge --info

Back to top
View user's profile Send private message
drizzt
Guru
Guru


Joined: 21 Jul 2002
Posts: 416

PostPosted: Mon Jul 29, 2019 5:21 pm    Post subject: Reply with quote

Thanks for the quick reply.

Here's the requested information:
1) How do you start your Plasma session from the TTY console?
First I tried with
Code:
export $(dbus-launch) && startplasmacompositor

Before writing this answer I tried your commands -> same result

2) Which CPU do you have?
AMD RYZEN 2700

3) Which graphics chip do you have?
AMD RX480 4GB

4) Please post the output of
Code:
emerge --info

Code:
Portage 2.3.69 (python 3.6.9-final-0, default/linux/amd64/17.1/desktop/plasma, gcc-9.1.0, glibc-2.29-r3, 5.2.1-gentoo x86_64)
=================================================================
System uname: Linux-5.2.1-gentoo-x86_64-AMD_Ryzen_7_2700_Eight-Core_Processor-with-gentoo-2.6
KiB Mem:    32952228 total,  28488664 free
KiB Swap:   16777212 total,  16777212 free
Timestamp of repository gentoo: Sun, 28 Jul 2019 12:15:01 +0000
Head commit of repository gentoo: a34631e939372cca387bc37edf74f81e54e46bf1
sh bash 5.0_p7
ld GNU ld (Gentoo 2.31.1 p5) 2.31.1
distcc 3.3.2 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          5.0_p7::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.0::gentoo
dev-lang/python:          2.7.16::gentoo, 3.6.9::gentoo
dev-util/cmake:           3.15.1::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.31.1-r4::gentoo, 2.32-r1::gentoo
sys-devel/gcc:            8.2.0-r6::gentoo, 8.3.0-r1::gentoo, 9.1.0-r1::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync15.de.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-max-age: 24
    sync-rsync-extra-opts:
    sync-rsync-verify-jobs: 1

last-hope
    location: /var/lib/layman/last-hope
    sync-type: laymansync
    sync-uri: https://github.com/ercpe/lh-overlay.git
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 Oracle-BCLA-JavaSE MakeMKV-EULA AdobeFlash-11_beta google-chrome AdobeFlash-10.3 AdobeFlash-11.x"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=znver1"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=znver1"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ https://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ https://ftp.halifax.rwth-aachen.de/gentoo/ rsync://ftp.halifax.rwth-aachen.de/gentoo/ rsync://ftp.fau.de/gentoo https://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j15"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="64bit X a52 aac aacplus aacs accessibility acl acpi activities additions aio alsa amd64 apache2 apm archive asf audiofile avcodec avx bash-completion bluetooth bluray branding btrfs bzip2 c++0x cairo cdda cddb cdparanoia cdr cgi cli clucene cmake consolekit crypt css ctype cups curl cvs cxx dar64 dbus declarative dga discid dri dri3 drm dts dvd dvdr egl embedded emboss encode exif extensions extra fam fbcon fbcondecor fbsplash festival ffmpeg filter firefox flac foomaticdb fortran fts3 g3dvl gallium gbm gd gdbm gif git glamor gles gles2 glib gpm graphite graphviz grub gs gtk gtk3 gzip hbci hidpi hwdb hwinfo iconv icq icu id3tag imagemagick imlib inotify ipc jabber java java6 javascript jpeg jpeg2k json kdcraw kde kdepim keymap kipi kontact kpathsea kwallet ladspa lame latex lcms legacy-systray libinput libkms libnotify libtirpc libxml2 lm_sensors logrotate mad matroska mbrola mime mjpeg mmap mng mp3 mp4 mpeg mplayer mtp multilib multimedia musicbrainz mysql mysqli ncurses nls nptl nsplugin odbc offensive ogg ogm opengl openmp opus orc osc oscar pam pango pch pcre pdf pdo phonon php plasma png policykit ppds pulseaudio python python3 qmake qml qt5 qthelp quicktime raster rdesktop readline redeyes samba sasl scanner sdl seccomp secure-delete semantic-desktop sensord server slp smbclient sndfile soap sox speex spell split-usr sql srt sse3 sse4_1 ssl startup-notification subversion svg sysvipc taglib tcpd theora threads tidy tiff tokenizer truetype udev udisks unicode upcall upnp usb vaapi valgrind vdpau virtuoso vnc vorbis wayland webdav webkit widgets wmf wxwidgets x264 x265 xattr xcb xcomposite xine xinerama xinetd xml xmlreader xmlrpc xmlwriter xpm xprint xscreensaver xv xvid xvmc xwayland yaz zip zlib" ABI_X86="32 64" ALSA_CARDS="hda-intel usb-audio" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif so speling status unique_id userdir usertrack vhost_alias worker access compat socache_shmcb authn_core authz_core unixd" APACHE2_MPMS="worker" CALLIGRA_FEATURES="stage words" CAMERAS="directory ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="libinput evdev wacom" KERNEL="linux" L10N="de" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby22 ruby24 ruby25" SANE_BACKENDS="mustek_usb" USERLAND="GNU" VIDEO_CARDS="amdgpu radeonsi radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



What happens is that after running the commands the screen doesn't react to any input. But the machine is not crashed. I can login via ssh and after I kill kwin_wayland I can use the machine normally again.

Thanks for any help
_________________
People don't have to earn my respect. I offer my respect to them, but be careful to lose my respect...
Back to top
View user's profile Send private message
Goverp
l33t
l33t


Joined: 07 Mar 2007
Posts: 729

PostPosted: Mon Jul 29, 2019 7:05 pm    Post subject: Reply with quote

FWIW, I have an older AMD-based setup, with RX570 video card, so similar VIDEO_CARDS setup, Wayland has provided variable operability over the last year or two. Currently starting a Wayland plasma session from sddm gives a grey screen, then the screen powers off; the keyboard is dead, but the system's alive and the power button triggers an ordered shutdown . I've tried kernel 5.2.1, but that's got some regression in the power management that renders it useless, so I've reverted to 5.1.16.

The best Wayland, around 6-12 months ago, was almost usable, except (a) only 1 desktop, not 4, (b) some windows such as akonadi asking for a password appear in the wrong place (c) different font sizes, though Wayland may be handling DPI correctly and X assuming Windows default for all I know, but worst (d) every so often after a few minutes it all locked up. IMHO Wayland isn't ready for production, and the AMDGPU driver developers appear to be trying to support too and increasingly many cards and features, leading to regressions.
_________________
Greybeard
Back to top
View user's profile Send private message
dasPaul
Apprentice
Apprentice


Joined: 14 Feb 2012
Posts: 217
Location: Dresden

PostPosted: Mon Aug 05, 2019 6:27 am    Post subject: Reply with quote

I also tried to start a tty session and failed:

System:
Code:
kde-plasma/plasma-meta-5.15.5
media-libs/mesa-19.0.8


GPU:
Code:
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06) (Skylake)


20-modesetting.conf:
Code:

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "modesetting"
        Driver      "intel"
    Option      "AccelMethod"    "glamor"
    Option      "DRI"            "3"
EndSection


I executet on tty1:
Code:
# XDG_SESSION_TYPE=wayland
# export $(dbus-launch)
# startplasmacompositor


then:
Code:
startplasmacompositor: Starting up...
No backend specified through command line argument, trying auto resolution
...ETERNAL HANG


then CTRL-C:
Code:
startplasmacompositor: Shutting down...
startplasmacompositor: Done.


then a minute later:
Code:
qt.qpa.xcb: could not connect to display :0
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
Available platform plugins are: wayland-org.kde.kwin.qpa, eglfs, minimal, minimalegl, offscreen, wayland-egl, wayland, xcb.


emerge --info:
Code:
Portage 2.3.69 (python 2.7.15-final-0, default/linux/amd64/17.0, gcc-8.3.0, glibc-2.29-r2, 4.19.52-gentoo x86_64)
=================================================================
System uname: Linux-4.19.52-gentoo-x86_64-Intel-R-_Core-TM-_i7-6700K_CPU_@_4.00GHz-with-gentoo-2.6
KiB Mem:    16398336 total,  13237536 free
KiB Swap:    4095996 total,   4095996 free
Timestamp of repository gentoo: Sun, 04 Aug 2019 06:30:01 +0000
Head commit of repository gentoo: c02d2a6502231fb1a1d56ed8808e8a9622bd1113
Head commit of repository brother-overlay: 16f77e7b48b00d3474a25df1a04b91830ac188ba

sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.32 p2) 2.32.0
app-shells/bash:          4.4_p23-r1::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.28.2-r1::gentoo
dev-lang/python:          2.7.15::gentoo, 3.6.5::gentoo
dev-util/cmake:           3.14.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            7.3.0-r3::gentoo, 8.3.0-r1::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.19::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: no
    sync-rsync-extra-opts:
    sync-rsync-verify-max-age: 24

crossdev
    location: /usr/local/portage-crossdev
    masters: gentoo
    priority: 10

bright
    location: /var/lib/layman/bright
    masters: gentoo
    priority: 50

cg
    location: /var/lib/layman/cg
    masters: gentoo
    priority: 50

brother-overlay
    location: /usr/local/portage/brother-overlay
    sync-type: git
    sync-uri: https://github.com/stefan-langenmaier/brother-overlay.git
    masters: gentoo
    priority: 9999

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=skylake -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.6/conf"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=skylake -O2 -pipe"
DISTDIR="/mnt/store/system/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="rsync://ftp-stud.hs-esslingen.de/gentoo/"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en"
MAKEOPTS="-j9"
PKGDIR="/mnt/store/system/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl alsa amd64 berkdb bzip2 cli consolekit crypt cuda cups cxx dbus dri dvb ffmpeg fontconfig fortran gdbm gif glamor gpm hackrf iconv ipv6 jpeg jpeg2k libtirpc mp3 multilib ncurses nls nptl opengl openmp pam pcre png policykit pulseaudio raw readline rtlsdr seccomp split-usr ssl tcpd tiff truetype udev udisks unicode vdpau wayland x264 xattr zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" L10N="de en en-GB" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24" USERLAND="GNU" VIDEO_CARDS="intel i965 nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

_________________
-=human without Windows®=-
sorry for my bad english!
Back to top
View user's profile Send private message
dasPaul
Apprentice
Apprentice


Joined: 14 Feb 2012
Posts: 217
Location: Dresden

PostPosted: Mon Aug 05, 2019 6:37 am    Post subject: Reply with quote

Obviously a nested session works:
Code:
kwin_wayland --xwayland
kwrite --platform wayland

_________________
-=human without Windows®=-
sorry for my bad english!
Back to top
View user's profile Send private message
mike155
Veteran
Veteran


Joined: 17 Sep 2010
Posts: 1731
Location: Frankfurt, Germany

PostPosted: Mon Aug 05, 2019 12:27 pm    Post subject: Reply with quote

dasPaul,

Plasma and Wayland work pretty well and flawlessly on machines with Intel graphics controllers. If it doesn't work on your machine, it probably is a configuration problem, which can be solved. If you want help, please create a new thread and copy your post to this thread.

The TO reported problems on a machine with an AMD graphics controller. I don't know much about AMD graphics controllers, but it seems that his problems are related to AMD graphics drivers. I don't know how to debug or solve that.
Back to top
View user's profile Send private message
dasPaul
Apprentice
Apprentice


Joined: 14 Feb 2012
Posts: 217
Location: Dresden

PostPosted: Mon Aug 05, 2019 12:46 pm    Post subject: Reply with quote

mike155 wrote:
dasPaul,
please create a new thread and copy your post to this thread.


Alright, I'll do that.
_________________
-=human without Windows®=-
sorry for my bad english!
Back to top
View user's profile Send private message
drizzt
Guru
Guru


Joined: 21 Jul 2002
Posts: 416

PostPosted: Tue Aug 06, 2019 5:31 pm    Post subject: Reply with quote

mike155 wrote:
dasPaul,

Plasma and Wayland work pretty well and flawlessly on machines with Intel graphics controllers. If it doesn't work on your machine, it probably is a configuration problem, which can be solved. If you want help, please create a new thread and copy your post to this thread.

The TO reported problems on a machine with an AMD graphics controller. I don't know much about AMD graphics controllers, but it seems that his problems are related to AMD graphics drivers. I don't know how to debug or solve that.


I don't think it is AMD related since I have exactly the same problems as dasPaul reports and weston works flawlessly.

@dasPaul: Maybe you can post a link to the new thread here and I will follow it and see if the solution there works for me, too.
Thanks
_________________
People don't have to earn my respect. I offer my respect to them, but be careful to lose my respect...
Back to top
View user's profile Send private message
dasPaul
Apprentice
Apprentice


Joined: 14 Feb 2012
Posts: 217
Location: Dresden

PostPosted: Tue Aug 06, 2019 6:46 pm    Post subject: Reply with quote

sure:
https://forums.gentoo.org/viewtopic-t-1100306.html
_________________
-=human without Windows®=-
sorry for my bad english!
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2542
Location: Canada

PostPosted: Tue Aug 06, 2019 7:09 pm    Post subject: Reply with quote

dasPaul - why there are two drivers (modesetting and intel) defined in configuration ?
Back to top
View user's profile Send private message
mike155
Veteran
Veteran


Joined: 17 Sep 2010
Posts: 1731
Location: Frankfurt, Germany

PostPosted: Tue Aug 06, 2019 11:47 pm    Post subject: Reply with quote

drizzt wrote:
I don't think it is AMD related since I have exactly the same problems as dasPaul reports and weston works flawlessly.

It could be that drizzt and dasPaul suffer from the same problem. If that is the case, then please accept my apologies for asking dasPaul to create a new thread. drizzt's problem and dasPauls's problem looked different to me.
Back to top
View user's profile Send private message
mike155
Veteran
Veteran


Joined: 17 Sep 2010
Posts: 1731
Location: Frankfurt, Germany

PostPosted: Wed Aug 07, 2019 11:36 pm    Post subject: Reply with quote

drizzt, please look at https://forums.gentoo.org/viewtopic-p-8359822.html#8359822

Does it help on your machine?
Back to top
View user's profile Send private message
drizzt
Guru
Guru


Joined: 21 Jul 2002
Posts: 416

PostPosted: Thu Aug 08, 2019 6:17 pm    Post subject: Reply with quote

mike155 wrote:
drizzt, please look at https://forums.gentoo.org/viewtopic-p-8359822.html#8359822

Does it help on your machine?


I'll try that elogind stuff next week.
I'll report back as soon as possible...

Thanks for your help and patience
_________________
People don't have to earn my respect. I offer my respect to them, but be careful to lose my respect...
Back to top
View user's profile Send private message
drizzt
Guru
Guru


Joined: 21 Jul 2002
Posts: 416

PostPosted: Mon Aug 12, 2019 1:57 pm    Post subject: Reply with quote

mike155 wrote:
drizzt, please look at https://forums.gentoo.org/viewtopic-p-8359822.html#8359822

Does it help on your machine?


Hi,
yes installing elogind and removeing consolekit fixed my problems, too.

Now I can start plasma on wayland as well as plasma on X11.

And it works great.


Thank you for your help.
_________________
People don't have to earn my respect. I offer my respect to them, but be careful to lose my respect...
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1774
Location: United Kingdom

PostPosted: Wed Aug 14, 2019 11:06 am    Post subject: Reply with quote

mike155 wrote:
Quote:
I cannot start plasma from TTY

How do you start your Plasma session from the TTY console?

I use
Code:
export XDG_SESSION_TYPE=wayland
export $(dbus-launch) && startplasmacompositor

I use:
Code:
export $(dbus-launch) && startplasmacompositor

i.e. I don't need to precede it with:
Code:
export XDG_SESSION_TYPE=wayland

The assignment of XDG_SESSION_TYPE is already included in /usr/bin/startplasmacompositor:

Code:
$ head /usr/share/wayland-sessions/plasmawayland.desktop
[Desktop Entry]
Exec=dbus-run-session /usr/bin/startplasmacompositor
TryExec=/usr/bin/startplasmacompositor
DesktopNames=KDE
Name=Plasma
Name[ar]=بلازما
Name[bs]=Plazma
Name[ca]=Plasma
Name[ca@valencia]=Plasma
Name[cs]=Plasma
$ grep XDG_SESSION_TYPE /usr/bin/startplasmacompositor
XDG_SESSION_TYPE=wayland
export XDG_SESSION_TYPE

_________________
Clevo W230SS: amd64 nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 xf86-video-ati. Dual boot Win 7 Pro 64-bit.
OpenRC eudev elogind & KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
jorgicio
n00b
n00b


Joined: 17 Oct 2014
Posts: 47

PostPosted: Mon Nov 18, 2019 11:55 pm    Post subject: Reply with quote

mike155 wrote:
dasPaul,

Plasma and Wayland work pretty well and flawlessly on machines with Intel graphics controllers. If it doesn't work on your machine, it probably is a configuration problem, which can be solved. If you want help, please create a new thread and copy your post to this thread.

The TO reported problems on a machine with an AMD graphics controller. I don't know much about AMD graphics controllers, but it seems that his problems are related to AMD graphics drivers. I don't know how to debug or solve that.


Not so flawlessly. Depending on what Intel drivers do you mean.

I have a Sandybridge chipset with that graphics and sometimes, it hangs out with Wayland and some apps don't work so well or even can't open (like Clementine).

It's known that Wayland and Qt can't get along so well.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum