Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mysterious screen tearing
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
picarica
Apprentice
Apprentice


Joined: 11 Aug 2018
Posts: 198

PostPosted: Mon Aug 05, 2019 1:45 pm    Post subject: mysterious screen tearing Reply with quote

so i am experiencing screen tearing but i see it only in mpv not in glxgears does have have to do something with opengl working but not nvidia ? or vulkna ? or gpu acceleration ?

here are videos

gfycat link watch online

link for download using Firefox send
Back to top
View user's profile Send private message
runningnak3d
n00b
n00b


Joined: 05 Sep 2018
Posts: 61

PostPosted: Mon Aug 05, 2019 9:05 pm    Post subject: Reply with quote

You mention nVidia, but is this a laptop with Optimus?

Also, what display manager are you using?

I had tearing issues for a long time, and I finally solved them today actually....

I use KDE, so I added agates kwin-lowlatency overlay, and I am 100% tear free now.

Also, I use a laptop, and have Optimus, and use Bumblebee / nVidia Xrun so most of the time I am using the Intel GPU. This Xorg conf solved the rest of my tearing issues:

Code:

Section "Device"
    Identifier     "Device0"
    Driver         "intel"
    Option      "AccelMethod"   "uxa"
    Option      "DRI"   "3"
    Option "TearFree" "true"
    Option  "TripleBuffer" "true"
    VendorName     "Intel"
EndSection


Lastly, do you use a USB Displaylink adapter? If so, there is NO getting rid of the tearing while it is plugged in. I am not talking about the new (wish my laptop had it) Alt mode Displayport over USB 3.1 Gen 2 -- I mean the old school adapter that uses the evdi driver, and the closed source DisplayLinkManager.

If it is none of that, it will still be a lot easier to help if you post more info.

-- Brian
Back to top
View user's profile Send private message
picarica
Apprentice
Apprentice


Joined: 11 Aug 2018
Posts: 198

PostPosted: Tue Aug 06, 2019 12:25 am    Post subject: Reply with quote

runningnak3d wrote:
You mention nVidia, but is this a laptop with Optimus?

Also, what display manager are you using?

I had tearing issues for a long time, and I finally solved them today actually....

I use KDE, so I added agates kwin-lowlatency overlay, and I am 100% tear free now.

Also, I use a laptop, and have Optimus, and use Bumblebee / nVidia Xrun so most of the time I am using the Intel GPU. This Xorg conf solved the rest of my tearing issues:

Code:

Section "Device"
    Identifier     "Device0"
    Driver         "intel"
    Option      "AccelMethod"   "uxa"
    Option      "DRI"   "3"
    Option "TearFree" "true"
    Option  "TripleBuffer" "true"
    VendorName     "Intel"
EndSection


Lastly, do you use a USB Displaylink adapter? If so, there is NO getting rid of the tearing while it is plugged in. I am not talking about the new (wish my laptop had it) Alt mode Displayport over USB 3.1 Gen 2 -- I mean the old school adapter that uses the evdi driver, and the closed source DisplayLinkManager.

If it is none of that, it will still be a lot easier to help if you post more info.

-- Brian


first of all i dont use laptop i am on Desktop dispay manager? you mea login screen? that is lightdm if you mean real dsipay manager then it is xorg


and no i use HDMI port from monitor
Back to top
View user's profile Send private message
runningnak3d
n00b
n00b


Joined: 05 Sep 2018
Posts: 61

PostPosted: Tue Aug 06, 2019 12:50 am    Post subject: Reply with quote

For display manager I mean do you use Gnome (mutter), KDE (kwin), Compton or Compiz with XFCE or LXQT, etc, etc.

If you use Gnome you are just going to have to deal with it .. mutter sucks.

-- Brian
Back to top
View user's profile Send private message
picarica
Apprentice
Apprentice


Joined: 11 Aug 2018
Posts: 198

PostPosted: Fri Aug 09, 2019 6:32 am    Post subject: Reply with quote

runningnak3d wrote:
For display manager I mean do you use Gnome (mutter), KDE (kwin), Compton or Compiz with XFCE or LXQT, etc, etc.

If you use Gnome you are just going to have to deal with it .. mutter sucks.

-- Brian


i use compton in XFCE session
Back to top
View user's profile Send private message
gorg86
Tux's lil' helper
Tux's lil' helper


Joined: 20 May 2011
Posts: 147

PostPosted: Sun Aug 11, 2019 10:34 pm    Post subject: Reply with quote

Post your GPU, used graphics driver, xorg.conf, compton config and output of xrandr pls.
Did you set the TearFree or EnablePageFlip option in xorg.conf?
Did you try it without compositing or with "xcompmgr -n"?

I had the weridest problems with Compton back in the day.
Back to top
View user's profile Send private message
picarica
Apprentice
Apprentice


Joined: 11 Aug 2018
Posts: 198

PostPosted: Mon Aug 12, 2019 9:46 pm    Post subject: Reply with quote

gorg86 wrote:
Post your GPU, used graphics driver, xorg.conf, compton config and output of xrandr pls.
Did you set the TearFree or EnablePageFlip option in xorg.conf?
Did you try it without compositing or with "xcompmgr -n"?

I had the weridest problems with Compton back in the day.


GPU: Nvidia GTX 1050 TI
driver x11-drivers/nvidia-drivers-430.40:0/430
here xorg.conf

compton config nonexistent
Code:


Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
   1920x1080     60.00*+  59.94    50.00
   1680x1050     59.95
   1600x900      60.00
   1440x900      59.89
   1280x1024     60.02
   1280x800      59.81
   1280x720      60.00    59.94    50.00
   1024x768      60.00
   800x600       60.32    56.25
   720x576       50.00
   720x480       59.94
   640x480       59.94
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)


i its so annoyinng i am just scrolling around and the tearing ughhh
Back to top
View user's profile Send private message
gorg86
Tux's lil' helper
Tux's lil' helper


Joined: 20 May 2011
Posts: 147

PostPosted: Mon Aug 12, 2019 10:04 pm    Post subject: Reply with quote

Start nvidia-settings and set VSync :)
Make sure nvidia-drivers got installed with the tools useflag.
Compton has two parameters for vsync: --vsync opengl-swc and --vsync-use-glfinish. --vsync opengl-swc gave me the best results when I was using it.
Try doing it with the driver-settings first though.
Back to top
View user's profile Send private message
picarica
Apprentice
Apprentice


Joined: 11 Aug 2018
Posts: 198

PostPosted: Tue Aug 13, 2019 6:40 am    Post subject: Reply with quote

gorg86 wrote:
Start nvidia-settings and set VSync :)
Make sure nvidia-drivers got installed with the tools useflag.
Compton has two parameters for vsync: --vsync opengl-swc and --vsync-use-glfinish. --vsync opengl-swc gave me the best results when I was using it.
Try doing it with the driver-settings first though.


okay first of all thank you for helping
nvidia driver are installed using tools and all the vsync settings in nvidia settin were turned on so i think that was fine

for the compton tho when i try ti open it with your recomended parameter i get this
Code:

vsync_opengl_swc_init(): I'm afraid glXSwapIntervalSGI wouldn't help if you are not using GLX backend. You could try, nonetheless.

does this mean it doesnt work or is it ignore-worthy error ?
Back to top
View user's profile Send private message
gorg86
Tux's lil' helper
Tux's lil' helper


Joined: 20 May 2011
Posts: 147

PostPosted: Tue Aug 13, 2019 11:31 pm    Post subject: Reply with quote

Wait, is that pesky nvidia driver using xrender?
Do a
Code:
cat /var/log/Xorg.0.log | grep -i loadmodule
to find out.
If yes you can try
Code:
compton --backend xrender --vsync opengl

I'd try to get VSync working on the driver level first, setting it with compton might be ugly, especially if you set Vsync in the drivers and compton at the same time, you might get weird framerate issues. I don't use nvidia but I know there are a ton of options.
This article might be helpful to you https://www.techticity.com/howto/how-to-fix-nvidia-vsync-on-linux-with-proprietary-drivers/
Maybe someone who is knowledgeable about the proprietary nvidia driver could help.
Back to top
View user's profile Send private message
picarica
Apprentice
Apprentice


Joined: 11 Aug 2018
Posts: 198

PostPosted: Fri Aug 16, 2019 1:10 pm    Post subject: Reply with quote

gorg86 wrote:
Wait, is that pesky nvidia driver using xrender?
Do a
Code:
cat /var/log/Xorg.0.log | grep -i loadmodule
to find out.
If yes you can try
Code:
compton --backend xrender --vsync opengl

I'd try to get VSync working on the driver level first, setting it with compton might be ugly, especially if you set Vsync in the drivers and compton at the same time, you might get weird framerate issues. I don't use nvidia but I know there are a ton of options.
This article might be helpful to you https://www.techticity.com/howto/how-to-fix-nvidia-vsync-on-linux-with-proprietary-drivers/
Maybe someone who is knowledgeable about the proprietary nvidia driver could help.


cat /var/log/Xorg.0.log | grep -i loadmodule
Code:

 ✘  ~  cat /var/log/Xorg.0.log | grep -i loadmodule
[     9.483] (II) LoadModule: "glx"
[     9.506] (II) LoadModule: "nvidia"
[     9.542] (II) LoadModule: "fb"
[     9.544] (II) LoadModule: "wfb"
[     9.545] (II) LoadModule: "ramdac"
[     9.547] (II) LoadModule: "glxserver_nvidia"
[    10.080] (II) LoadModule: "dri2"
[    10.133] (II) LoadModule: "libinput"


seems like it is , ill try your otpion and let you know if it works, thanks for helping me
Back to top
View user's profile Send private message
neyuru
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2020
Posts: 140

PostPosted: Mon Apr 06, 2020 9:43 pm    Post subject: Reply with quote

I was experiencing screen tearing and also with just scrolling the browser... I've found a solution that may or may not apply to you but I think will help others. This solution involves Firefox only (I am not aware of a solution for any other browser): just re-compile Firefox with the USE flag "hwaccel" in either your make.conf or preferably in your package.use files. My laptop uses an intel HD4000 series graphics and no matter if I used the intel DDX driver or the modesetting one, tearing would always appear on the browser. Now, no tearing appears with either the intel or the modesetting driver when using Firefox. Hope this helps.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum