Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Blank screen on laptop lid opened with lightdm and Xfce
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
alogim
Tux's lil' helper
Tux's lil' helper


Joined: 21 Aug 2015
Posts: 127

PostPosted: Thu Aug 01, 2019 8:07 am    Post subject: Blank screen on laptop lid opened with lightdm and Xfce Reply with quote

I have Xfce and lightdm with light-locker. These are the issues I am facing right now:
  • If I lock my screen with Ctrl + Alt + L, I can unlock it and everything works.
  • If I lock the screen and close the lid, the laptop is not suspended but stays in the lock screen. When I unlock it, the following notification appears: GDBus.Error:org.freedesktop.ConsoleKit.Manager.Error.InsufficientPermission: Not Authorized
  • If I do not lock the screen and close the lid, the laptop is suspended but when I open the lid, a black screen is shown in terminal 7.

I have the following packages:
  • Code:
    x11-misc/lightdm-1.28.0::gentoo was built with the following:
    USE="gnome gtk introspection -audit -qt5 -vala" ABI_X86="(64)"
  • Code:
    x11-misc/light-locker-1.8.0-r1::gentoo was built with the following:
    USE="consolekit dpms gtk3 screensaver upower -elogind -systemd" ABI_X86="(64)"
  • Code:
    x11-misc/lightdm-gtk-greeter-2.0.6::gentoo was built with the following:
    USE="branding (-ayatana)" ABI_X86="(64)"
  • Code:
    sys-apps/accountsservice-0.6.50-r1::gentoo was built with the following:
    USE="consolekit introspection -doc -elogind (-selinux) -systemd" ABI_X86="(64)"
  • Code:
    sys-power/upower-0.99.9-r1::gentoo was built with the following:
    USE="introspection -doc -ios (-selinux)" ABI_X86="(64)"

Can someone help me with this issue?

EDIT: I "fixed" the third point by enabling Lock screen when system is going for sleep option. Now, if I close the lid, the laptop is suspended; however, when I open the lid, I am shown the lock screen and I can unlock it but then again a black screen is shown.

EDIT 2: If I manually suspend the laptop it suspends. But if I switch it back on, it shows a black screen with a message saying I will be redirected to the unlock screen. However, it does not do that. I have to manually go to TTY8 (Ctrl + Alt + F8) and THERE the unlock screen is shown to me and I can unlock it. I also tried re-emerging consolekit with the USE flag pm-utils set, but to no avail.
_________________
Desktop: i5-3570k - 2x4 GB - Sapphire HD 7950 Dual-X - 500 GB WD Caviar Black - Dell SE2717H 27"
Laptop: HP EliteBook 850 G5 - i7-8550U - 1x16GB - Intel UHD 620 - 512 GB Samsung NVMe SSD
Phone: OnePlus 5T - SD835 - 8 GB - Adreno 540 - 128 GB


Last edited by alogim on Thu Aug 01, 2019 11:01 am; edited 2 times in total
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1787
Location: United Kingdom

PostPosted: Thu Aug 01, 2019 8:48 am    Post subject: Reply with quote

I'm not sure, but the following looks similar to what you're seeing:

https://forum.xfce.org/viewtopic.php?id=11807

Is that any help?
_________________
Clevo W230SS: amd64 nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 xf86-video-ati. Dual boot Win 7 Pro 64-bit.
OpenRC eudev elogind & KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
alogim
Tux's lil' helper
Tux's lil' helper


Joined: 21 Aug 2015
Posts: 127

PostPosted: Thu Aug 01, 2019 9:08 am    Post subject: Reply with quote

Fitzcarraldo wrote:
I'm not sure, but the following looks similar to what you're seeing:

https://forum.xfce.org/viewtopic.php?id=11807

Is that any help?
Interesting, but... what is the solution then? I am logged in as normal user, not as root, and I did not start lightdm manually as root.
_________________
Desktop: i5-3570k - 2x4 GB - Sapphire HD 7950 Dual-X - 500 GB WD Caviar Black - Dell SE2717H 27"
Laptop: HP EliteBook 850 G5 - i7-8550U - 1x16GB - Intel UHD 620 - 512 GB Samsung NVMe SSD
Phone: OnePlus 5T - SD835 - 8 GB - Adreno 540 - 128 GB
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum