Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Trouble with keybindings (Terminator, Guake)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
someguynamedmatt
n00b
n00b


Joined: 09 Apr 2019
Posts: 17

PostPosted: Fri Jul 26, 2019 7:59 pm    Post subject: [SOLVED] Trouble with keybindings (Terminator, Guake) Reply with quote

I can't seem to apply certain keybindings in both Terminator and Guake. Typically, I bind Ctrl+\ to hide my terminal window, but it doesn't work in Terminator. And in Guake I get a warning when I try to apply that binding to its respective setting ("A problem happened when trying to apply "Ctrl+\" key"). Because this is happening across different terminals, I think there's some environment issue at play, but I'm not sure where to look.

I know that Ctrl+\ can also be mapped to the SIGQUIT (?) command, but this has worked in the past. Specifically, it seemed to happen when I last upgraded my kernel. I've also tried to sanity check with various other bindings (Alt+/), but that also didn't work (in either terminal).

Running DE: Gnome 2


Last edited by someguynamedmatt on Mon Aug 05, 2019 6:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
someguynamedmatt
n00b
n00b


Joined: 09 Apr 2019
Posts: 17

PostPosted: Mon Aug 05, 2019 6:17 pm    Post subject: Reply with quote

I figured this out after some digging. It's an issue with Wayland and global key bindings, which explains why I was seeing it in both Terminator and Guake. If anyone stumbles on this here's the Arch Wiki page that helped me solve this:

https://wiki.archlinux.org/index.php/Guake#Toggling_Guake_visibility_does_not_work_(Wayland)

My solution was to ditch Terminator completely (maybe this wasn't necessary?) and use Guake as my primary terminal. I set a global keybinding (via Gnome settings) to execute

Code:
guake-toggle


with my specific keybinding and everything is working correctly.

[Moderator edit: added [url] tag. Forum auto-linking does not work when the URL contains parentheses. -Hu]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum