Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] xdm no longer works
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
pygoscelis
Guru
Guru


Joined: 07 Jun 2003
Posts: 390

PostPosted: Sat Jun 29, 2019 4:48 pm    Post subject: [SOLVED] xdm no longer works Reply with quote

Hello community,

after a profile update xdm has stopped working.

At first /etc/init.d/xdm could not find the xdm executable, and told me to emerge xdm package. Which I did.

Now /etc/init.d/xdm prints [ok], but there's no other effect. No desktop environment is started, no messages printed.

How do I get my desktop back?

I tried to run startx manually, but this fails because of bad permissions on /dev/tty0 (huh? why?) It runs as root but I don't want to run X as root!

Solved: the reason is that sddm was missing. It was my display manager all along, but somehow the executable disappeared and I had to emerge the new package x11-misc/sddm to bring it back. Did it exist in a different package and was moved? I don't know.
_________________
!זה הכי, אחי Gentoo


Last edited by pygoscelis on Sat Jun 29, 2019 6:16 pm; edited 2 times in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7480
Location: Austria

PostPosted: Sat Jun 29, 2019 5:16 pm    Post subject: Re: xdm no longer works Reply with quote

pygoscelis wrote:
after a profile update xdm has stopped working.

What profile update?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
pygoscelis
Guru
Guru


Joined: 07 Jun 2003
Posts: 390

PostPosted: Sat Jun 29, 2019 5:27 pm    Post subject: Reply with quote

Frankly I'm not sure what exactly it was. I did an update, turned off the computer and went to a business trip. It was a week ago.

I think it was an update to version 17 of the profile or something like that.

I have found the xdm.log file, deleted it, and tried to start xdm again. The newly created log says that another xdm process with pid XXXX is running. No process with pid XXXX exists when I check this file. XXXX is different every time I try to start xdm.
_________________
!זה הכי, אחי Gentoo
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7480
Location: Austria

PostPosted: Sat Jun 29, 2019 5:32 pm    Post subject: Reply with quote

That's really vague. Don't you think it would be helpful to at least tell us what profile you have now?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
pygoscelis
Guru
Guru


Joined: 07 Jun 2003
Posts: 390

PostPosted: Sat Jun 29, 2019 5:40 pm    Post subject: Reply with quote

Sorry about the vagueness, I could not use the computer with the broken DM to post messages here so I had to run back and forth to a different computer for every little thing. Anyway I was able to solve the problem by looking at /etc/init.d/xdm source. (Use the source, Luke). See updated post.
_________________
!זה הכי, אחי Gentoo
Back to top
View user's profile Send private message
jamapii
Guru
Guru


Joined: 16 Sep 2004
Posts: 580

PostPosted: Fri Jul 26, 2019 4:45 pm    Post subject: Reply with quote

Hope it's not 17.1

read
Code:
eselect news read $(eselect news list|grep "amd64 17.1 profiles are now stable"|cut -b4-5)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum