Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Lumina 1.4.0 fails to build.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3547
Location: Illinois, USA

PostPosted: Thu Jun 27, 2019 2:42 pm    Post subject: [solved] Lumina 1.4.0 fails to build. Reply with quote

This is ~amd64 but since it's in portage I figure it should at least build.

I built with MAKEOPTS="-j1" to isolate the error.

At the final link:
Code:
Project ERROR: Unknown module(s) in QT: dbus
make[3]: *** [Makefile:49: sub-src-lthemeengine-qtplugin-make_first] Error 3
make[3]: Leaving directory '/var/tmp/portage/x11-wm/lumina-1.4.0_p1-r1/work/lumina-1.4.0-p1/src-qt5/core/lumina-theme-engine'
make[2]: *** [Makefile:177: sub-lumina-theme-engine-make_first] Error 2
make[2]: Leaving directory '/var/tmp/portage/x11-wm/lumina-1.4.0_p1-r1/work/lumina-1.4.0-p1/src-qt5/core'
make[1]: *** [Makefile:49: sub-core-make_first] Error 2
make[1]: Leaving directory '/var/tmp/portage/x11-wm/lumina-1.4.0_p1-r1/work/lumina-1.4.0-p1/src-qt5'
make: *** [Makefile:47: sub-src-qt5-make_first] Error 2
 * ERROR: x11-wm/lumina-1.4.0_p1-r1::gentoo failed (compile phase):
 *   emake failed
emerge --info =x11-wm/lumina-1.4.0_p1-r1::gentoo
complete build log
emerge -pqv =x11-wm/lumina-1.4.0_p1-r1::gentoo
The ebuild environment

EDIT: stable lumina-1.3.0_p1 does build


Last edited by Tony0945 on Fri Jun 28, 2019 9:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7480
Location: Austria

PostPosted: Thu Jun 27, 2019 3:17 pm    Post subject: Reply with quote

It would mean the ebuild of 1.4.0 is missing dependency on dev-qt/qtdbus:5.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3547
Location: Illinois, USA

PostPosted: Thu Jun 27, 2019 11:51 pm    Post subject: Reply with quote

I'll file a bug. Thank you.

Adding:
Code:
dev-qt/qtdbus:5
To the common depend list allowed 1.4.0 to build. It will probably work for 1.5.0 as well.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7480
Location: Austria

PostPosted: Fri Jun 28, 2019 2:22 am    Post subject: Reply with quote

Not the only missing dep of this package btw: https://bugs.gentoo.org/645380
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3547
Location: Illinois, USA

PostPosted: Fri Jun 28, 2019 12:49 pm    Post subject: Reply with quote

Filed bug: Bug 688880
Watch for dev to response that it works on his system because he already has qtdbus.

Like he responded to my bug about about the missing session file with "I start with startx, no problem"
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7480
Location: Austria

PostPosted: Sat Jun 29, 2019 2:24 pm    Post subject: Reply with quote

Well, your bug report is missing a build.log (in this case more important than also missing emerge --info), link to forums does not really cut it.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3547
Location: Illinois, USA

PostPosted: Mon Jul 01, 2019 4:38 pm    Post subject: Reply with quote

Tony0945 wrote:
Watch for dev to response that it works on his system because he already has qtdbus.

Like he responded to my bug about about the missing session file with "I start with startx, no problem"

Andrey Grozin has applied both fixes in git, per e-mail I received this morning.

I withdraw my complaint and publicly commend his quick action on the second bug.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum