Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg Error failed to load intel, fbdev, vesa modules.
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
MythKhan
n00b
n00b


Joined: 23 Jun 2019
Posts: 12

PostPosted: Sun Jun 23, 2019 7:47 am    Post subject: Xorg Error failed to load intel, fbdev, vesa modules. Reply with quote

As mentioned, I am attempting to use Xorg in gentoo to run i3 however when using the startx command I receive this log error:

https://imgur.com/a/MCTJxKr

Here is my lspci:

https://imgur.com/a/4txMhhm

Here is my make.conf:

https://imgur.com/a/C6U8TKG

What do I need to change in my kernel or Config to fix this error? I installed Xorg and i3 as mentioned in the wiki.

Any help is appreciated :)
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24341
Location: here

PostPosted: Sun Jun 23, 2019 8:15 am    Post subject: Reply with quote

You can see in relative wiki pages for nouveau or intel
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
MythKhan
n00b
n00b


Joined: 23 Jun 2019
Posts: 12

PostPosted: Sun Jun 23, 2019 8:32 am    Post subject: Reply with quote

In my dell XPS 15 9570 I have both a NVIDIA graphics card and An inbuilt intel one. How might I include both in make.conf?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24341
Location: here

PostPosted: Sun Jun 23, 2019 9:11 am    Post subject: Reply with quote

MythKhan wrote:
In my dell XPS 15 9570 I have both a NVIDIA graphics card and An inbuilt intel one. How might I include both in make.conf?

With nouveau I don't know, in my XPS 9550 I use bumblebee for switch from intel to nvidia with optirun (works but honestly never used). You can follow instructions in the wiki

EDIT: ... and welcome to gentoo forum!
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
MythKhan
n00b
n00b


Joined: 23 Jun 2019
Posts: 12

PostPosted: Sun Jun 23, 2019 9:24 am    Post subject: Reply with quote

I did what you mentioned earlier with the wiki. Only difference is I’m not getting intel error, but I’m still getting the error for fbdev and vesa
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 3428

PostPosted: Sun Jun 23, 2019 9:51 am    Post subject: Reply with quote

MythKhan wrote:
In my dell XPS 15 9570 I have both a NVIDIA graphics card and An inbuilt intel one. How might I include both in make.conf?

/etc/portage/make.conf:
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j8"
CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"
MICROCODE_SIGNATURES="-S"

INPUT_DEVICES="libinput"
VIDEO_CARDS="intel i965 nouveau"


And, setting the driver in /etc/X11/xorg.conf.d/ should suppress those "Error failed to load intel, fbdev, vesa modules" errors in Xorg.0.log
/etc/X11/xorg.conf.d/20-modesetting.conf:
# https://wiki.gentoo.org/wiki/Intel#Modesetting_DDX

Section "Device"
        Identifier  "Intel Graphics"
        Driver      "modesetting"
        Option      "AccelMethod"    "glamor"
#       Option      "DRI"            "3"
EndSection
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45805
Location: 56N 3W

PostPosted: Sun Jun 23, 2019 10:02 am    Post subject: Reply with quote

MythKhan,

Intel/nVidia pairing like you have come in two sorts.
By far the most common is the Optimus graphics system where only the Intel GPU is connected to the display. but both can draw in the pixel buffer.
Much rarer, is two separate graphics system.

It matters for your Xorg setup.

Your Xorg log shows
Code:
(EE) open /dev/dri/card0: Ne such file or directory
That points to a bit missing in your kernel.

Determine if you have an Optimus graphics system or not.
Follow the Optimus page on the wiki if you do.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 3428

PostPosted: Sun Jun 23, 2019 10:22 am    Post subject: Reply with quote

NeddySeagoon wrote:
By far the most common is the Optimus graphics system where only the Intel GPU is connected to the display. but both can draw in the pixel buffer.
Much rarer, is two separate graphics system.

How to clearly detect if the system is Optimus or not?
Not clear to me if this is one ore not.
lspci -k | grep -i -e vga -e nvidia:
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108GLM [NVS 5200M] (rev a1)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45805
Location: 56N 3W

PostPosted: Sun Jun 23, 2019 1:29 pm    Post subject: Reply with quote

charles17,

There isn't a good way. Read the system specification is safe.

The ugly way is to attempt to use the nVidia card alone with Xorg and notice that you only get a blank screen.
Code:
startx;  sleep 30 && killall X
should let you recover without pulling the power.

That should startx, wait 30 seconds then kill Xorg.
That's plenty of time to observe the blank screen and for Xorg to write its log.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 3428

PostPosted: Sun Jun 23, 2019 2:44 pm    Post subject: Reply with quote

NeddySeagoon wrote:
There isn't a good way. Read the system specification is safe.

Got it. Dell Latitude laptops have the BIOS option Enable Optimus. It's always been enabled and I didn't care. So it is one of the next things I will try.
Thnaks for the hint.
Back to top
View user's profile Send private message
MythKhan
n00b
n00b


Joined: 23 Jun 2019
Posts: 12

PostPosted: Mon Jun 24, 2019 7:30 am    Post subject: Reply with quote

I tried again, it gets the nvidia graphics card but no devices or screens. Here’s the log:
https://imgur.com/a/0m27qUN
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 3428

PostPosted: Mon Jun 24, 2019 7:58 am    Post subject: Reply with quote

MythKhan wrote:
I tried again, it gets the nvidia graphics card but no devices or screens. Here’s the log:
https://imgur.com/a/0m27qUN
Could you please also wgetpaste your output of dmesg?
Back to top
View user's profile Send private message
MythKhan
n00b
n00b


Joined: 23 Jun 2019
Posts: 12

PostPosted: Mon Jun 24, 2019 9:02 am    Post subject: Reply with quote

Here it is:
http://dpaste.com/0S3W9JB
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45805
Location: 56N 3W

PostPosted: Mon Jun 24, 2019 9:12 am    Post subject: Reply with quote

MythKhan,

Your system is neither Intel nor nVidia. Its Optimus.
You can use the Intel video driver alone.
You can also use the Intel video chip to refresh the screen while the nVidia GPU draws in the pixel buffer. That's Optimus
You cannot use the nVidia GPU alone, which is what your image shows you ace trying to do.

The "No Devices Detected" means that nvidia-drivers-430.26 does not support your GPU or that something else has already grabbed it.

You also have a /etc/X11/xorg.conf file. That may or may not be a good thing.

Make friends with wgetpast and pastebin the following:-
The output of dmesg
The output of emerge --info
Your kernel .config
Your /etc/X11/xorg.conf
Your /var/log/Xorg.0.log

None of those will fit in a post.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
MythKhan
n00b
n00b


Joined: 23 Jun 2019
Posts: 12

PostPosted: Mon Jun 24, 2019 9:34 am    Post subject: Reply with quote

The output of dmesg

http://dpaste.com/0S3W9JB

Output of emerge —info:

http://dpaste.com/3B2HF64

Output of .config

http://dpaste.com/2C7XA7X

Output of /etc/X11/Xorg.conf

http://dpaste.com/24AV47M

Output of /var/log/Xorg.0.log

http://dpaste.com/1YGPJFP
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45805
Location: 56N 3W

PostPosted: Mon Jun 24, 2019 10:10 am    Post subject: Reply with quote

MythKhan,

emerge --info looks OK. In particular, your VIDEO_CARDS.

dmesg says that your runnig kernel was built on Thu Jun 20 02:51:05 UTC 2019
Also its missing any signs of intelfb. You are using the efifb. I would nave expected intelfb to be in use and the nvidia kernel module to load.
Both are missing.

You have CONFIG_DRM_I915=y in your kernel, so we have a contradiction.

I suspect that you are not running the kernel that belongs to that configuration because
a) the kernel was made on Thursday, this is Monday and you have tried several things.
b) CONFIG_DRM_I915=y gets you intelfb in dmesg and its missing.

You must remove nouveau support from your kernel. At least, you can have nouveau or nvidia-drivers but not both.

Some things to check.
i) Did you mount /boot to install your new kernel(s)
ii) Did you update grub.cfg, so it knows about a new kernel
iii) Are you choosing the correct kernel from the grub menu - it may be hidden in the advanced submenu.
iv) Something else.

Nothing else matters until the kernel is correct and intelfb appears in dmesg.

However, there is more. Your /etc/X11/xorg.conf will prevent Xorg ever working. It tries to use the nvidia GPU alone. Remove it.
Its mostly obsolete. You will need an Optimus xorg.conf, which only contains a few lines.

Once your kernel is correct, with no /etc/X11/xorg.conf, Xorg should start using only the Intel GPU. You will get a USA keymap, as that's the default.
That's a major step forward.

If you remove /etc/X11/xorg.conf and boot the kernel that belongs to the .config you posted, I would expect Xorg to start.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
MythKhan
n00b
n00b


Joined: 23 Jun 2019
Posts: 12

PostPosted: Mon Jun 24, 2019 10:56 am    Post subject: Reply with quote

I removed the /etc/X11/Xorg.conf file and removed the nouveau support in the kernel and now I get this xlog:

http://dpaste.com/38JV35J

I) yes
ii/iii) I am using efibootmgr not grub and yes I am moving the kernel file like mentioned in the efi stub wiki page here:

https://wiki.gentoo.org/wiki/EFI_stub_kernel

iv) should I add anything to the kernel?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45805
Location: 56N 3W

PostPosted: Mon Jun 24, 2019 11:36 am    Post subject: Reply with quote

MythKhan,

The top of your log says
Code:
[  9110.566] Build Operating System: Linux 4.19.52-gentoo x86_64 Gentoo
[  9110.567] Current Operating System: Linux livecd 4.19.52-gentoo #1 SMP Thu Jun 20 02:51:05 UTC 2019 x86_64

which suggests you are using the liveCD with a kernel dated Thu Jun 20 02:51:05 UTC 2019.

This kernel does not support DRM at all as you get
Code:
[  9110.587] (EE) open /dev/dri/card0: No such file or directory


With your /etc/X11/Xorg.conf gone, there is something in /etc/X11/xorg.conf.d/* choosing a video driver as Xorg goes straight to the modesetting driver.
Find that and comment it out. You will want modesetting for Optimus but lets get a picture first.

There should be a list of drivers that suit your hardware in the log and Xorg should try them in order.

I suspect you booted the CD to make your post, then didn't reboot to run your own kernel.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
MythKhan
n00b
n00b


Joined: 23 Jun 2019
Posts: 12

PostPosted: Mon Jun 24, 2019 11:54 am    Post subject: Reply with quote

I got rid of that text in the other conf.d file. Rebooted and just booted to the console.

Went back into the liveCD and did startx and now I get black screen with this different error in the log:

http://dpaste.com/146CBVX

Apparently can’t find the driver. How can I install it?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45805
Location: 56N 3W

PostPosted: Mon Jun 24, 2019 12:42 pm    Post subject: Reply with quote

MythKhan,

Don't go back to the liveCD. Use your own kernel.

Your list of drivers is
Code:
[    59.417] (==) Matched intel as autoconfigured driver 0
[    59.417] (==) Matched modesetting as autoconfigured driver 1
[    59.417] (==) Matched fbdev as autoconfigured driver 2
[    59.417] (==) Matched vesa as autoconfigured driver 3


You don't have fbdev or vesa installed as they are not in your VIDEO_CARDS
Both intel and modesetting require /dev/dri/card0 which is not provided by the liveCD kernel.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
MythKhan
n00b
n00b


Joined: 23 Jun 2019
Posts: 12

PostPosted: Mon Jun 24, 2019 1:03 pm    Post subject: Reply with quote

Ah ok. When I use startx without liveCD it lets me select a few settings before showing a black screen with an error in the bottom right saying:
Code:
Error: status_command not found or is missing a library dependency(exit 127)



Maybe if I had been using startx without liveCD this whole time I would have solved it by now
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45805
Location: 56N 3W

PostPosted: Mon Jun 24, 2019 1:39 pm    Post subject: Reply with quote

MythKhan,

Please pastebin the /var/log/Xorg.0.log file as it is now.
It will be overwritten if you try to startx again. Make a copy and post the copy if you need to.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
xtasquee
n00b
n00b


Joined: 17 Jun 2019
Posts: 5

PostPosted: Tue Jun 25, 2019 1:29 pm    Post subject: Reply with quote

my setup is different. newer laptop and i'm using the proprietary driver, but the configuration should still be similar.

for your kernel, i recommend just going through the intel and nouveau wiki pages and adding any relevent options for either.

as for the 'no screens found' error when starting the x server... you have to make a file at /etc/X11/xorg.conf.d/00_optimus.conf (name it whatever you like) that looks something like this:

Code:
Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nouveau"
    Inactive "intel"
EndSection

Section "Device"
    Identifier  "nouveau"
    Driver      "nouveau"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "nouveau"
    Device "nouveau"
EndSection

Section "Device"
    Identifier  "intel"
    Driver      "intel"
    BusID       "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection



and in your ~/.xinitrc, you have to add this:
Code:
xrandr --setprovideroutputsource Intel nouveau
xrandr --auto


if not, you will get a black screen, because the discrete gpu isn't attached to the display. all the rendering done by it is passed to the integrated gpu.

edit: also, if you'd prefer to use the kernel driver, you could replace any mention of intel drivers above with "modesetting" and just use "VIDEO_CARDS="i965 nouveau". anything that requires acceleration should be rendered by the discrete card anyway.
Back to top
View user's profile Send private message
MythKhan
n00b
n00b


Joined: 23 Jun 2019
Posts: 12

PostPosted: Wed Jun 26, 2019 6:53 am    Post subject: Reply with quote

I configured what you told me to. It registers the intel and nvidia cards now however it presents this error in the Xorg log.

https://imgur.com/a/4Xkrmjb


Here is my 00_optimus conf file:

https://imgur.com/a/QAgUKvK

Here is my make.conf:

https://imgur.com/a/Nw5Rwr0

It seems it’s using the i9615 in the Xorg error rather than i965.


Sorry I couldn’t paste the output, I don’t have internet on the system yet.


Last edited by MythKhan on Wed Jun 26, 2019 7:59 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45805
Location: 56N 3W

PostPosted: Wed Jun 26, 2019 7:19 am    Post subject: Reply with quote

MythKhan,

We need the entire Xorg log.

I would prefur to make Intel or modesetting work alone, then add in nvidia. Keep it simple. Build on what you know works.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum