Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome-terminal WARNING: terminal is not fully [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1164
Location: Tri-Cities, WA USA

PostPosted: Sat Jun 01, 2019 9:07 pm    Post subject: gnome-terminal WARNING: terminal is not fully [solved] Reply with quote

I'm running Gentoo with gnome3 and systemd on a tower.

If I use gnome-terminal (3.30.3) I get the following error with 'less' and 'man'
Code:

WARNING: terminal is not fully functional


- If I use xterm on the system all is fine.

- If I ssh from a Debian 9.9 machine using gnome I get the SAME WARNING.

- If I ssh from my Gentoo laptop using xfce4 I get the SAME ERROR.

- If I ssh from my Gentoo laptop with no desktop environment. NO WARNING.

- If I ssh from a Raspberry Pi NO ERROR. 'less' and 'man' work fine. NO WARNING

gnome-ternimal is not fully functional on the tower.

? ANY IDEAS ?
_________________
Without diversity there can be no evolution:)


Last edited by cwc on Wed Jun 12, 2019 11:25 am; edited 1 time in total
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2480
Location: Frankfurt, Germany

PostPosted: Sat Jun 01, 2019 9:40 pm    Post subject: Reply with quote

I can easily reproduce this warning message if I set the TERM environment variable to an invalid value:
Code:
$ export | grep TERM
declare -x TERM="xterm-256color"

$ man ls   # works fine

$ export TERM="xghjgxgjghx"     # invalid value, this terminal emulation doesn't exist
$ man ls   # WARNING: terminal is not fully functional

$ export TERM="vt100"           # valid value, but incompatible with my terminal
$ man ls   # works fine

$ export TERM="xterm-256color"  # back to default value
$ man ls   # works fine

TL;DR: check your TERM environment variable :)
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1164
Location: Tri-Cities, WA USA

PostPosted: Sat Jun 01, 2019 10:38 pm    Post subject: Reply with quote

thank you!

this is mine. yikes!
Code:

$ export | grep TERM         
declare -x COLORTERM="truecolor"
declare -x GNOME_TERMINAL_SCREEN="/org/gnome/Terminal/screen/04e3ddd4_1aae_4ca5_8fc2_b40222969977"
declare -x GNOME_TERMINAL_SERVICE=":1.70"
declare -x TERM="xterm-256color"


I've got some work to do.
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2480
Location: Frankfurt, Germany

PostPosted: Sat Jun 01, 2019 10:44 pm    Post subject: Reply with quote

What is the ouput of
Code:
export | grep "TERM="

when you get the "WARNING: terminal is not fully functional" messages?
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1164
Location: Tri-Cities, WA USA

PostPosted: Sun Jun 02, 2019 12:18 am    Post subject: Reply with quote

cwc@ciclo ~ $ export | grep "TERM="
declare -x COLORTERM="truecolor"
declare -x TERM="xterm-256color"
cwc@ciclo ~ $

gnome-terminal output:
Code:

cwc@ciclo ~ $ man ls
WARNING: terminal is not fully functional
-  (press RETURN)

_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1164
Location: Tri-Cities, WA USA

PostPosted: Sun Jun 02, 2019 1:01 pm    Post subject: Reply with quote

I'm a slow one sometimes :(

export TERM="linux"

works fine on my system.

Thanks you.
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 16197

PostPosted: Sun Jun 02, 2019 4:41 pm    Post subject: Reply with quote

I think TERM=linux is not correct for the graphical terminal emulators, though it is close enough that it mostly works. I use TERM=xterm-256color in x11-terms/xterm with =sys-libs/ncurses-6.1-r2 and man ls works fine for me.
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2480
Location: Frankfurt, Germany

PostPosted: Sun Jun 02, 2019 5:30 pm    Post subject: Reply with quote

Hu wrote:
I think TERM=linux is not correct for the graphical terminal emulators, though it is close enough that it mostly works. I use TERM=xterm-256color in x11-terms/xterm with =sys-libs/ncurses-6.1-r2 and man ls works fine for me.

I agree. On my machine, TERM has one of the values below:
  • TERM="linux" on the Linux text TTYs
  • TERM="xterm" in xterm and uxterm
  • TERM="xterm-256color" in konsole and qterminal
The TERM environment variable is set by the terminal itself - NOT by me and NOT by my login profiles or scripts.

@cwc: if I understand correctly, "man ls" sometimes gives you the "WARNING: terminal is not fully functional" message and sometimes not. That depends on the way you log in. But TERM is always "xterm-256color". Is that true?

If that's the case, it's NOT the TERM environment variable that is wrong. Leave it on "xterm-256color". Don't change it.

Something else is wrong. Please re-install ncurses:
Code:
emerge --oneshot ncurses

Does that solve the problem?
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 512

PostPosted: Tue Jun 04, 2019 7:32 pm    Post subject: Reply with quote

Did you build ncurses with the tinfo flag?

The different behaviour are "normal": ssh export the current terminal emulator $TERM when connecting:
- xterm sets TERM=xterm
- debian probably set gnome-terminal's TERM to a value that your gentoo don't know
- gentoo laptop with xfce, I don't know its TERM but probably also not know
- gentoo with no desktop is probably TERM=linux
- RPy : not idea of the TERM value
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1164
Location: Tri-Cities, WA USA

PostPosted: Tue Jun 11, 2019 1:33 pm    Post subject: solved Reply with quote

set new profile:
[22] default/linux/amd64/17.1/desktop/gnome/systemd (stable) *

ciclo ~ # export | grep "TERM="
declare -x COLORTERM="truecolor"
declare -x TERM="xterm-256color"
ciclo ~ # export | grep TERM=
declare -x COLORTERM="truecolor"
declare -x TERM="xterm-256color"


thank you for all the posts.
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum