Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
AppImage through firejail: Error: cannot configure loopback
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
urcindalo
l33t
l33t


Joined: 08 Feb 2005
Posts: 601
Location: Almeria, Spain

PostPosted: Mon Jun 10, 2019 6:31 am    Post subject: AppImage through firejail: Error: cannot configure loopback Reply with quote

Hi!

I used some apps through their appimage. In the past, the menu entries created by appimaged (https://github.com/AppImage/appimaged) used to work out of the box.
However, since I upgraded to the new 17.1 profile (I think it's just a chronological coincidence, but just in case, since I haven't used my appimages in a long time), my appimages cannot be launched through the appimaged-created menu entries due to sandbox related issues:
Code:
# firemon

08:06:23 exec 19541 (root) NEW SANDBOX: firejail --appimage /home/ramiro/bin/GIMP_AppImage-git-2.10.11-20190606-x86_64.AppImage
08:06:23 exit 19541 (root) EXIT SANDBOX
08:06:46 exec 19557 (root) NEW SANDBOX: firejail --env=DESKTOPINTEGRATION=appimaged --noprofile --appimage /home/ramiro/bin/GIMP_AppImage-git-2.10.11-20190606-x86_64.AppImage %U
08:06:46 exit 19557 (root) EXIT SANDBOX

The errors above appear with the command in the corresponding the menu entry and a reduced version:
Code:
$ firejail --appimage /home/ramiro/bin/GIMP_AppImage-git-2.10.11-20190606-x86_64.AppImage
Error: cannot configure loopback device
$ firejail --env=DESKTOPINTEGRATION=appimaged --noprofile --appimage /home/ramiro/bin/GIMP_AppImage-git-2.10.11-20190606-x86_64.AppImage %U
Error: cannot configure loopback device


However, appimages work if they are launched directly.
Any ideas?
Code:
$ ./GIMP_AppImage-git-2.10.11-20190606-x86_64.AppImage
DIR: /tmp/.mount_GIMP_AMlIKjL
AILIBDIR=/tmp/tmp.9vLDXM1Xpc
deleting /tmp/tmp.9vLDXM1Xpc/libxcb-dri3.so*
System stdc++ library: "/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/libstdc++.so.6"
System stdc++ library version: "3.4.25"
Bundled stdc++ library version: "3.4.22"
Newest stdc++ library version: "3.4.25"
Using system stdc++ library
atomiclib: /usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/libatomic.so.1
Checking versions of library "libfontconfig"
  system library: "/usr/lib64/libfontconfig.so.1.11.1" (libfontconfig.so.1.11.1)
  system library version: 1.11.1
  ailib: "/tmp/.mount_GIMP_AMlIKjL/usr/lib/libfontconfig.so.1.11.1"
  bundled library: "/tmp/.mount_GIMP_AMlIKjL/usr/lib/libfontconfig.so.1.11.1" (libfontconfig.so.1.11.1)
  bundled library version: 1.11.1
  newest library version: "1.11.1"
Removing bundled "libfontconfig"
'/tmp/tmp.9vLDXM1Xpc/libfontconfig.so.1' borrado
'/tmp/tmp.9vLDXM1Xpc/libfontconfig.so.1.11.1' borrado
Checking versions of library "libfreetype"
  system library: "/usr/lib64/libfreetype.so.6.16.1" (libfreetype.so.6.16.1)
  system library version: 6.16.1
  ailib: "/tmp/.mount_GIMP_AMlIKjL/usr/lib/libfreetype.so.6.16.1"
  bundled library: "/tmp/.mount_GIMP_AMlIKjL/usr/lib/libfreetype.so.6.16.1" (libfreetype.so.6.16.1)
  bundled library version: 6.16.1
  newest library version: "6.16.1"
Removing bundled "libfreetype"
'/tmp/tmp.9vLDXM1Xpc/libfreetype.so.6' borrado
'/tmp/tmp.9vLDXM1Xpc/libfreetype.so.6.16.1' borrado
APPDIRS: /tmp/tmp.9vLDXM1Xpc:/tmp/tmp.9vLDXM1Xpc/gimp/2.0/plug-ins:/home/ramiro/.config/GIMP-AppImage/2.10/plug-ins:/tmp/.mount_GIMP_AMlIKjL:
GTK_PATH=/tmp/.mount_GIMP_AMlIKjL/usr/lib/gtk-2.0
GTK_IM_MODULE_FILE=/tmp/.mount_GIMP_AMlIKjL/usr/lib/gtk-2.0:/tmp/.mount_GIMP_AMlIKjL/usr/lib/gtk-2.0
PANGO_LIBDIR=/tmp/.mount_GIMP_AMlIKjL/usr/lib
BABL_PATH /tmp/.mount_GIMP_AMlIKjL/usr/lib/babl-0.1
GEGL_PATH /tmp/.mount_GIMP_AMlIKjL/usr/lib/gegl-0.4
python=/tmp/.mount_GIMP_AMlIKjL/usr/bin/python2
python2=/tmp/.mount_GIMP_AMlIKjL/usr/bin/python2
/tmp/.mount_GIMP_AMlIKjL/usr/bin/python=/tmp/.mount_GIMP_AMlIKjL/usr/bin/python2
:Python:E::py::python2:
GIMP2_PLUGINDIR: /tmp/tmp.9vLDXM1Xpc/gimp/2.0
/tmp/.mount_GIMP_AMlIKjL/apprun-helper.sh: línea 149: /tmp/.mount_GIMP_AMlIKjL/startup_scripts/*.sh: No existe el fichero o el directorio
load_external_plugins: linking plug-ins under /home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/gmic_qt/plug-ins
load_external_plugins: sourcing /home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/gmic_qt/plug-ins/../scripts/startup.sh
load_external_plugins: linking plug-ins under /home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/LiquidRescale/plug-ins
load_external_plugins: sourcing /home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/LiquidRescale/plug-ins/../scripts/startup.sh
load_external_plugins: linking plug-ins under /home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/NUFraw/plug-ins
load_external_plugins: sourcing /home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/NUFraw/plug-ins/../scripts/startup.sh
load_external_plugins: linking plug-ins under /home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/PhFGimp/plug-ins
load_external_plugins: sourcing /home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/PhFGimp/plug-ins/../scripts/startup.sh
load_external_plugins: linking plug-ins under /home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/ResynthesizerPlugin/plug-ins
load_external_plugins: sourcing /home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/ResynthesizerPlugin/plug-ins/../scripts/startup.sh
LD_LIBRARY_PATH: /home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/ResynthesizerPlugin/usr/lib:/home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/PhFGimp/usr/lib:/home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/NUFraw/usr/lib:/home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/LiquidRescale/usr/lib:/home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/gmic_qt/usr/lib:/tmp/tmp.9vLDXM1Xpc:/usr/lib::/tmp/.mount_GIMP_AMlIKjL/usr/lib/gdk-pixbuf-2.0/loaders
QT_PLUGIN_PATH: /home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/gmic_qt/usr/lib/qt5/plugins:
Input parameters: ""

Input File:
        linux-vdso.so.1 (0x00007ffe90d8b000)
        libgimpwidgets-2.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libgimpwidgets-2.0.so.0 (0x00007f30b7ee0000)
        libgtk-x11-2.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libgtk-x11-2.0.so.0 (0x00007f30b7858000)
        libgdk-x11-2.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libgdk-x11-2.0.so.0 (0x00007f30b7590000)
        libatk-1.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libatk-1.0.so.0 (0x00007f30b7368000)
        libgimpconfig-2.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libgimpconfig-2.0.so.0 (0x00007f30b7150000)
        libgimpmath-2.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libgimpmath-2.0.so.0 (0x00007f30b6f48000)
        libgimpthumb-2.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libgimpthumb-2.0.so.0 (0x00007f30b6d38000)
        libgimpcolor-2.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libgimpcolor-2.0.so.0 (0x00007f30b6b20000)
        libgimpmodule-2.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libgimpmodule-2.0.so.0 (0x00007f30b6918000)
        libgimpbase-2.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libgimpbase-2.0.so.0 (0x00007f30b66e8000)
        libgdk_pixbuf-2.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libgdk_pixbuf-2.0.so.0 (0x00007f30b64c0000)
        libpangocairo-1.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libpangocairo-1.0.so.0 (0x00007f30b62b0000)
        libpangoft2-1.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libpangoft2-1.0.so.0 (0x00007f30b6098000)
        libpango-1.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libpango-1.0.so.0 (0x00007f30b5e50000)
        libcairo.so.2 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libcairo.so.2 (0x00007f30b5b38000)
        libpixman-1.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libpixman-1.so.0 (0x00007f30b5888000)
        libfontconfig.so.1 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libfontconfig.so.1 (0x00007f30b5640000)
        libexpat.so.1 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libexpat.so.1 (0x00007f30b5410000)
        libuuid.so.1 => /lib64/libuuid.so.1 (0x00007f30b53a0000)
        libfreetype.so.6 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libfreetype.so.6 (0x00007f30b50f8000)
        libbz2.so.1 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libbz2.so.1 (0x00007f30b4ee8000)
        libharfbuzz.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libharfbuzz.so.0 (0x00007f30b4c48000)
        libpng16.so.16 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libpng16.so.16 (0x00007f30b4a10000)
        libxcb-shm.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libxcb-shm.so.0 (0x00007f30b4808000)
        libxcb.so.1 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libxcb.so.1 (0x00007f30b45e0000)
        libxcb-render.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libxcb-render.so.0 (0x00007f30b43d0000)
        libXrender.so.1 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libXrender.so.1 (0x00007f30b41c0000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f30b4080000)
        libXext.so.6 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libXext.so.6 (0x00007f30b3e68000)
        librt.so.1 => /lib64/librt.so.1 (0x00007f30b3e58000)
        libgegl-npd-0.4.so => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libgegl-npd-0.4.so (0x00007f30b3c50000)
        libgegl-0.4.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libgegl-0.4.so.0 (0x00007f30b3978000)
        libgthread-2.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libgthread-2.0.so.0 (0x00007f30b3770000)
        libgmodule-2.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libgmodule-2.0.so.0 (0x00007f30b3568000)
        libjson-glib-1.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libjson-glib-1.0.so.0 (0x00007f30b3340000)
        libbabl-0.1.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libbabl-0.1.so.0 (0x00007f30b3058000)
        libgio-2.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libgio-2.0.so.0 (0x00007f30b2cb8000)
        liblcms2.so.2 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/liblcms2.so.2 (0x00007f30b2a58000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f30b2a30000)
        libgexiv2.so.2 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libgexiv2.so.2 (0x00007f30b2808000)
        libexiv2.so.26 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libexiv2.so.26 (0x00007f30b2210000)
        libz.so.1 => /lib64/libz.so.1 (0x00007f30b21f0000)
        libmypaint-1.3.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libmypaint-1.3.so.0 (0x00007f30b1fd8000)
        libjson-c.so.2 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libjson-c.so.2 (0x00007f30b1dc8000)
        libgobject-2.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libgobject-2.0.so.0 (0x00007f30b1b78000)
        libglib-2.0.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libglib-2.0.so.0 (0x00007f30b1860000)
        libunwind.so.8 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libunwind.so.8 (0x00007f30b1640000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f30b1500000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f30b14f8000)
        libjpeg.so.62 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libjpeg.so.62 (0x00007f30b12a0000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f30b10d0000)
        libXfixes.so.3 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libXfixes.so.3 (0x00007f30b0ec8000)
        libXinerama.so.1 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libXinerama.so.1 (0x00007f30b0cc0000)
        libXi.so.6 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libXi.so.6 (0x00007f30b0ab0000)
        libXrandr.so.2 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libXrandr.so.2 (0x00007f30b08a0000)
        libXcursor.so.1 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libXcursor.so.1 (0x00007f30b0690000)
        libXcomposite.so.1 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libXcomposite.so.1 (0x00007f30b0488000)
        libXdamage.so.1 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libXdamage.so.1 (0x00007f30b0280000)
        libpng15.so.15 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libpng15.so.15 (0x00007f30b0050000)
        libthai.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libthai.so.0 (0x00007f30afe40000)
        libfribidi.so.0 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libfribidi.so.0 (0x00007f30afc20000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f30b8178000)
        libgraphite2.so.3 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libgraphite2.so.3 (0x00007f30af9f0000)
        libXau.so.6 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libXau.so.6 (0x00007f30af7e8000)
        libpcre.so.1 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libpcre.so.1 (0x00007f30af580000)
        libffi.so.6 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libffi.so.6 (0x00007f30af378000)
        libselinux.so.1 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libselinux.so.1 (0x00007f30af150000)
        libresolv.so.2 => /lib64/libresolv.so.2 (0x00007f30af130000)
        libmount.so.1 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libmount.so.1 (0x00007f30aeee8000)
        libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/libgcc_s.so.1 (0x00007f30aeec8000)
        libstdc++.so.6 => /usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/libstdc++.so.6 (0x00007f30aecc0000)
        libblkid.so.1 => /tmp/.mount_GIMP_AMlIKjL/usr/bin/../lib/libblkid.so.1 (0x00007f30aea80000)

/tmp/.mount_GIMP_AMlIKjL/usr/bin/gimp.bin --pdb-compat-mode=on ""
/tmp/.mount_GIMP_AMlIKjL/usr/bin/python
DIRNAME: /tmp/.mount_GIMP_AMlIKjL/usr/bin
DESKTOPFILE_NAME: gimp.desktop
APP_FULL: GNU Image Manipulation Program
APP: GNUImageManipulationProgram
APP_FULL: GNU Image Manipulation Program
APP: GNUImageManipulationProgram
BIN: /tmp/.mount_GIMP_AMlIKjL/usr/bin/gimp.bin
is_external_process: bundled process found: /tmp/.mount_GIMP_AMlIKjL/usr/bin/gimp-2.10
/tmp/.mount_GIMP_AMlIKjL/usr/bin/gimp.bin: Gimp-Widgets-WARNING: parse_iso_codes: error parsing '/tmp/.mount_GIMP_AMlIKjL/usr/share/xml/iso-codes/iso_639.xml': No existe el fichero o el directorio

Skipping duplicate plug-in: '/tmp/tmp.9vLDXM1Xpc/gimp/2.0/plug-ins/plugin-heal-selection.py'
Skipping duplicate plug-in: '/tmp/tmp.9vLDXM1Xpc/gimp/2.0/plug-ins/plugin-heal-transparency.py'
Skipping duplicate plug-in: '/tmp/tmp.9vLDXM1Xpc/gimp/2.0/plug-ins/plugin-map-style.py'
Skipping duplicate plug-in: '/tmp/tmp.9vLDXM1Xpc/gimp/2.0/plug-ins/plugin-render-texture.py'
Skipping duplicate plug-in: '/tmp/tmp.9vLDXM1Xpc/gimp/2.0/plug-ins/plugin-resynth-enlarge.py'
Skipping duplicate plug-in: '/tmp/tmp.9vLDXM1Xpc/gimp/2.0/plug-ins/plugin-resynth-fill-pattern.py'
Skipping duplicate plug-in: '/tmp/tmp.9vLDXM1Xpc/gimp/2.0/plug-ins/plugin-resynth-sharpen.py'
Skipping duplicate plug-in: '/tmp/tmp.9vLDXM1Xpc/gimp/2.0/plug-ins/plugin-uncrop.py'
Skipping duplicate plug-in: '/tmp/tmp.9vLDXM1Xpc/gimp/2.0/plug-ins/resynthesizer'
Skipping duplicate plug-in: '/tmp/tmp.9vLDXM1Xpc/gimp/2.0/plug-ins/resynthesizer_gui'
is_external_process: bundled process found: /home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/PhFGimp/plug-ins/phf_gimp
is_external_process: bundled process found: /home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/PhFGimp/plug-ins/file-photoflow
is_external_process: bundled process found: /home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/NUFraw/plug-ins/nufraw-gimp
/tmp/tmp.9vLDXM1Xpc/gimp/2.0/plug-ins/nufraw-gimp: error while loading shared libraries: libgtkimageview.so.0: cannot open shared object file: No such file or directory
/tmp/.mount_GIMP_AMlIKjL/usr/bin/gimp.bin: LibGimpBase-WARNING: gimp.bin: gimp_wire_read(): error
is_external_process: bundled process found: /tmp/.mount_GIMP_AMlIKjL/usr/lib/gimp/2.0/plug-ins/file-darktable/file-darktable
is_external_process: bundled process found: /home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/PhFGimp/plug-ins/phf_gimp
phf_gimp::query() called, exec_path=photoflow
phf_gimp::init(): failed to run photoflow (photoflow)
is_external_process: bundled process found: /home/ramiro/.config/GIMP-AppImage/2.10/plug-ins/PhFGimp/plug-ins/file-photoflow
file-photoflow::init() called, exec_path=photoflow
file-photoflow::init(): failed to run photoflow (photoflow)
is_external_process: bundled process found: /tmp/.mount_GIMP_AMlIKjL/usr/lib/gimp/2.0/plug-ins/file-rawtherapee/file-rawtherapee
is_external_process: bundled process found: /tmp/.mount_GIMP_AMlIKjL/usr/lib/gimp/2.0/plug-ins/file-darktable/file-darktable
is_external_process: bundled process found: /tmp/.mount_GIMP_AMlIKjL/usr/lib/gimp/2.0/plug-ins/script-fu/script-fu
Plug-in "script-fu"
(/tmp/tmp.9vLDXM1Xpc/gimp/2.0/plug-ins/script-fu/script-fu) is installing procedure "Glossy-Metal-3D-Text-By-Monsoonami" with a full menu path "<Image>/File/Create/Logos/Glossy Metal 3D Text By Monsoonami" as menu label, this deprecated and will be an error in GIMP 3.0
Plug-in "script-fu"
(/tmp/tmp.9vLDXM1Xpc/gimp/2.0/plug-ins/script-fu/script-fu) is installing procedure "script-fu-fake-hdr-effect" with a full menu path "<Image>/Script-Fu/Enhance/Fake HDR Effect..." as menu label, this deprecated and will be an error in GIMP 3.0
Plug-in "script-fu"
(/tmp/tmp.9vLDXM1Xpc/gimp/2.0/plug-ins/script-fu/script-fu) is installing procedure "script-fu-fake-hdr-effect-plus" with a full menu path "<Image>/Script-Fu/Enhance/Fake HDR Effect plus..." as menu label, this deprecated and will be an error in GIMP 3.0
Plug-in "script-fu"
(/tmp/tmp.9vLDXM1Xpc/gimp/2.0/plug-ins/script-fu/script-fu) is installing procedure "script-fu-draw-arrow" with a full menu path "<Image>/Tools/Arrow..." as menu label, this deprecated and will be an error in GIMP 3.0


Thanks in advance.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum