Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gcc] quelle(s) version(s) conserver ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
pti-rem
Guru
Guru


Joined: 14 Oct 2011
Posts: 309
Location: Aquitaine FRANCE

PostPosted: Sun Jun 09, 2019 9:12 am    Post subject: [gcc] quelle(s) version(s) conserver ? Reply with quote

Bonjour,

Code:
n73sm ~ # gcc-config -l
 [1] x86_64-pc-linux-gnu-5.4.0
 [2] x86_64-pc-linux-gnu-6.4.0
 [3] x86_64-pc-linux-gnu-7.3.0
 [4] x86_64-pc-linux-gnu-8.3.0 *
n73sm ~ #

J'ai trop de versions là...
Quelle version conserver en plus de la 8.3.0 ?

Merci
_________________
Il faut être léger pour voler sur les cailloux - amd64/17.1/desktop - GMT
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 501

PostPosted: Sun Jun 09, 2019 10:21 am    Post subject: Reply with quote

Sauf besoin spécifique, aucune!
Back to top
View user's profile Send private message
pti-rem
Guru
Guru


Joined: 14 Oct 2011
Posts: 309
Location: Aquitaine FRANCE

PostPosted: Sun Jun 09, 2019 2:10 pm    Post subject: Reply with quote

Comme je ne sais pas si j'ai un besoin spécifique, je ne dois probablement pas en avoir.

Code:
emerge -av --depclean sys-devel/gcc:5.4.0 sys-devel/gcc:6.4.0 sys-devel/gcc:7.3.0

n'a pas bronché ; ces versions sont supprimées désormais.

Merci YetiBarBar
_________________
Il faut être léger pour voler sur les cailloux - amd64/17.1/desktop - GMT
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 501

PostPosted: Mon Jun 10, 2019 7:33 am    Post subject: Reply with quote

Un peu plus de précisions sur les besoins spécifiques: tant que tu utilises gcc "juste" pour compiler ton système, tu n'as pas d'intérêt particulier à "redescendre" la version de gcc, il y a même des théories qui prévoient des effets de bords indésirables dans ce cas.

Il y a un cas particulier avec quelques paquets qui ne supporte pas un gcc trop récent (pour ceux que j'ai déjà pu rencontré, ils étaient liés à Cuda mais il doit bien y en avoir d'autres).

Pour les usages plus spécifiques qui peuvent nécessiter de garder une autres versions de gcc auxquels je pensais, ils sont liés à des profils "développeur":
- tests de compilation avec différentes versions de gcc (on ne choisit pas le compilateur des utilisateurs de son programme :-))
- besoin de générer des paquets binaires pour une cible en gardant une version précise d'ABI, voire sur une autres architecture où tu ne disposes pas du même gcc que ta version courante (par exemple, une cross-compilation vers une plateforme embarquée avec un gcc anti-diluvien)
- dans la même veine, pour compiler des paquets vers une architecture "abandonnée" par une nouvelle version de gcc (par exemple, gcc9 droppe le support de très vieux processeurs ARM)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum