Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with alsa-firmware [Solved]
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Fulgurance
l33t
l33t


Joined: 15 Feb 2017
Posts: 657

PostPosted: Thu May 23, 2019 10:10 pm    Post subject: Problem with alsa-firmware [Solved] Reply with quote

Hello, today i have finished to install all of my system on my laptop, but i have seen ig problem. alsa-firmware package don't have hda-intel use flag for ALSA_CARDS global use flag ???
It's big problem, because i have no sound ...


Last edited by Fulgurance on Mon Aug 19, 2019 9:24 am; edited 1 time in total
Back to top
View user's profile Send private message
Banana
Guru
Guru


Joined: 21 May 2004
Posts: 335
Location: Germany

PostPosted: Fri May 24, 2019 12:55 pm    Post subject: Reply with quote

Without any information about your system, we can only guess what could be wrong.

So please provide:
- output of emerge --info
- output of lspci
_________________
My personal space
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44959
Location: 56N 3W

PostPosted: Fri May 24, 2019 8:43 pm    Post subject: Reply with quote

Fulgurance,

Lack of firmware is probably not your problem.

What does
Code:
cat /proc/asound/devices
say and how are you expecting sound to work?
Analogue from the pale green front stereo jack socket or over a digital video link?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Fulgurance
l33t
l33t


Joined: 15 Feb 2017
Posts: 657

PostPosted: Sun May 26, 2019 9:51 am    Post subject: Reply with quote

I have thinking and i think i have found source on problem. Its license problem !
I have seen use flag for linux-firmware (unknow-license), but i dont have any success to enable it. (I have hda-intel sound card)

I have changed default license use flag, but again this use flag is masked...
i have set:
ACCEPT_LICENSE=* -@EULA
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44959
Location: 56N 3W

PostPosted: Sun May 26, 2019 10:10 am    Post subject: Reply with quote

Fulgurance,

Tell us your problem not your proposed solution.
By way of describing your problem, provide the information your helpers have requested.

Code:
ACCEPT_LICENSE=* -@EULA
is missing the quotes.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Fulgurance
l33t
l33t


Joined: 15 Feb 2017
Posts: 657

PostPosted: Sun May 26, 2019 10:22 am    Post subject: Reply with quote

I have just missing quote because i write with my phone. Just wait, i emerge Firefox. When i have finished, i post Emerge info
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44959
Location: 56N 3W

PostPosted: Sun May 26, 2019 10:35 am    Post subject: Reply with quote

Fulgurance,

and the other things too please.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Fulgurance
l33t
l33t


Joined: 15 Feb 2017
Posts: 657

PostPosted: Mon May 27, 2019 12:10 am    Post subject: Reply with quote

If you can help me !
I think problem is with new license system. linux-firmware have new license use flag and i don't have success to enable it.

Look:

Emerge info:
Code:
fulgurance@msi-gs73vr-6rf ~ $ emerge --info
Portage 2.3.66 (python 3.6.8-final-0, default/linux/amd64/17.0/hardened/selinux, gcc-9.1.0, glibc-2.29-r2, 5.1.4-gentoo x86_64)
=================================================================
System uname: Linux-5.1.4-gentoo-x86_64-Intel-R-_Core-TM-_i7-6700HQ_CPU_@_2.60GHz-with-gentoo-2.6
KiB Mem:    16305432 total,  10874584 free
KiB Swap:   20971516 total,  20971516 free
Timestamp of repository gentoo: Fri, 24 May 2019 21:30:01 +0000
Head commit of repository gentoo: d430fbc0a7c8b6e2e87e77b88f2af77ff980b0d2
sh bash 5.0_p7
ld GNU ld (Gentoo 2.32 p2) 2.32.0
app-shells/bash:          5.0_p7::gentoo
dev-lang/perl:            5.30.0::gentoo
dev-lang/python:          2.7.16::gentoo, 3.6.8::gentoo
dev-util/cmake:           3.14.4::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.17::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            9.1.0::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.0-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts:

fulgurance-overlay
    location: /var/lib/layman/fulgurance-overlay
    sync-type: laymansync
    sync-uri: https://github.com/Fulgurance/Gentoo-Overlay.git
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=skylake -O2 -pipe -mmovbe -mmmx -msse -msse2 -msse3 -mssse3 -msse4.1 -msse4.2 -mpopcnt -mavx -mavx2 -maes -mpclmul -mfsgsbase -mrdrnd -mfma -mbmi -mbmi2 -mf16c -mrdseed -madx -mprefetchwt1 -mclflushopt -mxsavec -mxsaves"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=skylake -O2 -pipe -mmovbe -mmmx -msse -msse2 -msse3 -mssse3 -msse4.1 -msse4.2 -mpopcnt -mavx -mavx2 -maes -mpclmul -mfsgsbase -mrdrnd -mfma -mbmi -mbmi2 -mf16c -mrdseed -madx -mprefetchwt1 -mclflushopt -mxsavec -mxsaves"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=skylake -O2 -pipe -mmovbe -mmmx -msse -msse2 -msse3 -mssse3 -msse4.1 -msse4.2 -mpopcnt -mavx -mavx2 -maes -mpclmul -mfsgsbase -mrdrnd -mfma -mbmi -mbmi2 -mf16c -mrdseed -madx -mprefetchwt1 -mclflushopt -mxsavec -mxsaves"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs candy config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch preserve-libs protect-owned sandbox selinux sesandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=skylake -O2 -pipe -mmovbe -mmmx -msse -msse2 -msse3 -mssse3 -msse4.1 -msse4.2 -mpopcnt -mavx -mavx2 -maes -mpclmul -mfsgsbase -mrdrnd -mfma -mbmi -mbmi2 -mf16c -mrdseed -madx -mprefetchwt1 -mclflushopt -mxsavec -mxsaves"
GENTOO_MIRRORS="http://ftp.free.fr/mirrors/ftp.gentoo.org/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ http://gentoo.modulix.net/gentoo/ http://gentoo.mirrors.ovh.net/gentoo-distfiles/ ftp://mirrors.soeasyto.com/distfiles.gentoo.org/ http://mirrors.soeasyto.com/distfiles.gentoo.org/ https://mirrors.soeasyto.com/distfiles.gentoo.org/"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="fr fr_FR"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl acpi alsa amd64 bzip2 compat crypt cryptsetup custom-cflags custom-optimization cxx dbus device-mapper dhcpcd dri dri3 elogind experimental git glamor gstreamer hardened iconv initramfs ipv6 jpeg kde libtirpc lvm mp3 mp4 multilib ncurses networkmanager nls nptl ogg open_perms opengl openmp pam pcre peer_perms phonon pie png policykit pulseaudio readline seccomp selinux semantic-desktop ssl ssp tiff ubac udev udisks unconfined unicode vorbis vulkan wayland wifi wireless xattr xtpax zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" L10N="fr fr-FR" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-1" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24" USERLAND="GNU" VIDEO_CARDS="intel i965 nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Linux firmware use flags:
Code:
fulgurance@msi-gs73vr-6rf ~ $ eix linux-firmware
[I] sys-kernel/linux-firmware
     Available versions:  20190502^bs 20190514^bsd **99999999^bsd {+redistributable savedconfig unknown-license}
     Installed versions:  20190514^bs(22:31:46 25/05/2019)(redistributable -savedconfig -unknown-license)
     Homepage:            https://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git
     Description:         Linux firmware files


Lspci:
Code:
fulgurance@msi-gs73vr-6rf ~ $ lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
00:14.0 USB controller: Intel Corporation 100 Series/C230 Series Chipset Family USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation 100 Series/C230 Series Chipset Family Thermal Subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation 100 Series/C230 Series Chipset Family MEI Controller #1 (rev 31)
00:17.0 SATA controller: Intel Corporation HM170/QM170 Chipset SATA Controller [AHCI Mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #1 (rev f1)
00:1c.4 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #5 (rev f1)
00:1d.0 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #9 (rev f1)
00:1d.5 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #14 (rev f1)
00:1d.6 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #15 (rev f1)
00:1f.0 ISA bridge: Intel Corporation HM170 Chipset LPC/eSPI Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation 100 Series/C230 Series Chipset Family Power Management Controller (rev 31)
00:1f.3 Audio device: Intel Corporation 100 Series/C230 Series Chipset Family HD Audio Controller (rev 31)
00:1f.4 SMBus: Intel Corporation 100 Series/C230 Series Chipset Family SMBus (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] (rev ff)
3c:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM981/PM981
3d:00.0 Ethernet controller: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller (rev 10)
3e:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44959
Location: 56N 3W

PostPosted: Mon May 27, 2019 12:23 am    Post subject: Reply with quote

Fulgurance,

Code:
00:1f.3 Audio device: Intel Corporation 100 Series/C230 Series Chipset Family HD Audio Controller (rev 31)

It that needs firmware, its the first snd-hda-intel divice I've met that does.

You only appear to have a single sound card there but lets not assume anything.
Please post the output of
Code:
cat /proc/asound/devices

It shows all the devices on all your sound cards.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Fulgurance
l33t
l33t


Joined: 15 Feb 2017
Posts: 657

PostPosted: Mon May 27, 2019 12:33 am    Post subject: Reply with quote

It's strange, it's the first time i have this problem...

Code:
fulgurance@msi-gs73vr-6rf ~ $ cat /proc/asound/devices
  1:        : sequencer
  2: [ 0- 0]: digital audio playback
  3: [ 0- 0]: digital audio capture
  4: [ 0- 1]: digital audio playback
  5: [ 0- 3]: digital audio playback
  6: [ 0- 7]: digital audio playback
  7: [ 0- 8]: digital audio playback
  8: [ 0- 9]: digital audio playback
  9: [ 0-10]: digital audio playback
 10: [ 0- 0]: hardware dependent
 11: [ 0- 2]: hardware dependent
 12: [ 0]   : control
 33:        : timer
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44959
Location: 56N 3W

PostPosted: Mon May 27, 2019 12:37 am    Post subject: Reply with quote

Fulgurance,

That looks good. One soundcard.

What does alsamixer show?
You can paste the text screen between code tags.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Fulgurance
l33t
l33t


Joined: 15 Feb 2017
Posts: 657

PostPosted: Mon May 27, 2019 12:40 am    Post subject: Reply with quote

Screen: http://zupimages.net/viewer.php?id=19/22/0p6h.png
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44959
Location: 56N 3W

PostPosted: Mon May 27, 2019 12:48 am    Post subject: Reply with quote

Fulgurance,

Your sound card can do digital audio or analogue audio but only one at a time.
When both are enabled digital wins.

Mute all the controls with S/PDIF or IEC in their names.
Your screen shot shows two enabled and there may be more if you scroll to the right in alsomixer.

Just now your sound is going to the digital output.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Fulgurance
l33t
l33t


Joined: 15 Feb 2017
Posts: 657

PostPosted: Mon May 27, 2019 12:01 pm    Post subject: Reply with quote

Sorry, i haven't finished to configure my sound before i post this informations. I have again no sound.
This is my alsa configuration for pulseaudio:


/etc/alsa/conf.d/50-pulseaudio.conf
Code:
# Add a specific named PulseAudio pcm and ctl (typically useful for testing)

pcm.pulse {
    type pulse
}
ctl.pulse {
    type pulse
}
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}


And my alsamixer screenshot (look "Sortie Factice") : http://zupimages.net/viewer.php?id=19/22/hrl1.png

Nobody have any idea for new linux-firmware use flag? I'm sure source of problem is this.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44959
Location: 56N 3W

PostPosted: Mon May 27, 2019 12:11 pm    Post subject: Reply with quote

Fulgurance,

pulseaudio is a wrapper around alsa.

I'm not a pulseaudio user but until alsa can make sounds, pulse won't work either.

Did you mute all the digital outputs?


-- edit --

The screen shot background, behind alsamixer, with the heading "Configurer le volume audio" shows that sound is muted.
Look at the icon above the 100% at the end of the slider.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Fulgurance
l33t
l33t


Joined: 15 Feb 2017
Posts: 657

PostPosted: Mon May 27, 2019 1:41 pm    Post subject: Reply with quote

This is my sound configuration: http://zupimages.net/viewer.php?id=19/22/xce4.png

Is it possible problem come because i just enable abi_x86_64 use flag ?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44959
Location: 56N 3W

PostPosted: Mon May 27, 2019 4:17 pm    Post subject: Reply with quote

Fulgurance,

Your
Code:
/proc/asound/devices
shows your kernel is good.
All the expected sound devices are there.

Until you installed pulseaudo, the only thing wrong in alsamixer was the digital interfaces being unmuted.

With pulse on top of Alsa, I'm out of ideas except your GUI shows that sound output is muted.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Fulgurance
l33t
l33t


Joined: 15 Feb 2017
Posts: 657

PostPosted: Mon May 27, 2019 5:57 pm    Post subject: Reply with quote

I have already follow your advice, but the same problem... no sound

Screenshot: http://zupimages.net/viewer.php?id=19/22/gjxy.png

And it's not mutted, system show mutted icon, but it's not ...
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44959
Location: 56N 3W

PostPosted: Mon May 27, 2019 7:52 pm    Post subject: Reply with quote

Fulgurance,

Code:
┌────────────────────────────── AlsaMixer v1.1.9 ──────────────────────────────┐
│ Card: HDA ATI SB                                     F1:  Help               │
│ Chip: VIA VT1708S                                    F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All             F6:  Select sound card  │
│ Item: Master [dB gain: 0.00]                         Esc: Exit               │
│                                                                              │
│     ┌──┐              ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐      │
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      │
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      │
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      →
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      →
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      →
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      →
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      →
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      →
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      →
│     │▒▒│              │▒▒│     │▒▒│     │  │     │▒▒│     │▒▒│     │▒▒│      │
│     │▒▒│              │▒▒│     │▒▒│     │  │     │▒▒│     │▒▒│     │▒▒│      │
│     ├──┤     ┌──┐     └──┘     ├──┤     ├──┤     └──┘     ├──┤     ├──┤      │
│     │OO│     │OO│              │OO│     │MM│              │OO│     │OO│      │
│     └──┘     └──┘              └──┘     └──┘              └──┘     └──┘      │
│     100             100<>100 100<>100   0<>0    21<>21  100<>100   100       │
│  < Master >Headphon   PCM     Front   Front Mi Front Mi Surround  Center     │
└──────────────────────────────────────────────────────────────────────────────┘


There are more controls than you show in your image.

That's what the column of → mean on the right of the the window.
Do you have more controls to mute there?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Fulgurance
l33t
l33t


Joined: 15 Feb 2017
Posts: 657

PostPosted: Mon May 27, 2019 8:12 pm    Post subject: Reply with quote

Yes, i know alsamixer.
Code:
┌──────────────────────────────────────── AlsaMixer v1.1.9 ─────────────────────────────────────────┐
│    Carte: HDA Intel PCH                                                 F1:  Aide                 │
│     Puce: Realtek ALC898                                                F2:  Informations Système │
│      Vue: F3:[Lecture] F4: Capture  F5: Tout                            F6:  Choisir la carte son │
│ Contrôle: Loopback Mixing [Disabled]                                    Esc: Quitter              │
│                                                                                                   │
│                                                                                                   │
│       ┌──┐     ┌──┐                                                                               │
│       │  │     │  │                                                                               │
│       │  │     │  │                                                                               │
←       │  │     │  │                                                                               │
←       │  │     │  │                                                                               │
←       │  │     │  │                                                                               │
←       │  │     │  │                                                                               │
←       │  │     │  │                                                                               │
←       │  │     │  │                                                                               │
←       │  │     │  │                                                                               │
│       │  │     │  │                                                                               │
│       │  │     │  │                                                                               │
│       │  │     │  │                                                                               │
│       ├──┤     └──┘     ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐   Disabled     │
│       │MM│              │MM│     │MM│     │MM│     │MM│     │MM│     │MM│     │MM│                │
│       └──┘              └──┘     └──┘     └──┘     └──┘     └──┘     └──┘     └──┘                │
│       0<>0     0<>0                                                                               │
│       Mic    Mic Boos  S/PDIF  S/PDIF D S/PDIF 1 S/PDIF 2 S/PDIF 3 S/PDIF 4 S/PDIF 1<Loopback>    │
│                                                                                                   │
└───────────────────────────────────────────────────────────────────────────────────────────────────┘
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44959
Location: 56N 3W

PostPosted: Mon May 27, 2019 8:49 pm    Post subject: Reply with quote

Fulgurance,

You may need to pass the model= module parameter when snd_hda_intel loads.
There is a list in /usr/src/linux/Documentation/sound/hd-audio/models.rst starting at line 332, in my kernel anyway.

Many of them will not apply to you. Its a process of trial and error.
Code:
modprobe -r snd_hda_intel
modprobe snd_hda_intel model=<next_on_list>

Test sound.

Repeat until you find one that works.

Once you have your model, the boot process can apply it.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Fulgurance
l33t
l33t


Joined: 15 Feb 2017
Posts: 657

PostPosted: Tue Jun 04, 2019 11:01 am    Post subject: Reply with quote

Hello, sorry for waiting time.

I have looking documentation you asked me.
But, it's strange, i don't found my module... It's very strange, because in many installations in past, my sound work immediatly...

Look that:

Code:
zohran@msi-gs73vr-6rf ~ $ cat /proc/
Display all 272 possibilities? (y or n)
zohran@msi-gs73vr-6rf ~ $ cat /proc/asound/pcm
00-00: ALC898 Analog : ALC898 Analog : playback 1 : capture 1
00-01: ALC898 Digital : ALC898 Digital : playback 1
00-03: HDMI 0 : HDMI 0 : playback 1
00-07: HDMI 1 : HDMI 1 : playback 1
00-08: HDMI 2 : HDMI 2 : playback 1
00-09: HDMI 3 : HDMI 3 : playback 1
00-10: HDMI 4 : HDMI 4 : playback 1
zohran@msi-gs73vr-6rf ~ $ sudo updatedb
Mot de passe : 
zohran@msi-gs73vr-6rf ~ $ locate sdn-hda-intel
zohran@msi-gs73vr-6rf ~ $ locate sdn_hda_intel
zohran@msi-gs73vr-6rf ~ $


If you look, there are no hda intel modules found ... and when i look your documentation on /usr/src/linux/Documentation/sound/hd-audio/models.rst, i found section with my device name, but there isn't model name... I look bad?

Code:
ALC88x/898/1150/1220
====================
abit-aw9d
    Pin fixups for Abit AW9D-MAX
lenovo-y530
    Pin fixups for Lenovo Y530
acer-aspire-7736
    Fixup for Acer Aspire 7736
asus-w90v
    Pin fixup for ASUS W90V
cd
    Enable audio CD pin NID 0x1c
no-front-hp
    Disable front HP pin NID 0x1b
vaio-tt
    Pin fixup for VAIO TT
eee1601
    COEF setups for ASUS Eee 1601
alc882-eapd
    Change EAPD COEF mode on ALC882
alc883-eapd
    Change EAPD COEF mode on ALC883
gpio1
    Enable GPIO1
gpio2
    Enable GPIO2
gpio3
    Enable GPIO3
alc889-coef
    Setup ALC889 COEF
asus-w2jc
    Fixups for ASUS W2JC
acer-aspire-4930g
    Acer Aspire 4930G/5930G/6530G/6930G/7730G
acer-aspire-8930g
    Acer Aspire 8330G/6935G
acer-aspire
    Acer Aspire others
macpro-gpio
    GPIO setup for Mac Pro
dac-route
    Workaround for DAC routing on Acer Aspire
mbp-vref
    Vref setup for Macbook Pro
imac91-vref
    Vref setup for iMac 9,1
mba11-vref
    Vref setup for MacBook Air 1,1
mba21-vref
    Vref setup for MacBook Air 2,1
mp11-vref
    Vref setup for Mac Pro 1,1
mp41-vref
    Vref setup for Mac Pro 4,1
inv-dmic
    Inverted internal mic workaround
no-primary-hp
    VAIO Z/VGC-LN51JGB workaround (for fixed speaker DAC)
asus-bass
    Bass speaker setup for ASUS ET2700
dual-codecs
    ALC1220 dual codecs for Gaming mobos
clevo-p950
    Fixups for Clevo P950


Code:
[    1.485727]   No soundcards found.
[    1.510674] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input9
[    1.510709] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input10
[    1.510738] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input11
[    1.510765] input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input12
[    1.510793] input: HDA Intel PCH HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input13
[    1.510825] input: HDA Intel PCH HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input14
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44959
Location: 56N 3W

PostPosted: Tue Jun 04, 2019 11:30 am    Post subject: Reply with quote

Fulgurance,

The model parameter is related to how the codec operates.
Its codec specific, not sound card specific.

You have a ALC898 codec.

If sdn-hda-intel is compiled into the kernel, with <*>, it will not appear as a module.
There may be a sdn-hda-intel.o file in the kernel tree though.

Even if your specific system is not mentioned, it may be the same as one that is.
That's trial and error as we don't know which one.

Code:
[    1.485727]   No soundcards found.
is still a worry.
I don't understand how alsamixer shows controls and dmesg says "No soundcards found.".
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4405
Location: Dallas area

PostPosted: Tue Jun 04, 2019 11:56 am    Post subject: Reply with quote

paste you .config file, something is not configure properly
_________________
PRIME x570-pro, 3700x, RX 550 & 560, 5.5.15 zen kernel, gcc 9.3.0
Acer E5-575 (laptop), i3-7100u - i965, 5.0.13 zen kernel, gcc 8.2.0
---both---
profile 17.1 (no-pie & modified) amd64-no-multilib eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7511
Location: Saint Amant, Acadiana

PostPosted: Tue Jun 04, 2019 12:05 pm    Post subject: Reply with quote

Quote:
I don't understand how alsamixer shows controls and dmesg says "No soundcards found.".

I think this happens when ALSA is built in, but hardware specific drivers are built as modules.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum