Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto) [udev 240] errore recupero backup.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
ilnanny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2017
Posts: 115
Location: Italy/Taranto

PostPosted: Mon May 20, 2019 10:54 am    Post subject: [Risolto) [udev 240] errore recupero backup. Reply with quote

Salve .
Oggi ho dovuto ripristinare un backup perchè per causa forza maggiore :oops: ho dovuto formattare la partizione di root dove è installato gentoo.
Ma quando provo a ricostruire grub da chroot ottengo un messaggio di errore che và in loop all'infinito:

Code:

Installazione per la piattaforma i386-pc.
Installazione completata, nessun errore segnalato.
Generazione file di configurazione GRUB...
Tema trovato: /boot/grub/themes/Vimix/theme.txt
Trovata immagine linux: /boot/kernel-genkernel-x86_64-5.0.10-gentoo
Trovata immagine initrd: /boot/initramfs-genkernel-x86_64-5.0.10-gentoo
Trovata immagine linux: /boot/kernel-genkernel-x86_64-4.19.27-gentoo-r1
Trovata immagine initrd: /boot/initramfs-genkernel-x86_64-4.19.27-gentoo-r1
  WARNING: Device /dev/sda not initialized in udev database even after waiting 10000000 microseconds.
  WARNING: Device /dev/sda1 not initialized in udev database even after waiting 10000000 microseconds.
  WARNING: Device /dev/sda2 not initialized in udev database even after waiting 10000000 microseconds.
  WARNING: Device /dev/sda3 not initialized in udev database even after waiting 10000000 microseconds.
  WARNING: Device /dev/sdb not initialized in udev database even after waiting 10000000 microseconds.
  WARNING: Device /dev/sdb1 not initialized in udev database even after waiting 10000000 microseconds.
  WARNING: Device /dev/sdb2 not initialized in udev database even after waiting 10000000 microseconds.
  WARNING: Device /dev/sdb3 not initialized in udev database even after waiting 10000000 microseconds.
  WARNING: Device /dev/sdb4 not initialized in udev database even after waiting 10000000 microseconds.
  WARNING: Device /dev/sdc not initialized in udev database even after waiting 10000000 microseconds.
  WARNING: Device /dev/sdc1 not initialized in udev database even after waiting 10000000 microseconds.
  WARNING: Device /dev/sdc2 not initialized in udev database even after waiting 10000000 microseconds.
  WARNING: Device /dev/sdd not initialized in udev database even after waiting 10000000 microseconds.
  WARNING: Device /dev/sdd1 not initialized in udev database even after waiting 10000000 microseconds.
  WARNING: Device /dev/sdd2 not initialized in udev database even after waiting 10000000 microseconds.
  WARNING: Device /dev/sdd3 not initialized in udev database even after waiting 10000000 microseconds.
  WARNING: Device /dev/sde not initialized in udev database even after waiting 10000000 microseconds.
  WARNING: Device /dev/sde1 not initialized in udev database even after waiting 10000000 microseconds.
  WARNING: Device /dev/sde2 not initialized in udev database even after waiting 10000000 microseconds.
 

e ancora ...va in loop cosi fino alla fine del mondo .
Che cavolo ho combinato ?
===
Eseguo il backup con :
Code:

  tar -cjpP --ignore-failed-read --exclude=/home/*/.bash_history --exclude=/dev/* --exclude=/media/* --exclude=/mnt/*/* --exclude=/proc/* --exclude=/run/* --exclude=/sys/* --exclude=/tmp/* --exclude=/usr/portage/* --exclude=/var/lock/* --exclude=/var/log/* --exclude=/var/run/* --exclude=media/Dati/backup1.tar.bz2 -f /media/Dati/backup_genbox.tar.bz2 /*
 

Recupero il backup con :
Code:

  tar xvjpf backup_genbox.tar.bz2 -C /run/media/ilnanny/Gentoo/
 

che è la partizione (/dev/sda2)formattata precedentemente in ext4 e montata.

___________
Ho aggiustato fstab in quanto è cambiato l'UUID ,ma niente ,ho provato anche ad inserire /dev/sda2 al posto di uuid ma appare lo stesso errore.
cat /etc/fstab
Code:

#==================================================================================================
## ==          ==          ==        Fstab   Gentoo          ==          ==          ==          ==
#==================================================================================================
## ==    FILESYSTEM VIRTUALE
#==================================================================================================
#/dev/cdrom         /mnt/cdrom       auto         noauto,owner,ro,comment=x-gvfs-show     0  0
#devpts             /dev/pts         devpts       gid=5,mode=620               0   0
#proc               /proc            proc         defaults                     0   0
#tmpfs              /dev/shm         tmpfs        defaults                     0   0
#==================================================================================================
## == FILESYSTEM UUID
#==================================================================================================
## ==sdb1: LABEL=boot
# UUID=B769-DFA3     /boot    vfat   noauto,noatime       1  2

## ==sda2-LABEL=GentOpenBox
#UUID=729a0747-2c84-4f19-9e17-47eb7e192e43       /    ext4   rw,errors=remount-ro   0  1

## ==sdb1: LABEL=swap
#UUID=288740bb-d074-4395-b9ff-117f10b4ed56     swap    swap   sw   0  0
#==================================================================================================
## == FILESYSTEM DEV
#==================================================================================================
#/dev/sda1      /boot      vfat      noauto,noatime   1  2
/dev/sda2      /           ext4      rw,errors=remount-ro   0  1
/dev/sdb1      none      swap      sw      0  0
#==================================================================================================
## == FILESYSTEM NTFS
#==================================================================================================

## ==sdc1: LABEL=Dati
UUID=76CDC3FF57CBA78E   /media/Dati   ntfs-3g   defaults,rw,uid=1000,locale=it_IT.UTF-8   0   0

#==================================================================================================


Ho provato a farlo partire da grub ,rigenerato da un altro os.linux ,ma non mi trova la partizione di root

Magari rigenerare il kernel ?
_________________
== Lila-HD-icon-theme ==
https://github.com/ilnanny/Lila-HD-icon-theme


Last edited by ilnanny on Mon May 20, 2019 11:40 am; edited 3 times in total
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 791

PostPosted: Mon May 20, 2019 11:30 am    Post subject: Reply with quote

Leggendo un pò in giro , sembrerebbe un problema con >=udev-240

Portandolo alla versione 239 sembra risolva.
_________________
BOINC ed il calcolo distribuito

My LiveRecoverySystem Repo
Back to top
View user's profile Send private message
ilnanny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2017
Posts: 115
Location: Italy/Taranto

PostPosted: Mon May 20, 2019 11:37 am    Post subject: Reply with quote

sabayonino wrote:
Leggendo un pò in giro , sembrerebbe un problema con >=udev-240

Portandolo alla versione 239 sembra risolva.

Grazie mille Sabayonino .
_________________
== Lila-HD-icon-theme ==
https://github.com/ilnanny/Lila-HD-icon-theme
Back to top
View user's profile Send private message
ilnanny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2017
Posts: 115
Location: Italy/Taranto

PostPosted: Mon May 20, 2019 1:15 pm    Post subject: Reply with quote

OT:

@Sabayonino ,stò scaricando la tua live recovery ,..ma hai fatto qualche guida in giro per il web ? in itaGliano spero :D
Vorrei farne una con gli strumenti che utilizzo e con un interfaccia che parli la mia lingua .magari posso metterla su una chiavetta e portarmela in giro a mò di coltellino svizzero.
_________________
== Lila-HD-icon-theme ==
https://github.com/ilnanny/Lila-HD-icon-theme
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 791

PostPosted: Mon May 20, 2019 6:16 pm    Post subject: Reply with quote

Non c'è niente di mio .
E' solo una SRCD aggiornata.
_________________
BOINC ed il calcolo distribuito

My LiveRecoverySystem Repo
Back to top
View user's profile Send private message
ilnanny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2017
Posts: 115
Location: Italy/Taranto

PostPosted: Tue May 21, 2019 12:48 am    Post subject: Reply with quote

ok grazie oltre che funzionale è anche bello il look .
_________________
== Lila-HD-icon-theme ==
https://github.com/ilnanny/Lila-HD-icon-theme
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum