Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
I have to restart XDM after each suspend
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
BlueManCZ
n00b
n00b


Joined: 11 Mar 2017
Posts: 18

PostPosted: Sat May 25, 2019 8:24 am    Post subject: I have to restart XDM after each suspend Reply with quote

I have fresh Gentoo with linux-4.19.44-gentoo kernel, working 430.14 nvidia driver (GTX 1060), OpenRC as init system and GDM as display manager.

Nvidia drivers configured according to this guide.

Each time I suspend system and then wake it up, the monitor also wakes up, but remains black. I can't switch to any TTY, but system is running and I can connect to SSH server. Keyboard also looks frozen, I can't even switch numlock.

:idea: I found one working workaround by restarting xdm:
Code:
/etc/init.d/xdm stop
/etc/init.d/xdm start

Then I can sign up to a new session and right after that Gnome locks my session. (This should be done before suspend.)

Where can be problem? This didn't occur with default nouveau driver.

I'll be glad for any help.

Edit #1
I just figured out I can suspend and wakeup without problem as root with acpid:
Code:
echo -n "mem" > /sys/power/state

But Gnome suspend button causes problem described above.
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 711
Location: Earth

PostPosted: Sat May 25, 2019 10:14 am    Post subject: Re: I have to restart XDM after each suspend Reply with quote

BlueManCZ wrote:
Where can be problem?

Sounds like this issue.

Quite a few people have been affected but we haven't pinpointed the cause.

I would suggest downgrading sys-auth/elogind to 239.4 (at least).
_________________
Dantrell B.
Back to top
View user's profile Send private message
BlueManCZ
n00b
n00b


Joined: 11 Mar 2017
Posts: 18

PostPosted: Sat May 25, 2019 11:13 am    Post subject: Reply with quote

Thank you, I didn't notice this thread.

But downgrade with:
Code:
emerge --ask --oneshot =sys-auth/elogind-239.4

didn't help. The problem still persists. It's strange. I don't even know what logs to look at.

I have dbus-1.12.12-r1.
Back to top
View user's profile Send private message
BlueManCZ
n00b
n00b


Joined: 11 Mar 2017
Posts: 18

PostPosted: Sat May 25, 2019 12:30 pm    Post subject: Reply with quote

For now I just created script suspend.sh
Code:
#!/bin/bash
xdg-screensaver lock
sleep 0.5
sudo pm-suspend

(allowed pm-suspend in sudoers without password)
and set it on a keyboard shortcut, because I don't really use GUI for suspending. :roll:

But It would be great figure out, where the problem is.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum