Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Workstation 12 Pro / Fedora30 /Docker / Gentoo proxy trouble
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
crisdean
n00b
n00b


Joined: 24 Jul 2009
Posts: 52

PostPosted: Wed May 15, 2019 12:10 pm    Post subject: Workstation 12 Pro / Fedora30 /Docker / Gentoo proxy trouble Reply with quote

Hi all,

Nowthat I managed to get Docker t pull images I thought it might be nice (for internal development purposes) to run Gentoo and play around with a few settings.

However, I run into some issues. Let me provide some details first:

VMware Workstation Pro 12 running Fedora 30 (behind corporate proxy and internet working) - no auth required

Docker details:
Client: Docker Engine - Community
Version: 19.03.0-beta4
API version: 1.40
Go version: go1.12.4
Git commit: e4666ebe81
Built: Tue May 14 12:46:59 2019
OS/Arch: linux/amd64
Experimental: false

Server:
Engine:
Version: 19.03.0-beta1
API version: 1.40 (minimum version 1.12)
Go version: go1.11.5
Git commit: 62240a9
Built: Thu Apr 4 19:17:37 2019
OS/Arch: linux/amd64
Experimental: false
containerd:
Version: 1.2.4
GitCommit:
runc:
Version: 1.0.0-rc7+dev
GitCommit: d38f8a2d00ff444e52d16ab1ea5bbe5c1cb471e8
docker-init:
Version: 0.18.0
GitCommit: fec3683[/code][/code]

I ran Docker images of Ubuntu (and configured the corporate proxy in Ubuntu as per instructions you find on the internet) and that worked fine.

Now I’m having some more issues on my hands. I pulled gentoo/stage3-amd64 and so far so good. But I’m having issues connecting to the internet. According to the Gentoo handbook, I tried an export http_proxy with the proxy I use for a variety of RHEL, CentOS and Ubuntu Linux distros which can use the proxy and allow me to download, update and upgrade packages.

Gentoo, however, doesn’t seem to like it. I need to download some software and because of the resistance to connect to the internet, I’m stuck right now.

What I want to check

Right now the network seems to be the default bridge network via the docker0 interface. I don’t have reason to believe that this failed as I can use it on configured systems to set up the proxy

Tried to use host network but no luck either

Could someone help me please as I’ve been spending at least 12 hours of troubleshooting but am nonthewiser.

Let me know if you require any more information from my side.


Code:
emerge --sync

b76faa734296 / # emerge --sync
>>> Syncing repository 'gentoo' into '/usr/portage'...
 * Using keys from /usr/share/openpgp-keys/gentoo-release.asc
 * Refreshing keys from keyserver ...OpenPGP keyring refresh failed:
gpg: refreshing 4 keys from hkps://hkps.pool.sks-keyservers.net
gpg: keyserver refresh failed: Server indicated a failure

OpenPGP keyring refresh failed:
gpg: refreshing 4 keys from hkps://hkps.pool.sks-keyservers.net
gpg: keyserver refresh failed: Server indicated a failure

OpenPGP keyring refresh failed:
gpg: refreshing 4 keys from hkps://hkps.pool.sks-keyservers.net
gpg: keyserver refresh failed: Server indicated a failure

OpenPGP keyring refresh failed:
gpg: refreshing 4 keys from hkps://hkps.pool.sks-keyservers.net
gpg: keyserver refresh failed: Server indicated a failure

OpenPGP keyring refresh failed:
gpg: refreshing 4 keys from hkps://hkps.pool.sks-keyservers.net
gpg: keyserver refresh failed: Server indicated a failure

OpenPGP keyring refresh failed:
gpg: refreshing 4 keys from hkps://hkps.pool.sks-keyservers.net
gpg: keyserver refresh failed: Server indicated a failure

OpenPGP keyring refresh failed:
gpg: refreshing 4 keys from hkps://hkps.pool.sks-keyservers.net
gpg: keyserver refresh failed: Server indicated a failure

!!! Manifest verification impossible due to keyring problem:
OpenPGP keyring refresh failed:
gpg: refreshing 4 keys from hkps://hkps.pool.sks-keyservers.net
gpg: keyserver refresh failed: Server indicated a failure

q: Updating ebuild cache for /usr/portage ...
q: Finished 0 entries in 0.000040 seconds

 * IMPORTANT: 14 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


Action: sync for repo: gentoo, returned code = 1

 * An update to portage is available. It is _highly_ recommended
 * that you update portage now, before any other packages are updated.

 * To update portage, run 'emerge --oneshot portage' now.



b76faa734296 / # emerge --oneshot portage


!!! /etc/portage/make.profile is not a symlink and will probably prevent most merges.
!!! It should point into a profile within /usr/portage/profiles/
!!! (You can safely ignore this message when syncing. It's harmless.)


!!! Your current profile is invalid. If you have just changed your profile
!!! configuration, you should revert back to the previous configuration.
!!! Allowed actions are limited to --help, --info, --search, --sync, and
!!! --version.



Can anyone help me in how to fix this please? I tried an export http_proxy="name and port of my proxy" but it fails
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 6728

PostPosted: Wed May 15, 2019 1:23 pm    Post subject: Reply with quote

Put sync-rsync-verify-metamanifest = no in your repos.conf to disable all sync security. Yes, it's as ridiculous as it sounds but Portage doesn't document any other way. Best to file a bug about it.
Back to top
View user's profile Send private message
crisdean
n00b
n00b


Joined: 24 Jul 2009
Posts: 52

PostPosted: Wed May 15, 2019 3:08 pm    Post subject: Reply with quote

Ant P. wrote:
Put sync-rsync-verify-metamanifest = no in your repos.conf to disable all sync security. Yes, it's as ridiculous as it sounds but Portage doesn't document any other way. Best to file a bug about it.


Thank you that helped a million!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum