Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] ksplashqml crashes with kernel 5.0.1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
cfgauss
Guru
Guru


Joined: 18 May 2005
Posts: 575
Location: USA

PostPosted: Fri May 03, 2019 4:22 am    Post subject: [SOLVED] ksplashqml crashes with kernel 5.0.1 Reply with quote

My kernel 5.0.0 boots KDE normally. To compile kernel 5.0.1 I copied the .config from 5.0.0 and then ran make oldconfig. This added nothing so the two .configs are the same. However, booting from 5.0.1 crashes with a KCrash window identifiying ksplashqml as the culprit.

Any debugging hints will be gratefully received.

[SOLVED] I had (foolishly) forgotten to emerge @module-rebuild in the new kernel so I had no nvidia driver. After doing so, it boots X/KDE normally. [/SOLVED]


Last edited by cfgauss on Sun May 05, 2019 3:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
cfgauss
Guru
Guru


Joined: 18 May 2005
Posts: 575
Location: USA

PostPosted: Sat May 04, 2019 2:06 pm    Post subject: Reply with quote

On the KDE Wiki page it states that only one of elogind and consolekit is allowed and that consolekit is "preferred" since it's the default for the desktop/plasma profile (which I have). But
Code:
$ equery depends elogind
 * These packages depend on elogind:
media-sound/pulseaudio-12.2-r1 (elogind ? sys-auth/elogind)
net-im/skypeforlinux-8.34.0.78-r2 (sys-auth/elogind)
net-misc/modemmanager-1.10.0 (elogind ? sys-auth/elogind)
net-misc/networkmanager-1.16.0 (elogind ? >=sys-auth/elogind-219)
sys-apps/accountsservice-0.6.50-r1 (elogind ? >=sys-auth/elogind-229.4)
sys-apps/dbus-1.12.12-r2 (elogind ? sys-auth/elogind)
sys-auth/pambase-20190402 (elogind ? sys-auth/elogind[pam])
sys-auth/polkit-0.116 (elogind ? sys-auth/elogind)
sys-fs/udisks-2.8.2 (elogind ? >=sys-auth/elogind-219)
sys-process/procps-3.3.15-r1 (elogind ? sys-auth/elogind)
x11-base/xorg-server-1.20.4 (elogind ? sys-auth/elogind)
x11-misc/sddm-0.18.1 (elogind ? sys-auth/elogind)

all of which I want installed.

So, do I need to have both elogind and consolekit installed? Would having both installed cause any difficulties?

Thanks for any clarification.
Back to top
View user's profile Send private message
cfgauss
Guru
Guru


Joined: 18 May 2005
Posts: 575
Location: USA

PostPosted: Sat May 04, 2019 7:17 pm    Post subject: Reply with quote

Using Systemsettings > Workspace Theme > Splash Screen > None the crash has shifted to other KDE processes: krunner, kinit, etc. I re-emerged KDE with
Code:
# emerge -1 $(qlist -I kde-)

but still get the aforementioned KDE crashes.

Are there any log files which might shed some light on this problem?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum