Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
starting apache: Code: Bad RIP value
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
guid0
Guru
Guru


Joined: 06 Jul 2003
Posts: 334
Location: The Netherlands / Nederland

PostPosted: Sun Aug 18, 2019 3:42 pm    Post subject: starting apache: Code: Bad RIP value Reply with quote

Something i have worked around for quite a while now but finally found the time to dig into this. However with little to zero progress on the issue yet.

When i start the server it goes through its regular reboot before it tries to start apache.

Code:
[   32.233166] /usr/sbin/apach[3918]: segfault at 7f137b3d1190 ip 00007f137b3d1190 sp 00007ffefaad36b8 error 14 in locale-archive[7f137fef6000+4a5000]
[   32.233173] Code: Bad RIP value.


The apache start fails and above lines are found in the kernel dmesg.

In /etc/conf.d/apache2 i have:

Code:
APACHE2_OPTS="-D SSL_DEFAULT_VHOST -D SSL -D PERL"


When i then log into the machine and run:

Code:
/usr/sbin/apache2 -D PERL -D SSL -k start


manually, all is fine and the service is up and running.

Anyone an idea on which direction to dig?

Cheers,
guid0
Back to top
View user's profile Send private message
alamahant
Guru
Guru


Joined: 23 Mar 2019
Posts: 555

PostPosted: Mon Aug 19, 2019 5:54 pm    Post subject: Reply with quote

Why do you invoke the binary directly?
Dont you have an openrc or systemd file to do that?
Something like
Code:

/etc/init.d/apache2 start or
systemctl start apache2

Is this a docker container?
Back to top
View user's profile Send private message
guid0
Guru
Guru


Joined: 06 Jul 2003
Posts: 334
Location: The Netherlands / Nederland

PostPosted: Mon Aug 19, 2019 6:31 pm    Post subject: Reply with quote

Sorry, forgot to add more info. I have been debugging this for a while and seem to have lost whats important and whats not.

Its an openrc configured server. No NFS:

Code:
/etc/init.d/apache2 start
 * apache2 has detected an error in your setup:
Syntax OK
 * ERROR: apache2 failed to start


which simply triggers another RIP

Quote:
[356482.607342] /usr/sbin/apach[4680]: segfault at 7f26ec790190 ip 00007f26ec790190 sp 00007fff6a22af88 error 14 in locale-archive[7f26f12b5000+4a5000]
[356482.607350] Code: Bad RIP value.


- guid0
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum