Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
RTL8821AE no longer detected
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
tenspd1370
Tux's lil' helper
Tux's lil' helper


Joined: 14 Dec 2017
Posts: 97

PostPosted: Tue Apr 30, 2019 3:20 pm    Post subject: RTL8821AE no longer detected Reply with quote

Hi all

After an emerge -uaVDN @world, my RTL8821AE is no longer even detected by lspci. At first I thought it was because I upgraded my kernel from 4.20.7 to 5.0.9, but I made sure that I had all the CONFIG*RTL* modules that I had in 4.20.7 checked in 5.0.9. I know it worked before because I have been using the wifi device on this desktop for about a year now. I suspect it is something is missing from the current linux-firmware package because when I dropped back to my 4.20.7 kernel, I had the same behavior as the 5.0.9. Please forgive me - I am at work running from memory right now. I can post any configurations necessary tonight once I find a network cable I can run across my living room tonight, but for now I am going from memory. Things I noticed:

1. As I mentioned above, before updating, lspci listed the device, after it does not
2. lsusb shows a bluetooth device, which makes sense because before I had both working, but rarely used the bluetooth
3. kernel dmesg shows rtl8821a_config.bin as missing - I have read that that may not actually be necessary for wifi
4. I tried turning off bluetooth in the kernel all together and just leaving wireless rtl8821ae modules checked, didn't help

Does anyone know of anything or seen anything similar that they might know a solution that I could try before I dig out network cables? Otherwise, please let me know what configurations you may need to see if you think you can help. I am all out of ideas, but would like to figure this out. I don't think the dogs will let me leave a cable running across my living room :)

Thanks!
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7517
Location: Saint Amant, Acadiana

PostPosted: Tue Apr 30, 2019 3:24 pm    Post subject: Reply with quote

If this is a PCI device and it does not show up in lspci then it is dead (or disabled in hardware).
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
tenspd1370
Tux's lil' helper
Tux's lil' helper


Joined: 14 Dec 2017
Posts: 97

PostPosted: Tue Apr 30, 2019 3:45 pm    Post subject: Reply with quote

Hmmm - ok. It may be time to come up with an alternate solution. I don't know why it would die between upgrades though - maybe the missing rtl8821a_config.bin is causing something? Of course, that is always a possibility - I mean, I guess when these things go, they just go - it isn't like they slowly degrade somehow....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum