Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installed Cinnamon, settings bits don't work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
greyspoke
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2010
Posts: 147

PostPosted: Sun Apr 28, 2019 10:27 am    Post subject: Installed Cinnamon, settings bits don't work Reply with quote

Right, after using openbox for ages, I decided to change to something a bit more flashy and chose cinnamon. I followed the wiki, a couple of use changes were required and off I went. ETA - running ~amd64 so it is cinnamon 4.0.3

Cinnamon started fine - I use startx so put exec dbus-launch cinnamon-session in my .xinitrc.

Problem is, many of the settings parts don't work, including the main settings button on the start menu. Click and nothing happens.

Having a bit of a rummage, trying to run the programmes for them (from looking at /usr/bin and the .desktop files) in a terminal I get this sort of thing:

Code:
timothy@tims_pc /usr/share/applications $ cinnamon-settings
Traceback (most recent call last):
  File "/usr/share/cinnamon/cinnamon-settings/cinnamon-settings.py", line 610, in <module>
    window = MainWindow()
  File "/usr/share/cinnamon/cinnamon-settings/cinnamon-settings.py", line 248, in __init__
    for module in modules:
  File "/usr/share/cinnamon/cinnamon-settings/modules/cs_backgrounds.py", line 5, in <module>
    import imtools
  File "/usr/share/cinnamon/cinnamon-settings/bin/imtools.py", line 623, in <module>
    if Image.VERSION == '1.1.7':
AttributeError: module 'PIL.Image' has no attribute 'VERSION'


I am running PYTHON_TARGETS="python2_7 python3_6". Looks like I am missing something. I am using the default/linux/amd64/17.0/desktop profile, I wonder if a gnome one might work better.

Anyone also had this, or any ideas?

Thanks.
Back to top
View user's profile Send private message
greyspoke
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2010
Posts: 147

PostPosted: Sun Apr 28, 2019 11:30 am    Post subject: Reply with quote

Well hold your horses folks, much to my surprise I appear to have sorted it by masking dev-python/pillow-6.0.0. I will post a bug about it.
Back to top
View user's profile Send private message
McQ
n00b
n00b


Joined: 27 Jul 2017
Posts: 5

PostPosted: Sun Apr 28, 2019 11:01 pm    Post subject: Reply with quote

I did have the same issue and this particular fix sorted it out:

https://forums.linuxmint.com/viewtopic.php?p=1622330#p1622330
Back to top
View user's profile Send private message
greyspoke
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2010
Posts: 147

PostPosted: Mon Apr 29, 2019 5:01 am    Post subject: Reply with quote

Yes that is the same issue I think. The problem I identified was that in Pillow 6.0.0 onwards the VERSION property is no longer used - this is Image.py
Code:
#
# The Python Imaging Library.
# $Id$
#
# the Image class wrapper
#
# partial release history:
# 1995-09-09 fl   Created
# 1996-03-11 fl   PIL release 0.0 (proof of concept)
# 1996-04-30 fl   PIL release 0.1b1
# 1999-07-28 fl   PIL release 1.0 final
# 2000-06-07 fl   PIL release 1.1
# 2000-10-20 fl   PIL release 1.1.1
# 2001-05-07 fl   PIL release 1.1.2
# 2002-03-15 fl   PIL release 1.1.3
# 2003-05-10 fl   PIL release 1.1.4
# 2005-03-28 fl   PIL release 1.1.5
# 2006-12-02 fl   PIL release 1.1.6
# 2009-11-15 fl   PIL release 1.1.7
#
# Copyright (c) 1997-2009 by Secret Labs AB.  All rights reserved.
# Copyright (c) 1995-2009 by Fredrik Lundh.
#
# See the README file for information on usage and redistribution.
#

# VERSION is deprecated and will be removed in Pillow 6.0.0.
# PILLOW_VERSION is deprecated and will be removed after that.
# Use __version__ instead.
...

Whereas the cinnamon scripts continue to do so eg in /usr/share/cinnamon/cinnamon-settings/imtools.pyit is used
Code:

if Image.VERSION == '1.1.7':
...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum