Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
openssh_8.0p1 - banner line contains invalid characters ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
yoshi314
l33t
l33t


Joined: 30 Dec 2004
Posts: 849
Location: PL

PostPosted: Wed Apr 24, 2019 9:58 am    Post subject: openssh_8.0p1 - banner line contains invalid characters ? Reply with quote

I am totally clueless as to what is going on here :

Code:

ssh lxc-oracle.dc -v
OpenSSH_8.0p1-PKIXSSH-12.0, OpenSSL 1.1.0j  20 Nov 2018
kex_exchange_identification: banner line contains invalid characters




Code:

ssh lxc-oracle.dc -vvvv
OpenSSH_8.0p1-PKIXSSH-12.0, OpenSSL 1.1.0j  20 Nov 2018
debug1: Can't process default engine config file: No such file or directory
debug1: Reading configuration data /home/mkowalski/.ssh/config
debug1: /home/mkowalski/.ssh/config line 152: Applying options for *
debug1: Reading configuration data /etc/ssh/ssh_config
debug2: hash dir '/home/mkowalski/.ssh/crt' added to x509 store
debug2: hash dir '/home/mkowalski/.ssh/crl' added to x509 revocation store
debug2: hash dir '/etc/ssh/ca/crt' added to x509 store
debug2: hash dir '/etc/ssh/ca/crl' added to x509 revocation store
debug1: ssh_set_validator: ignore responder url
debug2: resolving "lxc-oracle.dc" port 22
debug2: ssh_connect_direct
debug1: Connecting to lxc-oracle.dc [172.17.3.214] port 22.
debug1: Connection established.
debug3: sshkey_load_public() filename=/home/mkowalski/.ssh/id_rsa
debug3: sshkey_load_public() filename/2=/home/mkowalski/.ssh/id_rsa.pub
debug3: X509_from_blob: can not read X.509 from memory BIO: 'error:0D0680A8:asn1 encoding routines:asn1_check_tlen:wrong tag'
debug3: key_from_blob(..., ...) ktype=ssh-rsa
debug1: identity file /home/mkowalski/.ssh/id_rsa type 0
debug3: sshkey_load_public() filename=/home/mkowalski/.ssh/id_rsa-cert
debug3: sshkey_load_public() filename/2=/home/mkowalski/.ssh/id_rsa-cert.pub
debug1: identity file /home/mkowalski/.ssh/id_rsa-cert type -1
debug3: sshkey_load_public() filename=/home/mkowalski/.ssh/id_dsa
debug3: sshkey_load_public() filename/2=/home/mkowalski/.ssh/id_dsa.pub
debug1: identity file /home/mkowalski/.ssh/id_dsa type -1
debug3: sshkey_load_public() filename=/home/mkowalski/.ssh/id_dsa-cert
debug3: sshkey_load_public() filename/2=/home/mkowalski/.ssh/id_dsa-cert.pub
debug1: identity file /home/mkowalski/.ssh/id_dsa-cert type -1
debug3: sshkey_load_public() filename=/home/mkowalski/.ssh/id_ecdsa
debug3: sshkey_load_public() filename/2=/home/mkowalski/.ssh/id_ecdsa.pub
debug3: X509_from_blob: can not read X.509 from memory BIO: 'error:0D0680A8:asn1 encoding routines:asn1_check_tlen:wrong tag'
debug3: key_from_blob(..., ...) ktype=ecdsa-sha2-nistp256
debug3: key_from_blob(..., ...) ktype/nid=ecdsa-sha2-nistp256 / 415
debug1: identity file /home/mkowalski/.ssh/id_ecdsa type 4
debug3: sshkey_load_public() filename=/home/mkowalski/.ssh/id_ecdsa-cert
debug3: sshkey_load_public() filename/2=/home/mkowalski/.ssh/id_ecdsa-cert.pub
debug1: identity file /home/mkowalski/.ssh/id_ecdsa-cert type -1
debug3: sshkey_load_public() filename=/home/mkowalski/.ssh/id_ed25519
debug3: sshkey_load_public() filename/2=/home/mkowalski/.ssh/id_ed25519.pub
debug1: identity file /home/mkowalski/.ssh/id_ed25519 type -1
debug3: sshkey_load_public() filename=/home/mkowalski/.ssh/id_ed25519-cert
debug3: sshkey_load_public() filename/2=/home/mkowalski/.ssh/id_ed25519-cert.pub
debug1: identity file /home/mkowalski/.ssh/id_ed25519-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_8.0p1-PKIXSSH-12.0 PKIX[12.0]
kex_exchange_identification: banner line contains invalid characters




i am experiencing this when connecting to some debian installations that used to work just fine beforehand. Anyone has similar problem?
_________________
~amd64
shrink your /usr/portage with squashfs+aufs
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 6474

PostPosted: Wed Apr 24, 2019 5:51 pm    Post subject: Reply with quote

Looks like the remote server is rejecting your client version, but your version string is perfectly valid according to RFC4253 (which does not define "invalid characters"), so it's a bug on their end.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum