Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cant merge opencv ninja -v -j9 -l0 failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
picarica
Tux's lil' helper
Tux's lil' helper


Joined: 11 Aug 2018
Posts: 131

PostPosted: Thu Apr 11, 2019 1:34 pm    Post subject: Cant merge opencv ninja -v -j9 -l0 failed Reply with quote

i cant seem to emerge opencv at all and because of that my belnder2.8 is not working and i need it aSAP for my school project :/ i am posting build.log and info below beacue i tried every trick i have up my sleevee,


and here is --info

and here is -pqv


here is build.log

i am really bummed out from this any ideas ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22338
Location: here

PostPosted: Thu Apr 11, 2019 1:58 pm    Post subject: Reply with quote

The real error is
Code:
In file included from /var/tmp/portage/media-libs/opencv-3.4.1-r5/work/opencv-3.4.1/modules/core/include/opencv2/core/cuda/vec_traits.hpp:46:0,
                 from /var/tmp/portage/media-libs/opencv-3.4.1-r5/work/opencv-3.4.1/modules/cudaoptflow/src/precomp.hpp:55,
                 from /var/tmp/portage/media-libs/opencv-3.4.1-r5/work/opencv-3.4.1/modules/cudaoptflow/src/brox.cpp:43:
/var/tmp/portage/media-libs/opencv-3.4.1-r5/work/opencv-3.4.1/modules/core/include/opencv2/core/cuda/common.hpp:46:10: fatal error: cuda_runtime.h: No such file or directory
 #include <cuda_runtime.h>
          ^~~~~~~~~~~~~~~~
compilation terminated.

What dev-util/nvidia-cuda-toolkit version you installed? Exists cuda_runtime.h file in /opt/cuda (find /opt/cuda -name cuda_runtime.h)?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
picarica
Tux's lil' helper
Tux's lil' helper


Joined: 11 Aug 2018
Posts: 131

PostPosted: Thu Apr 11, 2019 2:09 pm    Post subject: Reply with quote

fedeliallalinea wrote:
The real error is
Code:
In file included from /var/tmp/portage/media-libs/opencv-3.4.1-r5/work/opencv-3.4.1/modules/core/include/opencv2/core/cuda/vec_traits.hpp:46:0,
                 from /var/tmp/portage/media-libs/opencv-3.4.1-r5/work/opencv-3.4.1/modules/cudaoptflow/src/precomp.hpp:55,
                 from /var/tmp/portage/media-libs/opencv-3.4.1-r5/work/opencv-3.4.1/modules/cudaoptflow/src/brox.cpp:43:
/var/tmp/portage/media-libs/opencv-3.4.1-r5/work/opencv-3.4.1/modules/core/include/opencv2/core/cuda/common.hpp:46:10: fatal error: cuda_runtime.h: No such file or directory
 #include <cuda_runtime.h>
          ^~~~~~~~~~~~~~~~
compilation terminated.

What dev-util/nvidia-cuda-toolkit version you installed? Exists cuda_runtime.h file in /opt/cuda (find /opt/cuda -name cuda_runtime.h)?


i have latest nvidia-cuda-toolkit version 10.1.105
and yes
Code:

/opt/cuda/targets/x86_64-linux/include/cuda_runtime.h
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22338
Location: here

PostPosted: Thu Apr 11, 2019 2:24 pm    Post subject: Reply with quote

The problem can be also that you enabled cuda use flag and also abi_x86_32, but this is a wrong option because dev-util/nvidia-cuda-toolkit package is only available on 64bit.
Try to disable abi_x86_32 or cuda use flag to opencv
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
picarica
Tux's lil' helper
Tux's lil' helper


Joined: 11 Aug 2018
Posts: 131

PostPosted: Thu Apr 11, 2019 2:41 pm    Post subject: Reply with quote

fedeliallalinea wrote:
The problem can be also that you enabled cuda use flag and also abi_x86_32, but this is a wrong option because dev-util/nvidia-cuda-toolkit package is only available on 64bit.
Try to disable abi_x86_32 or cuda use flag to opencv


how do i disable abi in .use ?
Code:
media-libs/opencv -cuda ABI_X86="64"

like this ?
Back to top
View user's profile Send private message
picarica
Tux's lil' helper
Tux's lil' helper


Joined: 11 Aug 2018
Posts: 131

PostPosted: Thu Apr 11, 2019 2:56 pm    Post subject: Reply with quote

thank you for help after disabling cuda flag in the .use blender finally starts and opencv merged sccsefully
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum