Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[mostly-solved]ATI Rage 128 small resolution
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
superdeez
n00b
n00b


Joined: 10 May 2015
Posts: 14

PostPosted: Fri Apr 05, 2019 8:14 pm    Post subject: [mostly-solved]ATI Rage 128 small resolution Reply with quote

I have an old machine I like to keep as a spare, which has an old ATI Rage 128 video card.

I'm trying to get it going after letting it sit off too long and since I have done my fresh install, X works great, but my biggest problem is that I am stuck at a 640*480 resolution. Both in my TTYs and X. X runs fine without configuration, but when I do the X -configure route or try to manually set the driver to r128, X crashes.

If I boot the liveCD, it comes up with framebuffer ttys at 1024*768. I have the aty128fb module loaded under both liveCD and in my kernel config. If I do X -configure, I get the error of
Code:
(II) AMDGPU(0): [KMS] drm report modesetting isn't supported


My guess is modesetting is the issue, I have searched and searched, but most of the information I find on this issue is years old and points to closed source ATI drivers that are no longer available or to kernel configs for the 2.6 kernel, etc.

Is this just a kernel config issue or has support just waned for these cards to where I'd be better off replacing the card with an NvidiaI have laying around? I like to keep this machine around as a spare because it's a Pentium 4 with support for USB and dual floppies. That 5.25" drive helps with keeping a couple of 286/386 toys going.


Last edited by superdeez on Tue Apr 16, 2019 3:13 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42564
Location: 56N 3W

PostPosted: Fri Apr 05, 2019 8:47 pm    Post subject: Reply with quote

superdeez,

Code:
X -configure
has been broken for many years.
Its been replaced almost entirely by automatic detection of hardware.

AMDGPU isn't for ATI Rage 128 cards.

Move your xorg.conf file out of the way, so the automaics do there thing, then try startx.

Put the /var/log/Xorg.0.log file on to a pastebin ... try wgetpaste.
Post the link you get back.

Post your make.conf fle too please.

You need DRM_R128 in your kernel for DRM support. See
Code:
  │ Symbol: DRM_R128 [=n]                                                                                                                                                             │ 
  │ Type  : tristate                                                                                                                                                                  │ 
  │ Prompt: ATI Rage 128                                                                                                                                                              │ 
  │   Location:                                                                                                                                                                       │ 
  │     -> Device Drivers                                                                                                                                                             │ 
  │       -> Graphics support                                                                                                                                                         │ 
  │ (1)     -> Enable legacy drivers (DANGEROUS) (DRM_LEGACY [=n])                                                                                                                    │ 
  │   Defined at drivers/gpu/drm/Kconfig:363                                                                                                                                          │ 
  │   Depends on: HAS_IOMEM [=y] && DRM_LEGACY [=n] && DRM [=y] && PCI [=y]                                                                                                           │ 
  │   Selects: FW_LOADER [=y]                             

_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
superdeez
n00b
n00b


Joined: 10 May 2015
Posts: 14

PostPosted: Sat Apr 06, 2019 8:50 pm    Post subject: Reply with quote

Thank you, NeddySeagoon

Using strictly the r128 module did work, but it made X display a resolution larger than my display is cappable of displaying.

I tried
Code:
 sleep 10 && xrandr --display 0 --fb 1280x1024

and
Code:
 sleep 10 && xrandr --screen 0 --fb 1280x1024
and invariably I get

Code:
 can't open display


The sleep command is in there to allow me to switch to tty7. I even tried it from the tty I ran startx from, still with the same results.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42564
Location: 56N 3W

PostPosted: Sat Apr 06, 2019 10:24 pm    Post subject: Reply with quote

superdeez,

There are several things going on here.

1) What you asked Xorg to do.
2) What it actually did.

Please post your /var/log/Xorg.0.log file. That will show what Xorg did.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
superdeez
n00b
n00b


Joined: 10 May 2015
Posts: 14

PostPosted: Sun Apr 07, 2019 4:41 pm    Post subject: Reply with quote

After a reboot X began to work, but it also made things worse. It began giving me a blank screen my display could output, but it completely locks the local console, such that a reboot via SSH is required.

Xorg.0.log is available here: http://dpaste.com/02EH543
make.conf is available here: http://dpaste.com/2PYRG9M
my .config is also available here: http://dpaste.com/0DC2X81

Thanks again for all of the help, NeddySeagoon. Do you think it would be eaiser to just put another card in this machine? I have a couple of other cards lying around here somewhere.

[Moderator edit: fixed links. Forum auto-linking does not work when the URL contains quotes. -Hu]
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42564
Location: 56N 3W

PostPosted: Sun Apr 07, 2019 5:47 pm    Post subject: Reply with quote

superdeez,

From your Xorg.0.log
Code:
[    32.371] (==) Matched ati as autoconfigured driver 0
[    32.371] (==) Matched modesetting as autoconfigured driver 1
[    32.371] (==) Matched fbdev as autoconfigured driver 2
[    32.371] (==) Matched vesa as autoconfigured driver 3

Good. Xorg is using the automatic detection and configuration.

Code:
[    32.380] (EE) open /dev/fb0: No such file or directory

means that your kernel has a bit missing.

Code:
[    32.775] (II) R128(0): Manufacturer: DEL  Model: 4000  Serial#: 1094267953
[    32.775] (II) R128(0): Year: 2003  Week: 31
[    32.775] (II) R128(0): EDID Version: 1.3
it found your display which advertised
Code:
[    32.775] (II) R128(0): Supported established timings:
[    32.775] (II) R128(0): 720x400@70Hz
[    32.775] (II) R128(0): 640x480@60Hz
[    32.775] (II) R128(0): 640x480@75Hz
[    32.775] (II) R128(0): 800x600@60Hz
[    32.775] (II) R128(0): 800x600@75Hz
[    32.775] (II) R128(0): 1024x768@60Hz
[    32.776] (II) R128(0): 1024x768@75Hz
[    32.776] (II) R128(0): 1280x1024@75Hz

So 1280x1024 was selected.
Code:
[    32.936] (II) R128(0): Output VGA-0 using initial mode 1280x1024 +0+0


Its using the new drm so the error above can be ignored.
Code:
[    33.024] drmOpenDevice: node name is /dev/dri/card0
[    33.024] drmOpenDevice: open result is 12, (OK)


It all seems to be correct but
Code:
[    33.032] (WW) R128(0): Direct rendering disabled

that's a major slowdown. Possibly a permissions issue.

Right at the end
[
Code:
    33.389] (EE)
[    33.389] (EE) Backtrace:
and the log is truncated.

Only members of the video group are permitted to use direct rendering, as it needs hardware access.
As your normal user what does the groups command output?
I get
Code:
$ groups
tty wheel uucp audio cdrom video games kvm cdrw usb users vboxusers scanner wireshark plugdev roy

You need to see video in your list of groups. If not, add yourself and reboot.
audio allows access to the sound hardware.

make.conf is OK but can be improved.
Code:
COMMON_FLAGS="-O2 -march=i686 -pipe"

That will produce code that will run on any i686 CPU, from the PentuimPro onwards. Unless you want to share code with other systems, -march=native will make better use of your CPU.
-O2 turns on all optimisations that do not increase code size.
Consider -Os instead. It optimises for size, so that programs load faster and execute faster and the smaller code is more likely to fit in the CPU cache.
-pipe is harmless. It requests gcc to pass intermediate files using pipes instead of writing files to disk. Disk files will be used if there is not enough RAM.

You should add CPU_FLAGS_X86= to make.conf.
Code:
emerge app-portage/cpuid2cpuflags
, that will convert /proc/cpuinfo for you.
These settings turn on hand optimised code sections in a few programs. Mostly multimedia and crypto.

Your kernel is built for a Pentium4
Code:
CONFIG_MPENTIUM4=y
, so -march=native will help userspace.
You need not rebuild everything is one go. Allow the the instructions set improvements to come is as you update.

Turn off
Code:
CONFIG_IDE=m
The IDE subsystem is old and unmaintained. Its all been moved to libsata.
All the options that were on the IDE menu are on the SATA menu now. You should migrate.

Code:
CONFIG_AGP=y
# CONFIG_AGP_ALI is not set
CONFIG_AGP_ATI=m
CONFIG_AGP_AMD=m
# CONFIG_AGP_AMD64 is not set
# CONFIG_AGP_INTEL is not set
looks wrong.
The CONFIG_AGP_ here refers to your motherboard chipset, not your GPU.
Post the output of
Code:
lspci -nnk
With a P4 processor, its unlikely you have either an ATI or AMD motherboard chipset.

That's the only queries in your kernel .config. It can be pruned some but its probably not worth the compile time unless you are rebuilding for other reasons.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
superdeez
n00b
n00b


Joined: 10 May 2015
Posts: 14

PostPosted: Mon Apr 08, 2019 8:37 am    Post subject: Reply with quote

The output of
Code:
 lspci -nnk

Can be found at http://dpaste.com/00AF3G5
Back to top
View user's profile Send private message
superdeez
n00b
n00b


Joined: 10 May 2015
Posts: 14

PostPosted: Mon Apr 08, 2019 8:49 am    Post subject: Reply with quote

My user is in the video group. Additionally I put root in that group because the console crash was occurring either with startx from my user or when xdm started.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42564
Location: 56N 3W

PostPosted: Mon Apr 08, 2019 9:12 am    Post subject: Reply with quote

superdeez,

You have an Intel motherboard chipset.

Code:
00:00.0 Host bridge [0600]: Intel Corporation 82845 845 [Brookdale] Chipset Host Bridge [8086:1a30] (rev 03)

so you need to turn on
Code:
# CONFIG_AGP_INTEL is not set
in your kernel.
Both
Code:
CONFIG_AGP_ATI=m
CONFIG_AGP_AMD=m
are not required but are harmless.


Code:
00:1f.1 IDE interface [0101]: Intel Corporation 82801BA IDE U100 Controller [8086:244b] (rev 12)
   Subsystem: Hewlett-Packard Company 82801BA IDE U100 Controller [103c:2440]
   Kernel driver in use: ata_piix


Your HDD should be /dev/sd<something>. If it is, turn off
Code:
CONFIG_IDE=m
as you are not using it anyway.
If your HDD is /dev/hd<something> the transition is a bit more painful an both grub.cfg and /etc/fstab need to change.
Your HDD will become /dev/sd..
Your kernel says
Code:
# SATA SFF controllers with BMDMA
#
CONFIG_ATA_PIIX=y
so you already have libata support for your HDD.

Your USB hardware is
Code:
00:1f.2 USB controller [0c03]: Intel Corporation 82801BA/BAM UHCI USB 1.1 Controller #1 [8086:2442] (rev 12)
   Subsystem: Hewlett-Packard Company 82801BA/BAM UHCI USB 1.1 Controller [103c:2440]
   Kernel driver in use: uhci_hcd
Thats Intel USB 1.1
Code:
CONFIG_USB_EHCI_HCD=y
is for USB 2, so you don't need that.
Code:
CONFIG_USB_OHCI_HCD=y
CONFIG_USB_OHCI_HCD_PCI=y
is non Intel USB 1.1, so thats not needed either.

The driver for your sound is either missing or not loaded
Code:
00:1f.5 Multimedia audio controller [0401]: Intel Corporation 82801BA/BAM AC'97 Audio Controller [8086:2445] (rev 12)
   Subsystem: Hewlett-Packard Company 82801BA/BAM AC'97 Audio Controller [103c:127a]

Its AC97, which is
Code:
CONFIG_SND_INTEL8X0
in the kernel. That's off just now
Code:
# CONFIG_SND_INTEL8X0 is not set


Do not edit the kernel .config by hand. Use menuconfig and the search.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
superdeez
n00b
n00b


Joined: 10 May 2015
Posts: 14

PostPosted: Tue Apr 09, 2019 6:04 pm    Post subject: Reply with quote

NeddySeagoon,

Firstly, thank you very much for the help you have provided thus far.

I turned off IDE and got the module for the Intel chipset working, but still no changes.

I may have to give up on that machine for awhile because an update of @world on my main box has now broken X on it.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42564
Location: 56N 3W

PostPosted: Tue Apr 09, 2019 7:26 pm    Post subject: Reply with quote

superdeez,

Gentoo is a hobby for most people, including me. I keep an eye on my posts, so I should see it when you post again.
Feel free to PM a link to your post if I miss it.

Even if it looks the same, please post the Xorg.0.log and the output of dmesg.
Fixing your kernel may have changed the logs, which in turn, would be a pointer to the next step.

Meanwhile, enjoy your Gentoo.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
superdeez
n00b
n00b


Joined: 10 May 2015
Posts: 14

PostPosted: Tue Apr 09, 2019 10:13 pm    Post subject: Reply with quote

Gentoo is my main OS. I first cut my teeth in Red Hat 16 years ago, then a cousin turned me on to Gentoo. I've played with the other distros, but Gentoo is the one I know the best.

I installed this machine in a hurry, I think I'll just re-do it once I get the main box working again
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42564
Location: 56N 3W

PostPosted: Wed Apr 10, 2019 6:32 pm    Post subject: Reply with quote

superdeez,

Theses not much wrong with your install.

I gave up Red Hat in 2002 and found Gentoo.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
superdeez
n00b
n00b


Joined: 10 May 2015
Posts: 14

PostPosted: Tue Apr 16, 2019 3:00 am    Post subject: Reply with quote

NeddySeagoon,

I ran X -retro and it did give me a fully usable display. It even got dri working, but it still ignores all of my input devices.

I've looked through Xorg.0.log (http://pastebin.com/3PBK7EZ) and I can't quite see where it drops my keyboard and mouse.

I do apprieciate the help you've given me thus far with this one.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42564
Location: 56N 3W

PostPosted: Tue Apr 16, 2019 8:34 pm    Post subject: Reply with quote

superdeez,

The pastebin has gone. Can you post it again please.

Input devices either use the old kbd and mouse drivers, in which case they are not auto detected, you need to set them up in xorg.conf or the autoblackmagic of evdev, which is in two parts.
The kernel part and the Xorg part. You need both bits.

If you set up both, evdev will be used.
If you set up neither ...
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
superdeez
n00b
n00b


Joined: 10 May 2015
Posts: 14

PostPosted: Wed Apr 17, 2019 8:36 pm    Post subject: Reply with quote

NeddySeagoon,

I had indeed forgotten to setup the X side of evdev. I merged XF86-drivers-evdev and also put
Code:
INPUT_DEVICES="evdev"
into my make.conf. I even did an @world update with the new useflags, but still no dice.

The output of Xorg.0.log is here: http://dpaste.com/31E7ANW
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42564
Location: 56N 3W

PostPosted: Wed Apr 17, 2019 9:16 pm    Post subject: Reply with quote

superdeez,

I'm not totally happy with that Xorg log. I would expect everything to be using /dev/input/event* device nodes not /dev/input/mouse* and or /dev/input/keyboard.

As the log says
Code:
[    68.772] (==) Using config directory: "/etc/X11/xorg.conf.d"
what do you have there?

The output of
Code:
cat /etc/X11/xorg.conf.d/*
would be good.
The file /etc/X11/xorg.conf should not exist but if it does, post its contents too.

I'm looking to get evdev working rather that the obsolete kbd and mouse drivers but the obsolete drivers still work.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
superdeez
n00b
n00b


Joined: 10 May 2015
Posts: 14

PostPosted: Thu Apr 18, 2019 9:35 pm    Post subject: Reply with quote

xorg.conf doesn't exist.

There's two files:
Code:
10evdev,conf
and
Code:
20opengl.conf


The cat of the directory may be found here. http://dpaste.com/31EWTVC
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum