Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GNOME 3.30 for all init systems
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3694
Location: Dallas area

PostPosted: Mon Apr 01, 2019 7:45 pm    Post subject: Reply with quote

Hossie wrote:
I really dont know what happened, but all this steam library madness is really annoying.

But running

Code:
steam --reset


fixes it (it deletes the steam installation, config, etc., but keeps installed games).


Perhaps it cache's some things which get flushed with a reset.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 7.3.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 434
Location: Brazil

PostPosted: Mon Apr 01, 2019 11:55 pm    Post subject: Reply with quote

Hossie wrote:
I really dont know what happened, but all this steam library madness is really annoying.

But running

Code:
steam --reset


fixes it (it deletes the steam installation, config, etc., but keeps installed games).

Yup, problem solved. Nothing to see here.

Thanks for the tip.
Back to top
View user's profile Send private message
Adrien.D
n00b
n00b


Joined: 18 Jan 2015
Posts: 53

PostPosted: Wed Apr 17, 2019 6:12 pm    Post subject: Reply with quote

After steam --reset nor work for me.
Always have
Code:
./steamwebhelper: symbol lookup error: /usr/lib/gio/modules/libdconfsettings.so: undefined symbol: g_log_structured_standard

_________________
AMD Ryzen 5 2600X - 8Go RAM - Radeon RX 560 (amdgpu)
MATE Desktop + sources-4.19.x
Back to top
View user's profile Send private message
rmk88
n00b
n00b


Joined: 31 Mar 2019
Posts: 8

PostPosted: Sat Apr 20, 2019 5:22 pm    Post subject: Reply with quote

Good job guys, good job. Special thanks to Dantrell, who was indeed pioneer in this case.

I was running Dantrell's Gnome 3-30 but got stuck to few problems, tried to switch to this, but things got even stranger. :D I decided to go for fresh install, and after a few package mask for lower version I got it all working just fine. Almost. I have full Vulkan support and can play ex. WoW for +150FPS!

But having problems with Steam. :( Maybe some clue what to next? I have Steam running but I get blank sceen where should be news or such. https://imgur.com/a/p4sMTQM

Otherwise seems to be working just fine! So thanks again. [spoiler]Fuck systemd[/spoiler] :D

P.S. Steam was working previously on Dantrell's Gnome. I tried all the fixes I did previously. steam --reset did not solve this issue. :(
Back to top
View user's profile Send private message
rmk88
n00b
n00b


Joined: 31 Mar 2019
Posts: 8

PostPosted: Sat Apr 20, 2019 5:32 pm    Post subject: Reply with quote

And FYI, packages I had to downgrade to order install TS3 was:

=dev-qt/qtxml-5.12.2
=dev-qt/qttest-5.12.2:5
=dev-qt/qtgui-5.12.2
=dev-qt/qtsvg-5.12.2
=dev-qt/qtwidgets-5.12.2
=dev-qt/qtdbus-5.12.2

Also gawk-5.0.0 was giving me troubles, so I would recommend to stay in 4.*.
Back to top
View user's profile Send private message
rmk88
n00b
n00b


Joined: 31 Mar 2019
Posts: 8

PostPosted: Wed Apr 24, 2019 4:31 pm    Post subject: Reply with quote

Adrien.D wrote:
After steam --reset nor work for me.
Always have
Code:
./steamwebhelper: symbol lookup error: /usr/lib/gio/modules/libdconfsettings.so: undefined symbol: g_log_structured_standard


Struggling with same error. I got Steam running with command "LD_PRELOAD="/usr/lib/libgio-2.0.so.0 /usr/lib/libglib-2.0.so.0" steam". Funny enough, seems to work once and then back to black Steam windows.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum