Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Can't rotate screen with xrandr
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Elmo.T
n00b
n00b


Joined: 02 Jul 2018
Posts: 6

PostPosted: Sun Mar 24, 2019 4:25 pm    Post subject: [SOLVED] Can't rotate screen with xrandr Reply with quote

Rotating my other screen with xrandr doesn't seem to work.

Code:
elmo@Host-T ~ $ xrandr --output DVI-1 --rotate left
xrandr: output DVI-1 cannot use rotation "left" reflection "none"


Code:
elmo@Host-T ~ $ xrandr
Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 16384 x 16384
DisplayPort-0 disconnected primary
HDMI-0 disconnected
DVI-0 connected 1920x1080+1920+0 531mm x 298mm
   1920x1080     60.00*+ 144.00   119.98    99.93    59.94 
   1280x1024    119.96    75.02    60.02 
   1440x900     119.85 
   1152x864      75.00 
   1024x768     119.99    75.03    60.00 
   832x624       74.55 
   800x600      119.97    75.00    60.32 
   640x480      119.99    75.00    60.00    59.94 
   720x400       70.08 
DVI-1 connected 1920x1080+0+0 531mm x 298mm
   1920x1080     60.00*+ 144.00   119.98    99.93    59.94 
   1280x1024    119.96    75.02    60.02 
   1440x900     119.85 
   1152x864      75.00 
   1024x768     119.99    75.03    60.00 
   832x624       74.55 
   800x600      119.97    75.00    60.32 
   640x480      119.99    75.00    60.00    59.94 
   720x400       70.08


/etc/X11/xorg.conf.d/radeon.conf
Code:
Section   "Device"
   Identifier   "radeon"
   Driver      "radeon"
   Option      "RandRRotation"   "True"
EndSection


/etc/X11/xorg.conf.d/50-video.conf
Code:
Section "Device"
   Identifier   "Device0"
   Option      "Monitor-DVI0"   "DVI-0"
   Option      "Monitor-DVI1"   "DVI-1"
   Option      "RandRRotation"   "on"
   Driver      "radeon"
EndSection



Section "Monitor"
        Identifier   "DVI-0"
EndSection



Section "Monitor"
        Identifier   "DVI-1"
        Option          "LeftOf"        "DVI-0"
EndSection



/var/log/Xorg.0.log
https://pastebin.com/1p7zPPPT

There is also some errors about gdm failing to open any driver when I start X.
Something like
Code:
gdm: failed to open any driver (search paths /usr/lib64/dri)
gdm: Last dlopen error: /usr/lib64/dri/radeonsi_dri.so: cannot open shared object file: No such file or directory
failed to load driver: radeonsi
gdm: failed to open any driver (search paths /usr/lib64/dri)
gdm: Last dlopen error: /usr/lib64/dri/radeonsi_dri.so: cannot open shared object file: No such file or directory
failed to load driver: radeonsi


Code:
Host-T ~ # ls -a /usr/lib64/dri/
.  ..  kms_swrast_dri.so  r200_dri.so  r300_dri.so  r600_dri.so  radeon_dri.so  swrast_dri.so


Code:
Host-T ~ # lspci | grep -i VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X]
Host-T ~ # qlist -Iv drivers
x11-base/xorg-drivers-1.20
x11-drivers/xf86-input-evdev-2.10.6
x11-drivers/xf86-input-keyboard-1.9.0
x11-drivers/xf86-input-libinput-0.28.2
x11-drivers/xf86-input-mouse-1.9.3
x11-drivers/xf86-video-ati-18.1.0


Last edited by Elmo.T on Sun Apr 07, 2019 3:33 pm; edited 2 times in total
Back to top
View user's profile Send private message
Elmo.T
n00b
n00b


Joined: 02 Jul 2018
Posts: 6

PostPosted: Sun Apr 07, 2019 3:32 pm    Post subject: Reply with quote

Problem was my own fault. Misunderstanding when reading the radeon wiki.
Making this change in make.conf fixed the issue.
Code:
-VIDEO_CARDS="radeon"
+VIDEO_CARDS="radeon radeonsi"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum