Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Plasma problems - Unable to start properly
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 283
Location: Italy, Torino

PostPosted: Thu Mar 21, 2019 8:45 am    Post subject: Plasma problems - Unable to start properly Reply with quote

Hi all!
this is a brand new installation. I have followed the guides and the plasma wiki... But i cannot start plasma properly.

SDDM starts and i can get to a black desktop (i can see briefly the logo and the backgounrd, then all goes black),

The display is working prefectly, i am typuing this post from Chrome, KWin works and so works all programs like konsole and system settings. But the plasma shell is not working.

If i start from command line i get:
Code:

Aborting shell load: The activity manager daemon (kactivitymanagerd) is not running.
If this Plasma has been installed into a custom prefix, verify that its D-Bus services dir is known to the system for the daemon to be activatable.
org.kde.plasmaquick: Applet preload policy set to 1
file:///usr/share/plasma/plasmoids/org.kde.desktopcontainment/contents/ui/main.qml:62:28: Unable to assign [undefined] to int
file:///usr/share/plasma/plasmoids/org.kde.desktopcontainment/contents/ui/main.qml:53:27: Unable to assign [undefined] to int
trying to show an empty dialog
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/PulseAudio.qml:22:1: module "org.kde.plasma.private.volume" is not installed
Trying to use rootObject before initialization is completed, whilst using setInitializationDelayed. Forcing completion
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
trying to show an empty dialog
trying to show an empty dialog
org.kde.klipper: Failed to load history resource. Clipboard history cannot be read. :  History file does not exist
Trying to use rootObject before initialization is completed, whilst using setInitializationDelayed. Forcing completion
libkcups: Create-Printer-Subscriptions last error: 1282 Descrittore di file errato
libkcups: Request failed 1282 -1
libkcups: Get-Jobs last error: 1282 Descrittore di file errato
libkcups: Get-Jobs last error: 1282 Descrittore di file errato
Plasma Shell startup completed
org.kde.plasmaquick: New Applet  "Avviatore di applicazioni" with a weight of 100
org.kde.plasmaquick: New Applet  "Orologio digitale" with a weight of 50
Both point size and pixel size set. Using pixel size.
file:///usr/share/plasma/plasmoids/org.kde.plasma.battery/contents/ui/CompactRepresentation.qml:53:39: Unable to assign [undefined] to int
trying to show an empty dialog
org.kde.plasmaquick: New Applet  "Appunti" with a weight of 50
org.kde.plasmaquick: New Applet  "Indicatore tastiera" with a weight of 50
org.kde.plasmaquick: New Applet  "Notificatore dei dispositivi" with a weight of 50
org.kde.plasmaquick: New Applet  "Notifiche" with a weight of 50
org.kde.plasmaquick: New Applet  "Stampanti" with a weight of 50
org.kde.plasmaquick: New Applet  "Batteria e luminosità" with a weight of 50
org.kde.plasmaquick: New Applet  "Messaggistica istantanea" with a weight of 50
org.kde.plasmaquick: New Applet  "Reti" with a weight of 50
org.kde.plasmaquick: Delayed preload of  "Avviatore di applicazioni" after 0 seconds
Empty filename passed to function
KAStatsFavoritesModel::setFavorites is ignored
KActivities: Database connection:  "kactivities_db_resources_140002989303808_readonly"
    query_only:          QVariant(qlonglong, 1)
    journal_mode:        QVariant(QString, "wal")
    wal_autocheckpoint:  QVariant(qlonglong, 100)
    synchronous:         QVariant(qlonglong, 0)
Entry is not valid "kontact.desktop" 0x555da375ae30
Entry is not valid "ktp-contactlist.desktop" 0x555da375ae30
Entry is not valid "org.kde.discover.desktop" 0x555da3770010
Entry is not valid "kontact.desktop" 0x555da37a15f0
Entry is not valid "ktp-contactlist.desktop" 0x555da37a15f0
Entry is not valid "org.kde.discover.desktop" 0x555da375ae30
Closing SQL connection:  "kactivities_db_resources_140002989303808_readonly"
trying to show an empty dialog
org.kde.plasmaquick: Applet "Avviatore di applicazioni" loaded after 108 msec
KCrash: Application 'plasmashell' crashing...
KCrash: Attempting to start /usr/lib64/libexec/drkonqi from kdeinit
sock_file=/var/run/user/1000/kdeinit5__0
QSocketNotifier: Invalid socket 8 and type 'Read', disabling...
QSocketNotifier: Invalid socket 18 and type 'Read', disabling...


I have checked and kactivitymanagerd seems to be running:
Code:

illy@willy-pc ~ $ kactivitymanagerd status
The service is running, version: 7.0.0


So also d-bus is working (i can see all the traffic with dbus monitor when plasmashell tries to start)... I have also tried to delete entirely the .local folder (it's a new install, so no harm) with no change.

At this point i am at a loss.... what should i try?

Notes: i have emerged plasma-meta and kde-apps-meta, so i guess all the required pieces should be there...
_________________
Willy Gardiol
willy@gardiol.org
Back to top
View user's profile Send private message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 283
Location: Italy, Torino

PostPosted: Thu Mar 21, 2019 2:05 pm    Post subject: Reply with quote

Update: i have a Quadro FX 4500 video card and i am using Nouveau since the NVidia driver is too new (i need version 304 but smallest is 430)...

Switching to VESA driver fixed the issue...

This is not exactly acceptable, does anybody have an idea to improve over vesa driver?
_________________
Willy Gardiol
willy@gardiol.org
Back to top
View user's profile Send private message
mrbassie
Guru
Guru


Joined: 31 May 2013
Posts: 554

PostPosted: Thu Mar 21, 2019 2:07 pm    Post subject: Reply with quote

shimitar wrote:
Update: i have a Quadro FX 4500 video card and i am using Nouveau since the NVidia driver is too new (i need version 304 but smallest is 430)...

Switching to VESA driver fixed the issue...

This is not exactly acceptable, does anybody have an idea to improve over vesa driver?


https://data.gpo.zugaina.org/multilib-portage/x11-drivers/nvidia-drivers/

https://wiki.gentoo.org/wiki/Custom_repository
Back to top
View user's profile Send private message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 283
Location: Italy, Torino

PostPosted: Thu Mar 21, 2019 3:13 pm    Post subject: Reply with quote

to be honest, the problem is that the version of the drivers i need are bound to Xorg 1.17....

I added xorg 1.17.4 to the overlay and now i am trying to downgrade...
What a mess... if this was not a scrap PC i would just ditch and go for an intel with open source drivers.
_________________
Willy Gardiol
willy@gardiol.org
Back to top
View user's profile Send private message
mrbassie
Guru
Guru


Joined: 31 May 2013
Posts: 554

PostPosted: Thu Mar 21, 2019 5:16 pm    Post subject: Reply with quote

I've had a go at getting 304 to compile myself; I edited out all the dependency versioning from the ebuild (which seemingly is fine) and tried compiling, which fails. Portage spits out a warning about kernels later than 3.18.

Now, it does work in the .deb distros if you downgrade the kernel (I've done it on a family members mint install), but I can't remember what the kernel version. A quick google later I found a post on the linux mint forums claiming that it works on mint up to kernel 4.13. That didn't wotk for me either.

I think it might be doable if you're willing to invest the time/effort/both but that's where my experimenting ends for today, I might try again tomorrow just to see if I can do it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum