Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gpg: keyserver refresh failed: No name
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
stefbon
n00b
n00b


Joined: 03 Dec 2018
Posts: 18

PostPosted: Mon Mar 18, 2019 7:29 am    Post subject: gpg: keyserver refresh failed: No name Reply with quote

Hi,

I try to sync before update:

Code:

emerge --sync
>>> Syncing repository 'gentoo' into '/usr/portage'...
 * Using keys from /usr/share/openpgp-keys/gentoo-release.asc
 * Refreshing keys from keyserver ...OpenPGP keyring refresh failed:
gpg: refreshing 4 keys from hkps://hkps.pool.sks-keyservers.net
gpg: keyserver refresh failed: No name


What's wrong?

Stef Bon
Back to top
View user's profile Send private message
Xenoist
n00b
n00b


Joined: 21 Aug 2002
Posts: 26
Location: EU/DE/NRW/NEUSS

PostPosted: Mon Mar 18, 2019 10:07 am    Post subject: Reply with quote

Same here.

gpg won't load from keyserver even on command line.

Seems like server is down, or connection is blocked. (Europe)

One solution is to wait till it is fixed.



Hazard Software may be installed when you disable gnupg check.
Better backup whole system before doing this.
The second is shut off the ckeck:

nano /etc/portage/repos.conf/gentoo.conf
sync-rsync-verify-metamanifest = no

"emerge --sync" will now not check for wrong gnupg signs! This is dangerous.

The other way is load the signed snapchots and test against the gpg sign.

Unpack like in Install instrucktion shown.

xenoist
_________________
Once live is to short to learn all, but keep trying it.

"emerge the world" every day!
Back to top
View user's profile Send private message
mike155
Veteran
Veteran


Joined: 17 Sep 2010
Posts: 1043
Location: Frankfurt, Germany

PostPosted: Mon Mar 18, 2019 10:59 am    Post subject: Reply with quote

I disabled tree verification - until developers come up with a better solution for tree verification.
  1. I emerged portage without USE flag 'rsync-verify'

  2. I added the lines below to the DEFAULT section of /etc/portage/repos.conf/gentoo.conf:
    Code:
    sync-rsync-verify-metamanifest = no
    sync-allow-hardlinks = no

Quote:
This is dangerous.

I do not believe that.
Back to top
View user's profile Send private message
Xenoist
n00b
n00b


Joined: 21 Aug 2002
Posts: 26
Location: EU/DE/NRW/NEUSS

PostPosted: Mon Mar 18, 2019 4:51 pm    Post subject: Reply with quote

fixed with:

emerge -qvv @system
_________________
Once live is to short to learn all, but keep trying it.

"emerge the world" every day!
Back to top
View user's profile Send private message
stefbon
n00b
n00b


Joined: 03 Dec 2018
Posts: 18

PostPosted: Thu Mar 21, 2019 9:03 am    Post subject: Reply with quote

It's working again.

So solved, but I do not know how and by who.

Stef
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum