Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
incompatibility between mesa 19 and eselect-opengl
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Azkalaak
n00b
n00b


Joined: 18 Mar 2019
Posts: 4

PostPosted: Mon Mar 18, 2019 4:10 pm    Post subject: incompatibility between mesa 19 and eselect-opengl Reply with quote

I was trying to reinstall my entire system (a funtoo with the gentoo packages), but I had the following error:

command used:
Code:
sudo emerge -e --autounmask-continue world


Code:
* Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.
(app-eselect/eselect-opengl-1.3.1-r4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=app-eselect/eselect-opengl-1.3.0 required by (x11-base/xorg-server-1.20.4:0/1.20.4::gentoo, ebuild scheduled for merge)
    >=app-eselect/eselect-opengl-1.3.0 required by (x11-proto/glproto-1.4.17-r1:0/0::xorg-kit, ebuild scheduled for merge)

  (media-libs/mesa-19.0.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/mesa-9.1.6[egl,abi_x86_32(-)?,abi_x86_64(-)?,
      abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,
      abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,
      abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[egl,abi_x86_32(-),
      abi_x86_64(-)]) required by (x11-libs/cairo-1.16.0-r2:0/0::gentoo, ebuild scheduled for merge)
    media-libs/mesa[egl] required by (dev-qt/qtwayland-5.12.2:5/5.12::gentoo, ebuild scheduled for merge)
    media-libs/mesa required by (media-libs/libtxc_dxtn-1.0.1-r4:0/0::gentoo, ebuild scheduled for merge)
    media-libs/mesa[egl] required by (dev-qt/qtgui-5.12.2:5/5.12::gentoo, ebuild scheduled for merge)
    >=media-libs/mesa-10.2:* required by (www-client/firefox-65.0.2:0/0::gentoo, ebuild scheduled for merge)
    >=media-libs/mesa-18[egl,gbm] required by (x11-base/xorg-server-1.20.4:0/1.20.4::gentoo, ebuild scheduled for merge)
    >=media-libs/mesa-18 required by (x11-base/xorg-server-1.20.4:0/1.20.4::gentoo, ebuild scheduled for merge)
    media-libs/mesa[egl] required by (kde-frameworks/kwayland-5.56.0:5/5.56::gentoo, ebuild scheduled for merge)
    media-libs/mesa[egl,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
      abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,
      abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (media-libs/mesa[egl,abi_x86_64(-)]) required by (media-libs/libepoxy-1.5.3:0/0::gentoo, ebuild scheduled for merge)
    >=media-libs/mesa-9.1.6[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
      abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,
      abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[abi_x86_32(-),abi_x86_64(-)]) required by (virtual/opengl-7.0-r2:0/0::gentoo, ebuild scheduled for merge)
    media-libs/mesa[egl?,gles2?] (media-libs/mesa) required by (x11-apps/mesa-progs-8.3.0:0/0::gentoo, ebuild scheduled for merge)


I tried to fix the bug by uninstalling my actual mesa (17.2.8) but it didn't change anything.
i'm don't really want to destroy my OS so I didn't mess up with my package.use / mask / unmask
any suggestions?

Wrapped long lines to make the forum layout behave.Chiitoo
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7686
Location: Pelotas, BR

PostPosted: Mon Mar 18, 2019 5:40 pm    Post subject: Reply with quote

Moved from Gentoo on AMD64 to Unsupported Software.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21318
Location: here

PostPosted: Mon Mar 18, 2019 5:49 pm    Post subject: Reply with quote

You can post full emerge output?
And from man emerge
Quote:
--autounmask-continue [ y | n ]
Automatically apply autounmask changes to configuration files, and continue to execute the specified command. If the dependency calculation is not
entirely successful, then emerge will simply abort without modifying any configuration files. This option implies --autounmask-backtrack=y. WARNING:
This option is intended to be used only with great caution, since it is possible for it to make nonsensical configuration changes which may lead to
system breakage
. Therefore, it is advisable to use --ask together with this option.

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Azkalaak
n00b
n00b


Joined: 18 Mar 2019
Posts: 4

PostPosted: Mon Mar 18, 2019 6:08 pm    Post subject: Reply with quote

the full error (I will not put the log of the 922 packages only the blocking one)

Code:
[blocks B     ] app-eselect/eselect-opengl ("app-eselect/eselect-opengl" is blocking media-libs/mesa-19.0.0)

Fetch instructions for dev-java/oracle-jdk-bin-1.8.0.202:
 * Please download these files and move them to your distfiles directory:
 *
 *   jdk-8u202-linux-x64.tar.gz
 *
 *   http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html
 *
 * If the above mentioned URL does not point to the correct version anymore,
 * please download the file from Oracle's Java download archive:
 *
 *   http://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html
 *

Fetch instructions for dev-java/oracle-jre-bin-1.8.0.202:
 * Please download jre-8u202-linux-x64.tar.gz and move it to
 * your distfiles directory:
 *
 *   http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html
 *
 * If the above mentioned URL does not point to the correct version anymore,
 * please download the file from Oracle's Java download archive:
 *
 *   http://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html
 *

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libdrm:0

  (x11-libs/libdrm-2.4.97:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/libdrm-2.4.97[video_cards_freedreno?,
    ^^                ^^^^^^  video_cards_nouveau?,video_cards_vc4?,
      video_cards_vivante?,video_cards_vmware?,abi_x86_32(-)?,
      abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,
      abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,
      abi_s390_64(-)?] required by (media-libs/mesa-19.0.0:0/0::gentoo, ebuild scheduled for merge)

    >=x11-libs/libdrm-2.4.89 required by (x11-base/xorg-server-1.20.4:0/1.20.4::gentoo, ebuild scheduled for merge)
    ^^                ^^^^^^                                                                                                                                             

  (x11-libs/libdrm-2.4.83:0/0::xorg-kit, installed) pulled in by
    x11-libs/libdrm[libkms] required by (sys-boot/plymouth-0.9.4-r1:0/0::gentoo, ebuild scheduled for merge)
                    ^^^^^^                                                                                                                     



 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-eselect/eselect-opengl-1.3.1-r4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=app-eselect/eselect-opengl-1.3.0 required by (x11-base/xorg-server-1.20.4:0/1.20.4::gentoo, ebuild scheduled for merge)
    >=app-eselect/eselect-opengl-1.3.0 required by (x11-proto/glproto-1.4.17-r1:0/0::xorg-kit, ebuild scheduled for merge)

  (media-libs/mesa-19.0.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/mesa-9.1.6[egl,abi_x86_32(-)?,abi_x86_64(-)?,
      abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,
      abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,
      abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[egl,abi_x86_32(-),
      abi_x86_64(-)]) required by (x11-libs/cairo-1.16.0-r2:0/0::gentoo, ebuild scheduled for merge)
    media-libs/mesa[egl] required by (dev-qt/qtwayland-5.12.2:5/5.12::gentoo, ebuild scheduled for merge)
    media-libs/mesa required by (media-libs/libtxc_dxtn-1.0.1-r4:0/0::gentoo, ebuild scheduled for merge)
    media-libs/mesa[egl] required by (dev-qt/qtgui-5.12.2:5/5.12::gentoo, ebuild scheduled for merge)
    >=media-libs/mesa-10.2:* required by (www-client/firefox-65.0.2:0/0::gentoo, ebuild scheduled for merge)
    >=media-libs/mesa-18[egl,gbm] required by (x11-base/xorg-server-1.20.4:0/1.20.4::gentoo, ebuild scheduled for merge)
    >=media-libs/mesa-18 required by (x11-base/xorg-server-1.20.4:0/1.20.4::gentoo, ebuild scheduled for merge)
    media-libs/mesa[egl] required by (kde-frameworks/kwayland-5.56.0:5/5.56::gentoo, ebuild scheduled for merge)
    media-libs/mesa[egl,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
      abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,
      abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (media-libs/mesa[egl,abi_x86_64(-)]) required by (media-libs/libepoxy-1.5.3:0/0::gentoo, ebuild scheduled for merge)
    >=media-libs/mesa-9.1.6[abi_x86_32(-)?,abi_x86_64(-)?,
      abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,
      abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,
      abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[abi_x86_32(-),abi_x86_64(-)]) required by (virtual/opengl-7.0-r2:0/0::gentoo, ebuild scheduled for merge)
    media-libs/mesa[egl?,gles2?] (media-libs/mesa) required by (x11-apps/mesa-progs-8.3.0:0/0::gentoo, ebuild scheduled for merge)

Wrapped long lines to make the forum layout behave.Chiitoo
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21318
Location: here

PostPosted: Mon Mar 18, 2019 6:50 pm    Post subject: Reply with quote

I don't understand, in my system I installed app-eselect/eselect-opengl and media-libs/mesa-19.0.0 without problem.
You can post emerge -pvq app-eselect/eselect-opengl media-libs/mesa output?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 6959

PostPosted: Mon Mar 18, 2019 7:52 pm    Post subject: Reply with quote

https://gitweb.gentoo.org/repo/gentoo.git/diff/media-libs/mesa/mesa-19.0.0.ebuild?id=7108b4dfaef2a05590cddc07f6f17a45821afdd1
Code:
libglvnd? (
-      media-libs/libglvnd
+      media-libs/libglvnd[${MULTILIB_USEDEP}]
       !app-eselect/eselect-opengl


USE="libglvnd" emerge mesa -> boom
USE="-libglvnd" emerge mesa -> happy
Back to top
View user's profile Send private message
Azkalaak
n00b
n00b


Joined: 18 Mar 2019
Posts: 4

PostPosted: Mon Mar 18, 2019 8:09 pm    Post subject: Reply with quote

The emerge -pvq output
Code:
[nomerge      ] media-libs/mesa-19.0.0 [17.2.8] USE="classic dri3 egl gallium gbm libglvnd%* llvm lm_sensors%* valgrind xa xvmc -d3d9 -debug -gles1 -gles2 -opencl -osmesa -pax_kernel -pic (-selinux) -test% -unwind -vaapi -vdpau -vulkan -wayland (-bindist%) (-nptl%*) (-openmax%)" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="i965 intel (-freedreno) -i915 (-imx) -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) -virgl (-vivante) -vmware"
[blocks b     ]  app-eselect/eselect-mesa ("app-eselect/eselect-mesa" is blocking media-libs/mesa-19.0.0)
[uninstall    ]   app-eselect/eselect-mesa-0.0.10-r1
[nomerge      ] media-libs/mesa-19.0.0 [17.2.8] USE="classic dri3 egl gallium gbm libglvnd%* llvm lm_sensors%* valgrind xa xvmc -d3d9 -debug -gles1 -gles2 -opencl -osmesa -pax_kernel -pic (-selinux) -test% -unwind -vaapi -vdpau -vulkan -wayland (-bindist%) (-nptl%*) (-openmax%)" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="i965 intel (-freedreno) -i915 (-imx) -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) -virgl (-vivante) -vmware"
[nomerge      ]  media-libs/libglvnd-1.0.0.20180524  ABI_X86="32 (64) (-x32)"
[blocks b     ]   media-libs/mesa[-libglvnd(-)] ("media-libs/mesa[-libglvnd(-)]" is blocking media-libs/libglvnd-1.0.0.20180524)
[ebuild     U ]    media-libs/mesa-19.0.0 [17.2.8] USE="classic dri3 egl gallium gbm libglvnd%* llvm lm_sensors%* valgrind xa xvmc -d3d9 -debug -gles1 -gles2 -opencl -osmesa -pax_kernel -pic (-selinux) -test% -unwind -vaapi -vdpau -vulkan -wayland (-bindist%) (-nptl%*) (-openmax%)" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="i965 intel (-freedreno) -i915 (-imx) -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) -virgl (-vivante) -vmware"
[ebuild  NS   ]     sys-devel/llvm-7.0.1 [5.0.1, 6.0.0] USE="libffi ncurses xml -debug -doc -exegesis -gold -libedit -test -xar" ABI_X86="32 (64) (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore"
[ebuild  N    ]     media-libs/libglvnd-1.0.0.20180524  ABI_X86="32 (64) (-x32)"
[ebuild     U ]     x11-libs/libdrm-2.4.97 [2.4.83] USE="valgrind -libkms* (-static-libs%)" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="intel -amdgpu (-exynos) (-freedreno) -nouveau (-omap) -radeon (-tegra) (-vc4) (-vivante) -vmware"
[ebuild  N    ]     dev-python/mako-1.0.7  USE="-doc -test" PYTHON_TARGETS="python2_7 python3_6 -pypy -pypy3 -python3_4 -python3_5 -python3_7"
[ebuild  N    ]      dev-python/markupsafe-1.0  PYTHON_TARGETS="python2_7 python3_6 -pypy -pypy3 -python3_4 -python3_5 -python3_7"
[ebuild     U ]     dev-util/meson-0.49.2 [0.48.1] USE="-test%" PYTHON_TARGETS="python3_6 -python3_5 -python3_7"
[ebuild   R   ] app-eselect/eselect-opengl-1.3.1-r4 [1.3.1-r4]
[nomerge      ] media-gfx/krita-3.3.3  USE="gsl jpeg pdf raw tiff -color-management -debug -fftw -openexr -qtmedia -test -vc"
[nomerge      ]  kde-frameworks/kxmlgui-5.43.0  USE="-attica -debug -doc -test"
[nomerge      ]   kde-frameworks/kglobalaccel-5.43.0  USE="nls -debug -doc -test"
[nomerge      ]    kde-frameworks/kwindowsystem-5.43.0  USE="X nls -debug -doc -test"
[ebuild     U ]     x11-libs/libxcb-1.13.1 [1.12-r2] USE="xkb -doc (-selinux) -static-libs -test" ABI_X86="32 (64) (-x32)"
[ebuild  N    ]      x11-base/xcb-proto-1.13  ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5 -python3_7"
[nomerge      ] media-libs/mesa-19.0.0 [17.2.8] USE="classic dri3 egl gallium gbm libglvnd%* llvm lm_sensors%* valgrind xa xvmc -d3d9 -debug -gles1 -gles2 -opencl -osmesa -pax_kernel -pic (-selinux) -test% -unwind -vaapi -vdpau -vulkan -wayland (-bindist%) (-nptl%*) (-openmax%)" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="i965 intel (-freedreno) -i915 (-imx) -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) -virgl (-vivante) -vmware"
[ebuild  N    ]  sys-apps/lm_sensors-3.5.0  USE="-contrib -sensord -static-libs" ABI_X86="32 (64) (-x32)"
[blocks B     ] app-eselect/eselect-opengl ("app-eselect/eselect-opengl" is blocking media-libs/mesa-19.0.0)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libdrm:0

  (x11-libs/libdrm-2.4.97:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/libdrm-2.4.97[video_cards_freedreno?,video_cards_nouveau?,video_cards_vc4?,video_cards_vivante?,video_cards_vmware?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/mesa-19.0.0:0/0::gentoo, ebuild scheduled for merge)
    ^^                ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                         

  (x11-libs/libdrm-2.4.83:0/0::xorg-kit, installed) pulled in by
    x11-libs/libdrm[libkms] required by (sys-boot/plymouth-0.9.3-r1:0/0::core-kit, installed)
                    ^^^^^^                                                                                                       



 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-eselect/eselect-opengl-1.3.1-r4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    app-eselect/eselect-opengl
    >=app-eselect/eselect-opengl-1.3.0 required by (x11-proto/glproto-1.4.17-r1:0/0::xorg-kit, installed)
    >=app-eselect/eselect-opengl-1.3.0 required by (x11-base/xorg-server-1.19.3-r3:0/1.19.3::xorg-kit, installed)

  (media-libs/mesa-19.0.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/mesa[egl?,gles2?] (media-libs/mesa) required by (x11-apps/mesa-progs-8.3.0:0/0::xorg-kit, installed)
    >=media-libs/mesa-10.3.4-r1[egl,gbm] required by (x11-base/xorg-server-1.19.3-r3:0/1.19.3::xorg-kit, installed)
    media-libs/mesa required by (media-libs/libsfml-2.4.2:0/2.4::media-kit, installed)
    media-libs/mesa
    media-libs/mesa[egl] required by (dev-qt/qtwayland-5.9.4-r1:5/5.9::kde-kit, installed)
    media-libs/mesa[egl] required by (kde-frameworks/kwayland-5.43.0:5/5.43::kde-kit, installed)
    >=media-libs/mesa-9.1.6[egl,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[egl,abi_x86_32(-),abi_x86_64(-)]) required by (x11-libs/cairo-1.14.12:0/0::gnome-kit, installed)
    media-libs/mesa[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (media-libs/mesa[abi_x86_64(-)]) required by (media-libs/libtxc_dxtn-1.0.1-r3:0/0::media-kit, installed)
    >=media-libs/mesa-9.1.6[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[abi_x86_32(-),abi_x86_64(-)]) required by (virtual/opengl-7.0-r1:0/0::xorg-kit, installed)
    media-libs/mesa[egl,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (media-libs/mesa[egl,abi_x86_64(-)]) required by (media-libs/libepoxy-1.4.3:0/0::xorg-kit, installed)
    >=media-libs/mesa-10.3.4-r1 required by (x11-base/xorg-server-1.19.3-r3:0/1.19.3::xorg-kit, installed)
    >=media-libs/mesa-10.2:* required by (www-client/firefox-60.5.0:0/0::net-kit, installed)
    media-libs/mesa[egl] required by (dev-qt/qtgui-5.9.4-r3:5/5.9::kde-kit, installed)
Back to top
View user's profile Send private message
Azkalaak
n00b
n00b


Joined: 18 Mar 2019
Posts: 4

PostPosted: Mon Mar 18, 2019 8:13 pm    Post subject: Reply with quote

I tried to use "-libglvnd" and it seems that it works (i have no errors while running the pre-merge part)
i'll try the hole install and cross my fingers for it not to break
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum