Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
app-emulation/docker-compose dependencies not correct
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
nexusdk
n00b
n00b


Joined: 15 Mar 2019
Posts: 1

PostPosted: Fri Mar 15, 2019 11:09 am    Post subject: app-emulation/docker-compose dependencies not correct Reply with quote

Running "docker-compose up" prints:
Code:
pkg_resources.DistributionNotFound: The 'requests!=2.11.0,!=2.12.2,!=2.18.0,<2.21,>=2.6.1' distribution was not found and is required by docker-compose

But the dependency in the ebuild is listed as:
Code:
 >=dev-python/requests-2.6.1[${PYTHON_USEDEP}]


app-emulation/docker-compose version installed: 1.23.2
dev-python/requests version installed: 2.21.0-r1
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22327
Location: here

PostPosted: Fri Mar 15, 2019 11:31 am    Post subject: Reply with quote

Welcome to gentoo forum!
See https://bugs.gentoo.org/679968 and https://forums.gentoo.org/viewtopic-p-8316886.html#8316886
Bug is resolved try to resync tree and reinstall docker-compose
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum