Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Stuttering video with vaapi and nouveau in Chromium
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
an7h
n00b
n00b


Joined: 10 Jan 2018
Posts: 47

PostPosted: Wed Mar 13, 2019 1:16 pm    Post subject: Stuttering video with vaapi and nouveau in Chromium Reply with quote

From what I understand nvidia cards aren't really supported with the use of hardware acceleration (vaapi) in Chromium, yet I've almost got it to work by enabling Override software rendering list in chrome://flags. What I should point out, though, is that the issue with stuttering only occurs while I try using the h264 codec for decoding. Of course nouveau also supports hardware acceleration for the standard codecs used on youtube and other video streaming websites (VP8 and VP9 from what I can tell), but I'm not really sure it's having an effect, because I can't really see any difference with CPU load while hardware acceleration is enabled or disabled. Btw, the way it streames a video is more like skipping frames, then comming back to a few previous ones, and instead of doing it in order and smoothly it becomes this jumbled mess. The audio is okay, though.

Anyway, I've got a GeForce 310m on this laptop (Sony VAIO VPCF12AFM).

vainfo: https://pastebin.com/kriAUDC5
lshw: https://pastebin.com/QxvjvZs5

I'm not sure what other info to give other than that Gentoo is installed correctly, I'm not having any other weird issues. I have nouveau built as a module, and I'm using =sys-kernel/gentoo-sources-4.14.101. Also in chrome://gpu it says that hardware acceleration is available for video decoding, and in chrome://media-internals I can confirm this by having MojoVideoDecoder used. So, it seems to be working, but not as it should.

I don't really need hardware acceleration for Chromium with the CPU I've got here, but I'm wondering how to set it up correctly with an nvidia GPU (if at all possilbe).
_________________
There's nothing more cheaper for politicians than human life.
Back to top
View user's profile Send private message
jornamd1
n00b
n00b


Joined: 22 Dec 2018
Posts: 1

PostPosted: Sun Mar 17, 2019 4:08 am    Post subject: Re: Stuttering video with vaapi and nouveau in Chromium Reply with quote

an7h wrote:
From what I understand nvidia cards aren't really supported with the use of hardware acceleration (vaapi) in Chromium, yet I've almost got it to work by enabling Override software rendering list in chrome://flags. What I should point out, though, is that the issue with stuttering only occurs while I try using the h264 codec for decoding. Of course nouveau also supports hardware acceleration for the standard codecs used on youtube and other video streaming websites (VP8 and VP9 from what I can tell), but I'm not really sure it's having an effect, because I can't really see any difference with CPU load while hardware acceleration is enabled or disabled. Btw, the way it streames a video is more like skipping frames, then comming back to a few previous ones, and instead of doing it in order and smoothly it becomes this jumbled mess. The audio is okay, though.

Anyway, I've got a GeForce 310m on this laptop (Sony VAIO VPCF12AFM).

CnZhaW5mbzogaHR0cHM6Ly9wYXN0ZWJpbi5jb20va3JpQVVEQzUKbHNodzogaHR0cHM6Ly9wYXN0
ZWJpbi5jb20vUXh2anZaczUKaHR0cHM6Ly9jZXphcnNwaWFuby5jb20K

I'm not sure what other info to give other than that Gentoo is installed correctly, I'm not having any other weird issues. I have nouveau built as a module, and I'm using =sys-kernel/gentoo-sources-4.14.101. Also in chrome://gpu it says that hardware acceleration is available for video decoding, and in chrome://media-internals I can confirm this by having MojoVideoDecoder used. So, it seems to be working, but not as it should.

I don't really need hardware acceleration for Chromium with the CPU I've got here, but I'm wondering how to set it up correctly with an nvidia GPU (if at all possilbe).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum