Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
errore upgrade di world
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Tue Mar 12, 2019 6:01 pm    Post subject: errore upgrade di world Reply with quote

Salve a tutti,

Ricevo il seguente errore durante un
Code:

# emerge -uDNv --with-bdeps y --backtrack=300 @world


Code:

Total: 175 packages (158 upgrades, 1 downgrade, 2 new, 4 in new slots, 10 reinstalls, 1 uninstall), Size of downloads: 2267217 KiB
Conflict: 1 block

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.20.4:0/1.20.4::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-base/xorg-server-1.20.3:0/1.20.3::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.20.3= required by (x11-drivers/xf86-input-evdev-2.10.6:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                             
    (and 1 more with the same problem)

media-gfx/imagemagick:0

  (media-gfx/imagemagick-7.0.8.30:0/7.0.8.30::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-gfx/imagemagick-7.0.8.23:0/7.0.8.23::gentoo, installed) pulled in by
    media-gfx/imagemagick:0/7.0.8.23=[cxx] required by (sci-mathematics/octave-4.4.1:0/4.4.1::gentoo, installed)
                         ^^^^^^^^^^^^                                                                                                               

x11-libs/vte:2.91

  (x11-libs/vte-0.54.1:2.91/2.91::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/vte-0.50.2:2.91 required by (x11-terms/gnome-terminal-3.26.2:0/0::dantrell-gnome-3-26, installed)
    ^^             ^^^^^^^^^^^                                                                                                                                                           

  (x11-libs/vte-0.48.4:2.91/2.91::eroen, installed) pulled in by
    >=x11-libs/vte-0.43.2:2.91[termite-patch(-)] required by (x11-terms/termite-13:0/0::eroen, installed)
                                                                                                                         

dev-libs/openssl:0

  (dev-libs/openssl-1.1.0j-r1:0/1.1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.1.0g:0[bindist=] required by (net-misc/openssh-7.9_p1-r4:0/0::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^^^                                                                                                                                                                     
    =dev-libs/openssl-1.1.0*:0/1.1= required by (net-libs/nodejs-11.8.0:0/0::gentoo, installed)
    ^                 ^^^^^^^^^^^^^                                                                                                                                     
    dev-libs/openssl:0/1.1= required by (dev-lang/rust-1.32.0:stable/1.32::gentoo, installed)
                    ^^^^^^^                                                                                                     
    (and 17 more with the same problems)

  (dev-libs/openssl-1.0.2r:0/0::gentoo, ebuild scheduled for merge) pulled in by
    <dev-libs/openssl-1.1:0= required by (dev-lang/ruby-2.3.8-r1:2.3/2.3::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^^                                                                                                                                                           

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.



come posso risolvere ??
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22301
Location: here

PostPosted: Tue Mar 12, 2019 6:05 pm    Post subject: Reply with quote

Ti ho gia' risposto nel forum principale.
Comunque ricapitolando devi disinstallare ruby23 che non puo' compilare con openssl-1.1 (sei in un sistema testing?), quindi controlla se e cosa hai settato in make.conf per la variabile RUBY_TARGETS e controlla che non ci siano abilitate use flags ruby_targets_ruby23 in package.use
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Tue Mar 12, 2019 6:25 pm    Post subject: Reply with quote

si sono in testing !
in make.conf non c'e` settato niente di ruby ...
ora ho disinstallato dev-lang/ruby.2.3.7
riprovo emerge
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22301
Location: here

PostPosted: Tue Mar 12, 2019 6:29 pm    Post subject: Reply with quote

Controlla che in package.use non ci sia qualche ruby_targets_ruby23 settato e se c'e' eliminalo. Poi dovresti ricompilare quei pacchetti con emerge -UD @world
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Tue Mar 12, 2019 6:36 pm    Post subject: Reply with quote

ora ottengo questo ... tralasciando l'errore vte che lo risolvo disinstallando termite .. cos'altro c'e` ?

Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.20.4:0/1.20.4::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-base/xorg-server-1.20.3:0/1.20.3::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.20.3= required by (x11-drivers/xf86-input-synaptics-1.9.1:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                               
    (and 1 more with the same problem)

x11-libs/vte:2.91

  (x11-libs/vte-0.54.1:2.91/2.91::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/vte-0.50.2:2.91 required by (x11-terms/gnome-terminal-3.26.2:0/0::dantrell-gnome-3-26, installed)
    ^^             ^^^^^^^^^^^                                                                                                                                                           

  (x11-libs/vte-0.48.4:2.91/2.91::eroen, installed) pulled in by
    >=x11-libs/vte-0.43.2:2.91[termite-patch(-)] required by (x11-terms/termite-13:0/0::eroen, installed)
                                                                                                                         

dev-python/cffi:0

  (dev-python/cffi-1.12.1:0/1.12.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-python/cffi-1.11.5:0/1.11.5::gentoo, installed) pulled in by
    >=dev-python/cffi-1.1.0:0/1.11.5=[python_targets_python2_7(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),python_targets_python3_6(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/cairocffi-0.9.0:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                                                                                                                                                                                                                                           

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22301
Location: here

PostPosted: Tue Mar 12, 2019 6:52 pm    Post subject: Reply with quote

A parte il problema con vte non mi sembra
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Tue Mar 12, 2019 7:04 pm    Post subject: Reply with quote

cosa intendi ??
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22301
Location: here

PostPosted: Tue Mar 12, 2019 7:46 pm    Post subject: Reply with quote

Che non mi sembra ci siano altri errori, mettendo a posto vte dovrebbe andare
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum