Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Pulseaudio 12.2-r1 fails setup phase during emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Scot-Irish
n00b
n00b


Joined: 26 Apr 2008
Posts: 8
Location: Rockville, MD, USA

PostPosted: Wed Apr 03, 2019 9:04 pm    Post subject: [Solved] Pulseaudio 12.2-r1 fails setup phase during emerge Reply with quote

Trying to emerge the new version of PulseAudio. It fails during the setup phase with Invalid Arguments (see below). Any thoughts? Thanks![/b]

Code:
>>> Emerging (1 of 1) media-sound/pulseaudio-12.2-r1::gentoo
 * pulseaudio-12.2.tar.xz BLAKE2B SHA512 size ;-) ...                                                                                  [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     4.14.83-gentoo
error writing group entry: Invalid argument
 * Adding group 'audio' to your system ...
error writing group entry: Invalid argument
 *  - Groupid: 18
groupadd: group 'audio' already exists
 * ERROR: media-sound/pulseaudio-12.2-r1::gentoo failed (setup phase):
 *   (no error message)
 *
 * Call stack:
 *                   ebuild.sh, line 124:  Called pkg_setup
 *   pulseaudio-12.2-r1.ebuild, line 143:  Called enewgroup 'audio' '18'
 *                 user.eclass, line 346:  Called die
 * The specific snippet of code:
 *              groupadd -r ${opts} "${egroup}" || die
 *
 * If you need support, post the output of `emerge --info '=media-sound/pulseaudio-12.2-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-sound/pulseaudio-12.2-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-sound/pulseaudio-12.2-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/pulseaudio-12.2-r1/temp/die.env'.
 * Working directory: '/var/tmp/portage/media-sound/pulseaudio-12.2-r1/homedir'
 * S: '/var/tmp/portage/media-sound/pulseaudio-12.2-r1/work/pulseaudio-12.2'


[Moderator edit: added [code] tags to preserve output layout. -Hu]


Last edited by Scot-Irish on Wed Apr 10, 2019 7:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22493
Location: here

PostPosted: Thu Apr 04, 2019 5:44 am    Post subject: Reply with quote

You can post grep audio /etc/group and grep :18: /etc/group command output?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Scot-Irish
n00b
n00b


Joined: 26 Apr 2008
Posts: 8
Location: Rockville, MD, USA

PostPosted: Wed Apr 10, 2019 7:47 pm    Post subject: [Solved] Pulseaudio 12.2-r1 fails setup phase during emerge Reply with quote

I solved this on my own by reverting the audio group back to its original form in /etc/group. Pulseaudio emerged properly at this stage. Sorry I didn't get back to this sooner. Thanks for your help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum