Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
unsupported locale setting [RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
aenigma
n00b
n00b


Joined: 02 Mar 2019
Posts: 60
Location: Italy

PostPosted: Sat Mar 02, 2019 8:34 am    Post subject: unsupported locale setting [RISOLTO] Reply with quote

Ciao a tutti, sono nuovo nel forum e sono riuscito, finalmente, ad installare la mitica Gentoo (MATE). Purtroppo è sorto un piccolo problema, cioè non mi da la lingua italiana o almeno in parte; il menù principale è in inglese (Application Places System) e i sottomenù sono in italiano avendo aggiunto in /etc/profile.d/lang.sh la stringa export LANG=it_IT
Lo stesso vale per la posta che è anche lei metà italiano e metà inglese. Il terminale prima di fare ogni operazione mi dice "unsupported locale setting". Grazie in anticipo per l'aiuto.
Ciao
_________________
Gentoo MATE


Last edited by aenigma on Sun Mar 03, 2019 4:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 682
Location: tra veneto e friuli (italy)

PostPosted: Sat Mar 02, 2019 8:41 am    Post subject: Reply with quote

In teoria c'è la guida ufficiale alla localizzazione sul wiki:
Localizzazione/Guida
Se non l'hai usata, ti conviene dargli un'occhiata: di solito risolve.
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
Massimog
Apprentice
Apprentice


Joined: 04 Nov 2011
Posts: 151
Location: Osimo(AN)

PostPosted: Sat Mar 02, 2019 1:43 pm    Post subject: Reply with quote

usa L10N="it" in /etc/portage/make.conf
Code:
$ eselect news read 13
2016-06-23-l10n-use_expand
  Title                     L10N USE_EXPAND variable replacing LINGUAS
  Author                    Mart Raudsepp <leio@gentoo.org>
  Author                    Ulrich Müller <ulm@gentoo.org>
  Posted                    2016-06-19
  Revision                  1

The L10N variable is replacing LINGUAS as a USE_EXPAND, to avoid a
conceptual clash with the standard gettext LINGUAS behaviour.

L10N controls which extra localization support will be installed.
This is commonly used for downloads of additional language packs.

If you have set LINGUAS in your make.conf, you most likely want to add
its entries also to L10N. Note that while the common two letter language
codes (like "de" or "fr") are identical, more complex entries have a
different syntax because L10N now uses IETF language tags. (For example,
"pt_BR" becomes "pt-BR" and "sr@latin" becomes "sr-Latn".) You can look
up the available codes in profiles/desc/l10n.desc in the gentoo tree.
A detailed description of language tags (aka BCP 47) can be found at:
https://www.w3.org/International/articles/language-tags/

After a transition time for packages to be converted, the LINGUAS
environment variable will maintain the standard gettext behaviour and
will work as expected with all package managers. It controls which
language translations are built and installed. An unset value means all
available, an empty value means none, and a value can be an unordered
list of gettext language codes, with or without country codes. Usually
two letter language codes suffice, but can be narrowed down by country
codes with a "ll_CC" formatting, where "ll" is the language code and
"CC" is the country code, e.g., "en_GB". Some rare languages also have
three letter language codes. Note that LINGUAS does not only affect
installed gettext catalog files (*.mo), but also lines of translations
in an always shipped file (e.g., *.desktop).

If you want English with a set LINGUAS, it is suggested to list it with
the desired country code, in case the default is not the usual "en_US".
It is also common to list "en" then, in case a package is natively
written in a different language, but does provide an English translation
for whichever country. A list of LINGUAS language codes is available at:
http://www.gnu.org/software/gettext/manual/gettext.html#Language-Codes

If you have per-package customizations of the LINGUAS USE_EXPAND, you
should also rename those. This typically means changing linguas_* to
l10n_*, and possibly updating the syntax as described above.

https://wiki.gentoo.org/wiki/Localization/Guide has also been updated to
reflect this change.

_________________
Distribuzione: Gentoo x86_64
Desktop: GNOME 3.30.2
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21334
Location: here

PostPosted: Sat Mar 02, 2019 2:14 pm    Post subject: Reply with quote

Mi resta solo da dire benvenuto in gentoo!
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
aenigma
n00b
n00b


Joined: 02 Mar 2019
Posts: 60
Location: Italy

PostPosted: Sat Mar 02, 2019 6:14 pm    Post subject: Reply with quote

Grazie per il benvenuto, ma abbiate un po' di pazienza se ogni tanto vi esaspererò; comunque... L10N è già impostato in italiano in /etc/portage/make.conf e non capisco perchè la lingua non cambia. Ho dato un'occhiata al manuale, ho fatto tutto quello che potevo ma resta tutto invariato.
_________________
Gentoo MATE
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21334
Location: here

PostPosted: Sat Mar 02, 2019 6:16 pm    Post subject: Reply with quote

Ok allora inizia con postare l'output dei comandi locale e locale -a cosi' vediamo se e' tutto a posto
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
aenigma
n00b
n00b


Joined: 02 Mar 2019
Posts: 60
Location: Italy

PostPosted: Sat Mar 02, 2019 6:22 pm    Post subject: Reply with quote

davide@gentoo ~ $ su
Password:
gentoo /home/davide # nano /etc/portage/make.conf
gentoo /home/davide # locale
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=it_IT
LC_CTYPE=it_IT.UTF-8
LC_NUMERIC="it_IT"
LC_TIME="it_IT"
LC_COLLATE=C
LC_MONETARY="it_IT"
LC_MESSAGES=C
LC_PAPER="it_IT"
LC_NAME="it_IT"
LC_ADDRESS="it_IT"
LC_TELEPHONE="it_IT"
LC_MEASUREMENT="it_IT"
LC_IDENTIFICATION="it_IT"
LC_ALL=
gentoo /home/davide #
_________________
Gentoo MATE
Back to top
View user's profile Send private message
aenigma
n00b
n00b


Joined: 02 Mar 2019
Posts: 60
Location: Italy

PostPosted: Sat Mar 02, 2019 6:24 pm    Post subject: Reply with quote

Password:
gentoo /home/davide # nano /etc/portage/make.conf
gentoo /home/davide # locale
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=it_IT
LC_CTYPE=it_IT.UTF-8
LC_NUMERIC="it_IT"
LC_TIME="it_IT"
LC_COLLATE=C
LC_MONETARY="it_IT"
LC_MESSAGES=C
LC_PAPER="it_IT"
LC_NAME="it_IT"
LC_ADDRESS="it_IT"
LC_TELEPHONE="it_IT"
LC_MEASUREMENT="it_IT"
LC_IDENTIFICATION="it_IT"
LC_ALL=
gentoo /home/davide # locale -a
C
POSIX
it_IT.utf8
gentoo /home/davide # clear

gentoo /home/davide # locale -a
C
POSIX
it_IT.utf8
gentoo /home/davide #
_________________
Gentoo MATE
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21334
Location: here

PostPosted: Sat Mar 02, 2019 6:36 pm    Post subject: Reply with quote

Non capisco perche' nelle variabili di locale hai solo it_IT e non it_IT.utf8
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 682
Location: tra veneto e friuli (italy)

PostPosted: Sat Mar 02, 2019 7:30 pm    Post subject: Reply with quote

Probabilmente perché ha impostato:
Quote:
e i sottomenù sono in italiano avendo aggiunto in /etc/profile.d/lang.sh la stringa export LANG=it_IT

Che non c'è nella guida.
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
aenigma
n00b
n00b


Joined: 02 Mar 2019
Posts: 60
Location: Italy

PostPosted: Sun Mar 03, 2019 10:23 am    Post subject: Reply with quote

Ciao gente, tutto a posto, ho eliminato la stringa che avevo aggiunto in /etc/profile.d/lang.sh ed ho seguito la guida rifacendo il settaggio di locale. Grazie per l'interessamento e a presto, ora mi godo Gentoo in italiano.
_________________
Gentoo MATE
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum