Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] i3 and urxvt - Delay when opening new terminals
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
pbd9
n00b
n00b


Joined: 28 Feb 2019
Posts: 2

PostPosted: Thu Feb 28, 2019 9:37 pm    Post subject: [SOLVED] i3 and urxvt - Delay when opening new terminals Reply with quote

Hey, I am a new Gentoo user. I am using i3 wm with urxvt terminal emulator. When I open a new terminal in i3 using alt+enter, there is a significant delay before the new terminal appears.
In my .Xresources file, I am setting the font using xft:
Code:
URxvt*font: xft:liberation mono:size=25

When I remove this line and set the font using XLFD:
Code:
URxvt.font: -*-liberation mono-*-r-*-*-25-*-*-*-*-*-iso8859-*

The delay disappears and new terminals open very quickly.
The letters on my screen appear jagged (no anti aliasing) when I set the font using XLFD. They appear smooth when I set the font using xft (yes anti aliasing). When I tried using kitty as my terminal emulator, I ran into the exact same delay problem when opening new terminals, but I did not try to fix it. I would like to find out how to get rid of the delay.


Last edited by pbd9 on Mon Mar 04, 2019 12:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
Makersmarx
n00b
n00b


Joined: 16 Feb 2019
Posts: 4
Location: Costa Rica

PostPosted: Fri Mar 01, 2019 12:32 pm    Post subject: Reply with quote

Do you have any blur or transparency going on? If so I assume you are using a compositor? Your XFT font setting appears correct, for reference mine is below and I have no issues. Also after any changes remember to xrdb ~/.Xresources which I am sure you know already.

***My Example
!Inconsolata
URxvt.font: xft:Inconsolata-14
URxvt.boldFont: xft:Inconsolata-14
URxvt.letterSpace: -1
_________________
Pura Vida
Back to top
View user's profile Send private message
kajzer
Guru
Guru


Joined: 27 Nov 2014
Posts: 368

PostPosted: Fri Mar 01, 2019 4:46 pm    Post subject: Reply with quote

Could be some USE flags not enabled.
Back to top
View user's profile Send private message
pbd9
n00b
n00b


Joined: 28 Feb 2019
Posts: 2

PostPosted: Fri Mar 01, 2019 6:09 pm    Post subject: Reply with quote

Quote:
Do you have any blur or transparency going on? If so I assume you are using a compositor? Your XFT font setting appears correct, for reference mine is below and I have no issues. Also after any changes remember to xrdb ~/.Xresources which I am sure you know already.

***My Example
!Inconsolata
URxvt.font: xft:Inconsolata-14
URxvt.boldFont: xft:Inconsolata-14
URxvt.letterSpace: -1

I have not set up a compositor yet, I plan to do that next. Do you think using a compositor help the issue?
Quote:
Could be some USE flags not enabled.

These are my USE flags for urxvt -
Code:

- - 256-color            : Enable 256 color support
 - - alt-font-width       : Calculate the font width using a different method
 - - blink                : Enable blinking text
 - - buffer-on-clear      : Store visible output to history buffer when clearing the
                            screen with ctrl-l. Read
                            https://bbs.archlinux.org/viewtopic.php?id=129302
 - - fading-colors        : Enable colors fading when off focus
 + + focused-urgency      : Enable the urgent flag when a terminal window is focused
 + + font-styles          : Enable support for bold and italic fonts
 - - iso14755             : Enable ISO-14755 support
 + + mousewheel           : Enable scrolling via mouse wheel or buttons 4 and 5
 + + perl                 : Enable perl script support. You can still disable this at
                            runtime with -pe ""
 - - pixbuf               : Enable transparency support using gtk's pixbuf
 - - secondary-wheel      : Support for wheel scrolling on secondary screens (like mutt).
                            Read http://lists.schmorp.de/pipermail/rxvt-unicode/2011q4/00
                            1491.html
 + + startup-notification : Enable application startup event feedback mechanism
 - - unicode3             : Use 21 instead of 16 bits to represent unicode characters
 + + vanilla              : Do not add extra patches which change default behaviour; DO
                            NOT USE THIS ON A GLOBAL SCALE as the severity of the meaning
                            changes drastically
 - - wcwidth              : Enable wide char width support
 + + xft                  : Build with support for XFT font renderer (x11-libs/libXft)

I just switched to using the urxvt daemon and that appears to get rid of the delay. If I can't figure out anything else in the next day then I guess I'll move on.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum