Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] kernel-4.19.23 & nvidia-drivers-390-116
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1145
Location: Eppingen, Germany

PostPosted: Thu Feb 28, 2019 9:22 am    Post subject: [gelöst] kernel-4.19.23 & nvidia-drivers-390-116 Reply with quote

Hallo....

bei mir passt mal wieder nichts auf Anhieb zusammen. Mit dem neuen Kernel habe ich auch nvidia-drivers heute upgedated. Das kernel-Update lief sauber durch, war ohne Probleme installiert und in grub2 konfiguriert. Allerdings wollen die nvidia-drivers seltsamerweise nicht und meckern über die fehlende .config und make-Datei.

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] x11-drivers/nvidia-drivers-390.116 [390.87]

Would you like to merge these packages? y

>>> Verifying ebuild manifests
>>> Running pre-merge checks for x11-drivers/nvidia-drivers-390.116
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Could not find a Makefile in the kernel source directory.
 * Please ensure that /usr/src/linux points to a complete set of Linux sources
 * Unable to calculate Linux Kernel version for build, attempting to use running version
 * Could not find a usable .config in the kernel source directory.
 * Please ensure that /usr/src/linux points to a configured set of Linux sources.
 * If you are using KBUILD_OUTPUT, please set the environment var so that
 * it points to the necessary object directory so that it might find .config.
 * ERROR: x11-drivers/nvidia-drivers-390.116::gentoo failed (pretend phase):
 *   Kernel not configured; no .config found in
 *
 * Call stack:
 *                       ebuild.sh, line 124:  Called pkg_pretend
 *   nvidia-drivers-390.116.ebuild, line 123:  Called nvidia_drivers_versions_check
 *   nvidia-drivers-390.116.ebuild, line 119:  Called check_extra_config
 *               linux-info.eclass, line 773:  Called require_configured_kernel
 *               linux-info.eclass, line 307:  Called die
 * The specific snippet of code:
 *              die "Kernel not configured; no .config found in ${KV_OUT_DIR}"
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/nvidia-drivers-390.116::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/nvidia-drivers-390.116::gentoo'`.
 * The complete build log is located at '/tmp/portage/x11-drivers/nvidia-drivers-390.116/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/x11-drivers/nvidia-drivers-390.116/temp/die.env'.
 * Working directory: '/tmp/portage/x11-drivers/nvidia-drivers-390.116/homedir'
 * S: '/tmp/portage/x11-drivers/nvidia-drivers-390.116/work/'

root@After8: Do Feb 28 10:09:20
/usr/src/ eselect kernel list
Available kernel symlink targets:
  [1]   linux-4.19.23-gentoo


Zumindest die .config kann ich sehen und öffnen. Da sind ca. 4.300 Zeilen drin - sieht für mich gut aus:
Code:

/usr/src/ ls -ali linux/
insgesamt 190840
 6292441 drwxr-xr-x 23 root root     4096 28. Feb 09:17 .
 5389713 drwxr-xr-x 16 root root     4096 20. Feb 21:01 ..
 6954160 drwxr-xr-x  4 root root     4096 24. Feb 16:41 arch
 6958316 drwxr-xr-x  3 root root     4096 24. Feb 16:41 block
 6315026 -rw-r--r--  1 root root  1071178 25. Nov 10:53 built-in.o
 6958417 drwxr-xr-x  2 root root     4096 24. Feb 16:41 certs
 6315016 -rw-r--r--  1 root root   112161 28. Feb 09:21 .config
 6958427 drwxr-xr-x  2 root root    12288 24. Feb 16:41 crypto
 6958588 drwxr-xr-x 63 root root     4096 24. Feb 16:41 drivers
 6958594 drwxr-xr-x  2 root root     4096 24. Feb 16:41 firmware
 6958597 drwxr-xr-x 25 root root    12288 24. Feb 16:41 fs
 7740845 drwxr-xr-x  4 root root     4096 24. Feb 16:41 include
 7742262 drwxr-xr-x  2 root root     4096 24. Feb 16:41 init
 7742396 drwxr-xr-x  2 root root     4096 24. Feb 16:41 ipc
 7871057 drwxr-xr-x 14 root root    12288 24. Feb 16:41 kernel
 9844446 drwxr-xr-x  6 root root    20480 24. Feb 16:41 lib
 6315020 -rw-r--r--  1 root root      548 25. Nov 10:33 .missing-syscalls.d
 9844840 drwxr-xr-x  2 root root    12288 24. Feb 16:41 mm
 6315120 -rw-r--r--  1 root root    16088 25. Nov 10:54 modules.builtin
 6315019 -rw-r--r--  1 root root      682 25. Nov 10:54 modules.order
 6315027 -rw-r--r--  1 root root   546295 25. Nov 10:54 Module.symvers
 9844957 drwxr-xr-x 20 root root     4096 24. Feb 16:41 net
10750254 drwxr-xr-x  7 root root     4096 24. Feb 16:41 scripts
11409939 drwxr-xr-x  5 root root     4096 24. Feb 16:41 security
11676719 drwxr-xr-x 22 root root     4096 24. Feb 16:41 sound
 6315035 -rw-r--r--  1 root root  3882640 25. Nov 10:53 System.map
 6315030 -rw-r--r--  1 root root   759416 25. Nov 10:53 .tmp_kallsyms1.o
 6315029 -rw-r--r--  1 root root  4541361 25. Nov 10:53 .tmp_kallsyms1.S
 6315033 -rw-r--r--  1 root root   759416 25. Nov 10:53 .tmp_kallsyms2.o
 6315032 -rw-r--r--  1 root root  4541361 25. Nov 10:53 .tmp_kallsyms2.S
 6315106 -rw-r--r--  1 root root  3882640 25. Nov 10:53 .tmp_System.map
 6426359 drwxr-xr-x  2 root root     4096 25. Nov 10:52 .tmp_versions
 6315028 -rwxr-xr-x  1 root root 51044872 25. Nov 10:53 .tmp_vmlinux1
 6315031 -rwxr-xr-x  1 root root 51044896 25. Nov 10:53 .tmp_vmlinux2
11676761 drwxr-xr-x  3 root root     4096 24. Feb 16:41 tools
11676763 drwxr-xr-x  2 root root     4096 24. Feb 16:41 usr
 6315015 -rw-r--r--  1 root root        2 25. Nov 10:53 .version
11676769 drwxr-xr-x  3 root root     4096 24. Feb 16:41 virt
 6315034 -rwxr-xr-x  1 root root 51044896 25. Nov 10:53 vmlinux
 6315021 -rw-r--r--  1 root root      124 25. Nov 10:53 .vmlinux.cmd
 6315022 -rw-r--r--  1 root root 44516440 25. Nov 10:53 vmlinux.o

Die make-Datei müsste ja auch da sein, da make && make modules_install && make install problemlos liefen....?????

Was habe ich übersehen?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org


Last edited by uhai on Thu Feb 28, 2019 7:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3574
Location: Germany

PostPosted: Thu Feb 28, 2019 3:29 pm    Post subject: Reply with quote

Hi uhai,
das Makefile ist Teil der installierten Linux-Sources (zb gentoo-sources).
Vermutlich zeigt dein /usr/src/linux Symlink auf ein (altes) Sources-Verzeichnis, die schon deinstalliert wurden (zb via --depclean).

Schau mal welche gentoo-sources Version installiert ist, und wohin der /usr/src/linux Symlink zeigt.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1145
Location: Eppingen, Germany

PostPosted: Thu Feb 28, 2019 5:28 pm    Post subject: Reply with quote

Der Symlink zeigt auf linux-4.19.23-gentoo. Ist ganz unten in der ersten "Code"-Liste....

Hat ja auch geklappt mit dem kernel-Backen - also muss das make-file ja da sein.

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3574
Location: Germany

PostPosted: Thu Feb 28, 2019 5:36 pm    Post subject: Reply with quote

uhai wrote:
Der Symlink zeigt auf linux-4.19.23-gentoo. Ist ganz unten in der ersten "Code"-Liste....

Ah ok sorry, die Ausgabe hatte ich übersehen.
Aber demnach ist der Symlink nicht gesetzt - da fehlt das Sternchen :)

Code:
eselect kernel set linux-4.19.23-gentoo
sollte den Symlink setzen.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1145
Location: Eppingen, Germany

PostPosted: Thu Feb 28, 2019 7:08 pm    Post subject: Reply with quote

:roll:

Stimmt, da fehlt das Sternchen.... :oops:

Da habe ich wohl auch etwas wesentliches übersehen....

Vielen herzlichen Dank, jetzt läufts.

Schönen Abend

Uwe
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum