Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst]Problem mit nvidia-drivers und gentoo-sources
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 205
Location: Wien

PostPosted: Sat Feb 23, 2019 12:37 pm    Post subject: [gelöst]Problem mit nvidia-drivers und gentoo-sources Reply with quote

Hallo,
möchte mein System auf die dzt. aktuellen sys-kernel/gentoo-sources 4.19.23 updaten, aber nachher will der Nvidia-Treiber nicht kompilieren
Code:
emerge nvidia-drivers
ergibt
Code:
Compile Error: emerge x11-drivers/nvidia-drivers-390.87
>>> Failed to emerge x11-drivers/nvidia-drivers-390.87
* Messages for package x11-drivers/nvidia-drivers-390.87:
 * Gentoo supports kernels which are supported by NVIDIA
 * which are limited to the following kernels:
 * <sys-kernel/gentoo-sources-4.19
 * <sys-kernel/vanilla-sources-4.19

Soll das bedeuten emerge nvidia-drivers
compiliert nur mit
sys-kernel/gentoo-sources-4.19
aber nicht mit
sys-kernel/gentoo-sources-4.19.23

Bitte um Hilfe


Last edited by oliver2104 on Wed Feb 27, 2019 11:40 am; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3650
Location: Germany

PostPosted: Sat Feb 23, 2019 3:17 pm    Post subject: Reply with quote

Hi,

nein, das bedeutet das die nvidia-drivers-390.87 Version (welche noch aus Zeiten stammt als es linux-4.19 noch nicht gab) nicht mit >=linux-4.19 (und auch 4.19.x) kompatibel ist.

Vorschlag:
Es ist grade vor ein paar tagen eine neue nvidia-drivers-390.116 Version released worden, die auch mit den neusten Kernelversionen kompatibel ist.
Die ist aber aktuell noch nicht stable markiert, sprich, die wirst du freischalten müssen:
Code:
emerge --sync
echo "x11-drivers/nvidia-drivers:0/390" >> /etc/portage/package.accept_keywords/nvidia
emerge -av1 ~nvidia-drivers-390.116
sollte kompatibel sein und funktionieren.
Back to top
View user's profile Send private message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 205
Location: Wien

PostPosted: Sun Feb 24, 2019 9:58 am    Post subject: Reply with quote

Hallo Josef.95
Vielen Dank für die Antwort !

Hab Deinen Vorschlag noch nicht ausprobiert, geh aber mal davon aus
dass, das auch so funktionieren würde.

Das Update auf linux-4.19 ist jetzt nicht dringend und ich möchte doch bei Stable bleiben.
Werde also noch zuwarten.

Aber:
Eine Inkompatiblität der aktuellen nvidia-drivers zu den aktuellen gentoo-sources
habe ich bisher noch nie erlebt.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3650
Location: Germany

PostPosted: Tue Feb 26, 2019 5:36 pm    Post subject: Reply with quote

Die neue kompatible nvidia-drivers-390.116 Version wurde heute stable markiert,
sprich ein demaskieren sollte nach einem frischen `emerge --sync` nun nicht mehr erforderlich sein.

Viel Erfolg :)
Back to top
View user's profile Send private message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 205
Location: Wien

PostPosted: Wed Feb 27, 2019 11:37 am    Post subject: Reply with quote

Nochmal Danke !
Es funktioniert
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum