Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
vnc connection problems using tigervnc
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
johan.lindgren
n00b
n00b


Joined: 17 Sep 2013
Posts: 5

PostPosted: Mon Feb 25, 2019 8:13 am    Post subject: vnc connection problems using tigervnc Reply with quote

I run the Guacamole desktop gateway on a virtual webserver (ubuntu) and from that I can connect to my desktop (gentoo). I have a quite sad internet connection (50/10mbit ADSL) and while I use vnc to my gentoo-box I frequently have connection problems, resetting my connection. If I move the mouse rapidly over the desktop it is mostly enough to reset my connection.

Still, the connection connects using vsock through nginx on the ubuntu-box and a nginx reverse proxy on my firewall over HTTPS.

Firstly I thought that the connection was reset since I was unable to lower the image quality (which worked better with tightvnc) but then I had to use one of my apps currently on my home primary display, so I ran x11vnc which then connects to a 3360x2560 display on default settings (the tigervnc which fails only run on 1024x1024 16bit) ..but I have still not encountered any failed connection when I use x11vnc!

What makes the tigervnc reset my connection so frequently since the traffic is obviously much lower?

I have yet to try rdp, but since x11vnc works then tigervnc should work... I think, right?

Is there any obvious protocol differences between tigervnc and x11vnc?
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7050
Location: almost Mile High in the USA

PostPosted: Mon Feb 25, 2019 8:39 am    Post subject: Reply with quote

Are you sure of what's actually resetting the connection? Sure it's not a router problem somewhere?

I have even sadder DSL (less than a QUARTER of your speed!) and still frequently VNC through a ssh tunnel to another machine (on FIOS) with fairly good results, though slow. I've also done loopback through the two and it also seems to work fine too, using tigervnc/x11vnc.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
johan.lindgren
n00b
n00b


Joined: 17 Sep 2013
Posts: 5

PostPosted: Mon Feb 25, 2019 10:04 am    Post subject: Reply with quote

I can't find anything strange in my router-logs really..

Here is a cut from the vnc logfile which complains from that the TLS session wasn't terminated gracefully.


Code:
Mon Feb 25 10:52:48 2019
 Connections: accepted: 172.16.8.14::57946
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type VeNCrypt(19)
 SVeNCrypt:   Client requests security type TLSVnc (258)
 
Mon Feb 25 10:52:50 2019
 VNCSConnST:  Server default pixel format depth 24 (32bpp) little-endian rgb888
 VNCSConnST:  Client pixel format depth 24 (32bpp) little-endian rgb888
 
Mon Feb 25 10:55:37 2019
 Connections: closed: 172.16.8.14::57946 (Clean disconnection)
 EncodeManager: Framebuffer updates: 1
 EncodeManager:   Tight:
 EncodeManager:     Solid: 4 rects, 1.31046 Mpixels
 EncodeManager:            64 B (1:81904.8 ratio)
 EncodeManager:     Bitmap RLE: 1 rects, 256 pixels
 EncodeManager:                 67 B (1:15.4627 ratio)
 EncodeManager:   Total: 5 rects, 1.31072 Mpixels
 EncodeManager:          131 B (1:40022.4 ratio)
 TLS:         TLS session wasn't terminated gracefully
 ComparingUpdateTracker: 0 pixels in / 0 pixels out
 ComparingUpdateTracker: (1:-nan ratio)
 
Mon Feb 25 10:58:04 2019
 Connections: accepted: 172.16.8.14::57950
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type VeNCrypt(19)
 SVeNCrypt:   Client requests security type TLSVnc (258)
 
Mon Feb 25 10:58:06 2019
 VNCSConnST:  Server default pixel format depth 24 (32bpp) little-endian rgb888
 VNCSConnST:  Client pixel format depth 24 (32bpp) little-endian rgb888
 
Mon Feb 25 10:58:07 2019
 Connections: closed: 172.16.8.14::57950 (Clean disconnection)
 EncodeManager: Framebuffer updates: 1
 EncodeManager:   Tight:
 EncodeManager:     Solid: 4 rects, 1.31046 Mpixels
 EncodeManager:            64 B (1:81904.8 ratio)
 EncodeManager:     Bitmap RLE: 1 rects, 256 pixels
 EncodeManager:                 67 B (1:15.4627 ratio)
 EncodeManager:   Total: 5 rects, 1.31072 Mpixels
 EncodeManager:          131 B (1:40022.4 ratio)
 TLS:         TLS session wasn't terminated gracefully
 ComparingUpdateTracker: 0 pixels in / 0 pixels out
 ComparingUpdateTracker: (1:-nan ratio)
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7050
Location: almost Mile High in the USA

PostPosted: Mon Feb 25, 2019 6:01 pm    Post subject: Reply with quote

That would imply that the network connection was severed if TLS wasn't terminated normally.

What network equipment and ISPs are being used here? What if you tried another ISP temporarily like a coffee shop?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
johan.lindgren
n00b
n00b


Joined: 17 Sep 2013
Posts: 5

PostPosted: Tue Feb 26, 2019 8:13 am    Post subject: Reply with quote

I have tested this from several networks, and the problem persists.

At home I have a 'adsl modem' forwarding transparently to my OPNSense router, which through a nginx reverse proxy forwards to a local ubuntu webserver also running nginx which has the Guacamole app online. From there I can connect using VNC or SSH to my machines. All machines at home run through gb-ethernet (no wifi).

Still, the x11vnc works perfectly, how is that possible?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum